8 Replies Latest reply: Sep 8, 2013 2:11 AM by Norrista
Norrista Level 1 (0 points)

Hi there,


I have a really urgent iMovie project I need to have completed by Monday, however I am having extreme difficulty importing my last video file for some reason. I am uploading footage from a SONY HD HANDYCAM (it says HDR-SR11) and I am using iMovie '09. Very confused as have always been able to upload footage from the camcorder - in fact did it yesterday with no troubles - but when I go to import this one clip (12mins), it goes through the process of 'importing', however no actual footage/ thumbnails is uploaded on the iMovie screen. I have selected to view 'All Clips' so that is not a problem. I have also deleted all events/projects and tried again but that one video still will not import.


When I go into Finder I can see the clips there except they cannot be opened although they are from the exact same camera as the rest. I have also tried on another Mac computer but with the same result. I cannot import to iPhoto, nor does it let me export using the free version of MPEG-2 converter.


I am using the camera to computer USB cable by the way.


I really, really appreciate any help or advice in advance, and apologise if this is a trivial problem but can't seem to find any answers in the hours I have spent on it, nor online.





  • Bengt Wärleby Level 6 (19,450 points)



    To me - very hard to guess


    a few thoughts though.


    • Free Space on the Start-Up Hard Disk. How Much ?


    • Did You try to trash the iMovie pref. and cache files - Do that - OR easier to see if this is the problem is to


    - Create a new User Account - Apple Menu and down to System pref. / Accounts - Plus Sign

    - Log out - Apple Menu down to bottom

    - Log into new account


    Now try iMovie Import from Camera - Does it work now ? then problems are in pref and cache files.


    Yours Bengt W

  • Karsten Schlüter Level 7 (31,915 points)

    Norrista wrote:

    … HDR-SR11…

    your device supports two recording standards …


    best to my knowledge, the SDef format is not supported by iM.

  • Norrista Level 1 (0 points)

    Hi Bengt W,


    Thank you so much for your imput. I have tried the option you said about creating a new account, however that did not change anything.


    In regards to your question about space - I assume I can just click Inspector on my iMac image - it says there are 7.94 GB free. And when I was 'importing' this video file into iMovie it said there was 2 hours 57 mins available which I thought would be fine as the clip is only 12 mins.


    I really appreciate any further advice you can give me because I'm coming to the deadline now and it isn't something I can just go out and shoot again unfortunately.


    And as a side note, I have tried selecting the Camera Archive option, but iMovie does not then allow me to import the files afterwards.


    Many thanks again,



  • Norrista Level 1 (0 points)

    Hi Karsten,


    Thanks also for your imput.


    That is correct - when my camera is connected to the computer there are two options for me to select ON the camera; one which looks like a small memory card thing and one that looks like a flattened cylinder. The 'memory card' one does not hold any video footage and I always select the 'cylinder' when I have imported previously.


    Thanks again,



  • Bengt Wärleby Level 6 (19,450 points)

    it says there are 7.94 GB free


    That makes me nervous as I try to never go less than 25GB (for interlaced SD-Quality - HD needs lot's more - say at least 4-5 times more to run OK)


    else - It's a situation un-familiar to me as I only use old miniDV tapes (interlaced SD-Quality)


    If You recorded in p50 or p60 - I think You can stop as iMovie can not use this - You need FinalCut Pro-X to use that.


    Yours Bengt W

  • Norrista Level 1 (0 points)

    Hi everyone,


    Just for future reference for anyone who has this problem - it has been solved (thank goodness!)


    I ended up ringing Apple and asking for their advice. The guy I spoke to said the file was likely corrupted seeing all other files were uploading. I'm not sure whether this was the case or not, but he said I should try to convert the file.


    So anyway, I came across Prism Video Converter (free) and put the file through that. It worked perfectly and came out really well. http://www.nchsoftware.com/prism/index.html


    Not sure why this happened but for anyone who has a problem with files like .MTS etc. I definitely recommend giving this a go.


    Cheers everyone!

  • quirinw Level 1 (0 points)

    Hi Norrista,


    I have a similar camera to you and have experienced the same problem, where some of my videos will import, however when I try this specific video, after "importing" it will tell me there was an error and it suggests that I Archive All my footage. After hearing that your problem was answered, I tried the same thing, (Prism Video Converter) however when I click "Add File" and select the clip from the device (which is plugged in through the USB), it will not appear on the "List of files to Convert".

    Am I going about this wrong (if so, advice would be appreciated) or is it simply just not working??

  • Norrista Level 1 (0 points)

    Hi quirinw,


    Sorry about the incredibly late reply, I have been away travelling.


    Has your problem been fixed yet? I didn't have the same problem when I used Prism and I am not a great computer expert, but if I can do anything to help I will try. Does your camera also have the option to select one of two options when connected via USB? If so, have you tried selecting the other one?


    Really sorry it didn't work for you though, I completely understand how frustrating it is!