2 Replies Latest reply: Apr 17, 2013 6:00 PM by BothFamily
BothFamily Level 1 Level 1 (0 points)

Hi,

 

I have an SSD and a HD in my iMac - I recently tried to relocate my home folders after upgrading my SSD & HD to newer/faster/larger ones.

 

Since the upgrade and subsequent reloading both by disk and from time machine, I cannot attach files in some programs especially Mail.

 

Basically everything works fine, except when I try and click on the attach button. Instead of the finder window opening up (or whatever that's called) - the computer will just sit there, and then in about 5 minutes the cursor just blinks again - like nothing happened.

 

I have tried searching, and have found nothing that helps. Closest I could find was a thread talking about repairing permissions - no luck. I have also repaired/verified the disks - with no change.

 

Programs like Photoshop or Dreamweaver, can open files just fine.

 

But Mail cannot attach files, and itunes is hit and miss on being able to open folders.

 

Any ideas?

 

Thanks in Advance.


iMac (27-inch Mid 2010), OS X Mountain Lion (10.8.3)
  • 1. Re: Crash/Failure when programs try to open/attach a file
    Eric Root Level 6 Level 6 (16,200 points)

    Mail:

     

    Write down all account information or take screen shots. You'll need to reenter the information later. Quit Mail. Hold down the option key while using the Finder "Go to Folder" command and type ~/Library/Containers/com.apple.mail. Move the entire container, not just the contents, to the desktop. Open Mail to see if it works. Reset all account information and test. If no change, put the container back. If Mail works properly, delete the container. You may/will lose some emails if you end up deleting the container.

     

    Do a backup, using either Time Machine or a cloning program, to ensure files/data can be recovered. Two backups are better than one.

     

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.

     

    Isolating an issue by using another user account

     

    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

     

    General information.

     

    Isolating issues in Mac OS X

     

    Troubleshooting Permission Issues

     

     

    Step by Step to Fix Your Mac

  • 2. Re: Crash/Failure when programs try to open/attach a file
    BothFamily Level 1 Level 1 (0 points)

    Thanks for the response.

     

    I tried moving the mail folder - and it wasn't the cause.

     

    I did confirm that it is only my account that is having issues though, my wife and my daughter's are both fine.

     

    It seems to be any program that uses the built in finder to attach files (including open and/or save them). I'm not sure that makes sense - but I'm not sure how else to describe it.

     

    I'm going to go thru the Safe Mode this coming weekend and see if I can figure out what may be causing it.

     

    Paul