Skip navigation

Calendar question - not syncing Gmail

342 Views 11 Replies Latest reply: Apr 9, 2013 7:11 AM by rockmyplimsoul RSS
etoile88 Calculating status...
Currently Being Moderated
Apr 8, 2013 11:04 AM

I recently created a new Gmail account. My old Gmail account is my Apple ID, so everything was synced to that. I have the Gmail app set up as my new email account now, but it will not sync the calendar. In settings, under Gmail, it shows the correct email, and calendars are turned "on." Why is it not finding my calendar updates though? Is it because my Apple ID is my old email? I've linked the two email accounts, shared calendars with both accounts, but it's still not working

 

Suggestions???

 

Thanks!

iPhone 4S
  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Apr 8, 2013 11:37 AM (in response to etoile88)

    GMail accounts must "Fetch*" information from the server, so there is a delay in seeing updates based on whatever you've set the Fetch interval to be -- every 15 minutes, 30 minutes, hourly, or manual.  Go into Settings for your mail accounts and tap on the "Fetch New Data" setting, what are your settings in the "Fetch" section?

     

    *The exception is if you set your GMail account up as an Exchange account, which is no longer possible for new installations after 1/31/13 since Google stopped supporting Active Sync.  Exchange setups used Push instead of Fetch, so changes were automatically received from the server as they occurred.

  • pdroth Level 5 Level 5 (4,830 points)
    Currently Being Moderated
    Apr 8, 2013 12:29 PM (in response to etoile88)

    It will fetch manually if you open the calendar app.   Leave it open for a few mins and it should start to populate.   It isn't necessarily instantaneous.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Apr 8, 2013 1:11 PM (in response to etoile88)

    etoile88 wrote:

     

    It's set with 'Push' on and scheduled to fetch data hourly.

    The "Push" setting you see does not apply to your GMail since it only supports Fetch.  The way you have it set, your account will retrieve any changes hourly, or shortly after you open a related app.

     

    Have you actually turned on your GMail Calendar?  Go to Settings/Mail, Contacts, Calendar and tap on your GMail account name.  Is Calender turned ON?

     

    If it is already ON, open your Calendar app and tap the "Calendars" button at the top-left corner.  If you have multiple Calendars, make sure your current GMail Calendar is selected.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Apr 8, 2013 3:42 PM (in response to etoile88)

    etoile88 wrote:

     

    Ah, so the problem is, under my calendar app itself, the Gmail account is listed as my OLD email. But, under settings, my Gmail account is listed as my NEW email (???).

    If you have the new GMail account set up, the Calendar app should be able to use it.  Try resetting your iPhone (press and hold the Home and Sleep/Wake buttons until the Apple logo appears).  Hopefully a reset will get it to recognize the new account.  If not, then you might need to restore the iPhone, but try the reset first.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Apr 8, 2013 6:22 PM (in response to etoile88)

    Somehow you must be missing a detail, there's no reason for the Calendar app to not see the GMail calendar if the GMail account has been created and Calendar setting is turned on.

     

    In re-reading your posts there are a few fishy things:

     

    1- Your Apple ID has no relation to this.  Even if your old GMail address is being used as your Apple ID that will have no effect on your Calendar.  The key question is, in Settings do you still have this old e-mail address set up as an account?  If so, delete this old GMail account from Settings/Mail if you're not using it.  Deleting this account will have no effect on your ability to buy things from the iTunes store.  You should only have the GMail account you're using entered into Settings/Mail.  Once you do that, make sure that Calendar is turned ON for this account, and make sure that this account is being used as the default Calendar account in Settings/Mail (in the Calendar section).

     

    2- In your first post you said "I have the Gmail app set up as my new email account now"  The GMail app is only for mail, it does not provide Calendar support, so if all you did was add the app and sign into your GMail account, that's why your Calendar is not updating.  If this is what's going on, you need to add your (new) GMail address as an account in Settings/Mail.  If you're sure that you did this, there is no reason for your Calendar app to not see the caldendar associated with this account.

     

    3- In your first post you said "I've linked the two email accounts, shared calendars with both accounts, but it's still not working"  I suppose you did this as part of your troubleshooting, but there should be no reason to link two GMail accounts to get your calendars to show up.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Apr 9, 2013 7:11 AM (in response to etoile88)

    Glad that you got it sorted out!  Yes, GMail can ignore dots but only for e-mail (from any source). For setting up an account for other purposes you have to enter it exactly as it was created.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.