Previous 1 2 Next 16 Replies Latest reply: May 5, 2014 6:09 PM by osullsean
VictorGo Level 1 Level 1 (0 points)

I have a new Macbook Pro Retina that I have been using for a few months. Everything is great except one really infuriating problem. The wifi drops constantly, every few minutes I will see the wifi icon start flashing like it's connecting to a network, it will reconnect no problem, but again, after a while it will just randomly disconnect itself. There are other devices on the network, like my iphone that never drops. I am wondering if there is a solution to this problem?

 

Also, I do have bluetooth turned off, I don't think there is any interference from that. I used to have a Macbook Air that did not have this problem. I upgraded from a 2010 Macbook Air to a 2012 Retina Pro, and that's when the problems started.


MacBook Pro with Retina display, OS X Mountain Lion (10.8.3)
  • ds store Level 7 Level 7 (30,315 points)

    Change your WiFi router to WPA2(AES) or WEP open (not encrypted) and if it's "hidden" or "invisible" undo that as it's not going to stop a hacker.

  • Baby Boomer (USofA) Level 9 Level 9 (56,470 points)

    Try the basics first:

       Change your router channel number.  Most times this works & is all you have to do.

     

    Disconnect & reconnect your modem.  unplug it for about 10 seconds.  Plug it back in.  Do the same for Apple’s routers.  Wait for everything to reboot.

     

    System Preferences>Network

    Click the Assist Me button.

    In the next window that pops up, click the Diagnostic button & do the necessary.

     

    Research Knowledge Base for network problems that pertain to the OS that is currently installed on your computer.   See these basic networking KB Articles:  http://support.apple.com/kb/HT1401 AirPort troubleshooting guide

     

    http://support.apple.com/kb/HT2712 Using network locations in Mac OS X

     

    Manually provided DNS server addresses are higher priority than DHCP's

     

    http://support.apple.com/kb/HT1714 Solutions for connecting to the Internet, setting up a small network, and troubleshooting

     

    ============================

     

    What to do when you can't connect to the Internet

     

    Also, run the Airport Utility app which is located inside the Utilities folder.

     

    =====================

     

    If using a  Linksys router, contact LinkSys Customer Support and/or post in their forums.

     

    If using Apple's Airport, please re-post over in one of the AirPort Forums.

     

     

     

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • ninodelmar Level 1 Level 1 (0 points)

    Hello, I bought a Macbook Pro Retina 2.7 and had nothing but issues with the WIFI dropping or not connecting at all. I took the first one back and was willing to give it another try. The same thing happened with the replacement laptop. I discovered the problem at least for me. I used Migration Manager and Time Machine to set up the laptops with my 2008 Macbook Pro so that I could have everything set up from my older laptop. This caused the issue with the Mountain Lion OSX even though my 2008 had been upgraded to Lion. I removed the Users after creating a new user but the problem persisted. I had to get the thunderbolt adapter which is $30 easy and use my ethernet  hook up. I erased the disk and had the new Macbook Pro Retina reset to factory specs. The wifi stated working properly now. I am unable to use migration manager from time machine as there is something that changes the connection settings but I can add my old files manually from Time Machine. So my new Macbook Pro Retina is working as normal now but am dissappointed that I could not back it up from my older Macbook.

  • VictorGo Level 1 Level 1 (0 points)

    Thanks for the replies, I unfortunately cannot change the channel or security on the network as it is my school's network. I believe it is set to either WPA or WPA2. The network is not hidden or anything. So it is really strange that my macbook would have this problem. There is someone with a Macbook Air in my class that works just fine, he's able to stream video perfectly, while if I try, I will get connection drops every 2-3 minutes. Sometimes it's as bad as every 30 seconds. Regardless, it is really frustrating!

     

    I still have no clue what is causing the problem. I have tried creating a new network location, or setting the MTU to a manual number. It still doesn't work. I also, am not using Time Machine.

  • Baby Boomer (USofA) Level 9 Level 9 (56,470 points)

    Results of the diagnostic test?

     

     

     

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • VictorGo Level 1 Level 1 (0 points)

    I will let you know once I get back to school on Monday. I'm not sure if it will do anything though. Because although it disconnects constantly, it will reconnect within 10 seconds. Not sure how long the diagnostic test will take, but I will give it a try.

  • VictorGo Level 1 Level 1 (0 points)

    Ok, so I press Diagnostics, click Continue with Wi-Fi selected, choose the network and click Continue again. The response I get is: This computer was unable to join the Wi-Fi Network you selected..."

     

    Which is weird...because I did diagnostics while I was actually connected to the network itself.

  • Baby Boomer (USofA) Level 9 Level 9 (56,470 points)

    Did you try all the solutions from the links I provided in my 1st reply to you? 

     

     

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • VictorGo Level 1 Level 1 (0 points)

    And what other solutions am I able to try? I believe I mentioned in an earlier post that this was for a school network.

  • Baby Boomer (USofA) Level 9 Level 9 (56,470 points)

    Click on all of the links.  Only you can determine from reading them if they apply to your type of situation.  Otherwise, how would you know if they will work or not?

     

    There is nothing more anyone here can do until you detail what worked & what did not work.  After that more knowledgeable users can chime in if you have any further questions.

     

     

    You are still under warranty.  Give AppleCare a call.  Let them deal w/it.

     

     

     

     

     

     

     

     

    2ue5vgy.gif

  • joetrumpet Level 1 Level 1 (0 points)

    I have the same exact problem.  Exactly.  I have a 15" 2.7 retina with 16gb and 512 gb ssd.  The wifi *****.  It drops a minimum of once every 15 minutes.  I have to turn the airport off and then turn it back on and it works fine.  If I switch over to win7 w/ boot camp I never have an issue.  I have two other mbp on my network, 2 iphones, 2 iPads, a host of other android devices, and an ESXi server with 15 VMs running.  I dont have the problem with ANY of the other devices or VMs.  Not one. 

     

    The funny thing is that it seems to be devices are that manufactured by cisco/linksys.  My main router is a Cisco SRP-541W.  I tried a WRT54G and had the problem.  But then when I switched to a netgear router, I had no issues at all.  Wired works fine through thunderbolt, and USB wirless work perfectly fine too.  LOL

     

    There are hundred if not thousnads of the same posts...You figure Apple would catch on and try to fix it.  Nope.

  • grobbins Level 1 Level 1 (0 points)

    If people are still having this problem, a solution is in the works. I've had the same problem several times a day since buying a 15" MBP retina over two months ago – until tonight. After 4 or 5 consecutive Genius Bar appointments, hauling in a Time Capsule and two Macbooks to reproduce the issue, I got a call this morning saying Apple was now acknowledging this issue and had a fix that works on about half of these machine. They were about to do a ~$700 hardware repair on my machine (which seemed odd to me), replacing my display/WiFi antennas and the BT/WiFi card. Instead, they went through a series of steps to clear out all settings related to WiFi AND BT. I'm sorry I don't have the complete details – they said it couldn't be shared with me – but it includes removing Keychain records that relate to wireless, removing registered BT devices and clearing out known WiFi networks, etc. While I'd noticed that disabling BT usually solved the problem, I hadn't thought of clearing out BT and Keychain settings. Since both wireless technologies are handled by the same card, it makes some sense. For me, it worked right away. I was told a system software update would be coming out soon (sounded like a week or two tops) that would incorporate this. But, in the meantime, I'd recommend going to your local Genius Bar and asking them to look it up.

    -Garth

    Carlsbad, CA

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    Hello VictorGo,

     

    Very bad issue indeed, a few days ago I experienced that on mine too. Although it just came one day, I had no issue with WiFi before. So I thought it was a software issue rather than an hardware issue.

     

    What I did was simple and now, I don't have issues anymore. I went to "settings/network" in the WiFi part, I deleted my saved networks, in my case it was networks from my Time Capsule 2.4GHz and 5GHz, I did the same in my keychain and in the iCloud Keychain as well. Then I turned off iCloud keychain on my devices in order to reset it (Mac, iPhone and iPad). Finally I connected from my Mac to the 5GHz network, I re-enabled iCloud Keychain from my Mac (that way it will send all my passwords from Mac), and I turned it back on on iPhone and iPad.

     

    Now, I don't have any issue about WiFi droping... I don't know exactly where the problem was. Maybe something about conflict from networks...

     

    I hope it will help! Otherwise go to an Apple Store, it can be an hardware issue...

     

    Have a nice day

  • Eric. Level 6 Level 6 (12,260 points)

    Might be the same issue in this thread: https://discussions.apple.com/message/23700197

     

    That said, for some, including me, it's a driver issue. The 10.9.2 update includes the updated driver, so if you haven't updated yet -- which you should anyway for security SSL fix -- then you should consider it.

Previous 1 2 Next