4 Replies Latest reply: Nov 13, 2013 8:59 AM by AMA man
DME2484 Level 1 Level 1

I have a MacBook that is about 5 years old. Latley, Airport has had trouble recognizing any wireless networks. Sometimes it works, and sometimes it doesn't. I know that there are networks available because other devices are connected. Recently it has stopped working all together. Has anyone else experienced the same problem and know how to fix?


MacBook, Mac OS X (10.5.8)
  • Mike Sombrio Level 6 Level 6

    Try resetting the SMC and PRAM

    MacBook Pro 

    Laptops with a battery you can remove 

    Shut down the computer.

    Disconnect the MagSafe power adapter from the computer, if it's connected.

    Remove the battery.

    Press and hold the power button for 5 seconds.

    Release the power button.

    Reconnect the battery and MagSafe power adapter.

    Press the power button to turn on the computer.

     

    Resetting NVRAM / PRAM

    Shut down your Mac.

    Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.

    Turn on the computer.

    Press and hold the Command-Option-P-R keys before the gray screen appears.

    Hold the keys down until the computer restarts and you hear the startup sound for the second time.

    Release the keys.

  • DME2484 Level 1 Level 1

    Thanks, Mike. I tried resetting the SMC and PRAM like you suggested, but it didn't fix the issue. Any other reccomendations? Thanks for your help!

  • Mike Sombrio Level 6 Level 6

    Try creating a new network location http://support.apple.com/kb/HT5289

  • AMA man Level 1 Level 1

    Hey Mike,

    Taking the battery out and resetting it fixed it for me.

    Thanks,

    d