12 Replies Latest reply: Jul 6, 2013 11:45 PM by stanfordbinet148
travisbarth Level 1 (0 points)

Hello,

 

Is there a way to keep the mouse cursor from derailing your intentions when hitting the command-tab combo to switch between applications?  When the mouse happens to be near the middle of the screen, my command-tab ends up going to some random app because it happened to be on the list where the mouse cursor was at that moment.  I drives me crazy when I'm in a hurry.

 

Is there a way to disable that functionality?

 

Getting into the habit of moving my mouse out of the way first is a very distant second (and just a work around) to the preferred solution.

 

Thanks!

 

-Travis


OS X Mountain Lion (10.8.2)
  • Eric Root Level 9 (50,202 points)

    It shouldn't be happening unless you are clicking on the mouse without realizing it.

  • travisbarth Level 1 (0 points)

    I wish that's how it worked ... unfortuantely, all that has to happen is for the mouse to be on one of the apps when you command-tab.  You don't have to click on it.

     

    So all of the time, I command tab to my previous app, but because the mouse just happens to be in the wrong place at the wrong time, I end up is a completely different app.

     

    I like your avatar ... I've had a few cats like that over the years.

     

    -t

  • Eric Root Level 9 (50,202 points)

    Mine doesn't do that when my cursor is there, but I'm using a trackpad. I hooked up my USB mouse and it didn't select anything either.

     

    I hope your tortys weren't as crazy as this one is.

  • travisbarth Level 1 (0 points)

    Hmmm.  It repros for me with either the USB mighty mouse, or the bluetooth Magic Mouse.  How odd.  I wish I could figure out how to disable it ... it's driving me nuts!  (I have to switch apps a lot.)

     

    Give her a scratch behind the ears for me.

  • Eric Root Level 9 (50,202 points)

    Roger the scratch.

     

    Some information here. The new account and Safe Mode are good ways to troubleshoot.

     

    Mouse Problems

     

    Isolating an issue by using another user account

     

    Safe Mode

     

    Safe Mode - About


  • Eric Root Level 9 (50,202 points)

    Also try deleting the mouse .plist in your user library.

     

    You need to look in your user Library/Preferences for the .plist. Hold down the option key while using the Finder "Go To Folder" command. Enter ~/Library/Preferences. Delete the .plist(s) for the mouse (there might be more than one).


    If you prefer to make your user library permanently visible, use the Terminal command found below.


    http://osxdaily.com/2011/07/04/show-library-directory-in-mac-os-x-lion/


    You might want to bookmark the command. I had to use it again after I installed 10.8.2. I have also been informed that if you drag the user library to Finder it will remain visible.

     

    Log out/in or restart and test.

     

    Ear scratch accomplished     

  • travisbarth Level 1 (0 points)

    Thanks for the info!

     

    The odd thing is that I really think this is a feature.  The bahavior is the same on my MBP, MBA, and iMac, all with the latest OS X.   If you hold the command key down and hit Tab to bring up the app switcher, then move your mouse across the apps in the list, whichever app the mouse cursor move over becomes the one that will become active if you let go of the Command key.

     

    Hello to the kitty for me,

     

    -t

  • Eric Root Level 9 (50,202 points)

    I think you are right about it being a feature. After doing some more experimenting on a MacBook Pro and an iMac, it seems to be a consistent behavior.

     

    I'll give her a kitty pet for you when she wakes up. She likes kitty pets.

  • commandtab Level 1 (0 points)

    Any updates? This anti-feature is very disturbing.

  • coredumperror Level 1 (0 points)

    I would also like to know if you guys ever came up with a solution to this. commandtab's use of the word "anti-feature" seems extremely approprirate for this awful UI design.

  • kevinfromglenpool Level 1 (0 points)

    I like the term "anti-feature" - this one annoys me daily.  Wouldn't mind the mouse interaction if I had to click to activate the app, but just because my mouse happened to hit an app when I let go of the Cmd key shouldn't cause me to switch to an unexpected app!

  • stanfordbinet148 Level 1 (0 points)

    Completely agree - probably THE single most annoying "feature" of OS X (at least in 10.7)

     

    I can not believe, there isn't an option to turn it off - so incredibly frustrating that you have to train your muscle memory to move your mouse-pointer out of the center of the screen before using this keyboard shortcut…

     

    …basically ruins the workflow of fast AND precise task-switching per shortcut.