13 Replies Latest reply: Jul 9, 2013 8:58 AM by lmadden
lmadden Level 1 Level 1 (0 points)

I am running running ARD 3.6.1 admin and connect to several macs remotely to send commands, deploy software, control/observe the machines, etc.

 

Most show up fine in my ARD console.  However, I have a few that show up with status 'Screensharing Available.'

 

I can observe and control, but nothing else.

 

I have deleted the object out of ARD and readded both via DNS name (short name and FQDN) and IP, same result.

 

Firewall is set to allow Remote Management in.

 

Remote Management is set with a local account and all the check boxes are checked.

 

Screen Sharing is not enabled.

 

The client is running Remote Desktop 3.6.2.

 

As far as I can find there is NO admin 3.6.2 available.

 

 

Any help is appreciated as this is extremely annoying.

 

Thanks,

 

Lisa


Mac Pro, OS X Mountain Lion (10.8.3)
  • varjak paw Level 10 Level 10 (169,820 points)

    You've confirmed on the problem clients that Remote Management is turned on in the Sharing system preferences and that the appropriate computer settings have been made?

  • lmadden Level 1 Level 1 (0 points)

    Morning,

     

    Yes.  I have no problem connecting remotely in control or observe mode.  What I cannot do is send UNIX commands, deploy software, copy files, pop up a message, run reports, or anything else other than control/observe.

     

    Have found other posts on the internet on this, but no fixes yet....

     

    Any help is appreciated.

     

    Lisa

  • varjak paw Level 10 Level 10 (169,820 points)

    Are the problem machines on the same subnet as the ones that work? If not, check the router/firewall to make sure that port 3283 is open to the appropriate subnet. It could be that 5900, the port used for control, is open but 3283 is not.

     

    Hope this helps.

  • lmadden Level 1 Level 1 (0 points)

    Hi again,

     

    I have two macs on same subnet.  One is fine, other is not.  However, I did a scan, and find port 3283 is indeed blocked on the affected machine!  Port 5900 is open.  Weird.  NO idea why, or how, it is blocked on this machine.

     

    Have a couple macs on other subnets that also say screensharing available.  Will scan those to see if that port is also blocked.

     

    Thanks,

     

    Lisa

  • varjak paw Level 10 Level 10 (169,820 points)

    Is the firewall active on that Mac? If so, try turning it off. If it claims it's off but the port still reports as blocked then there's probably a glitch (likely anyway if activating Remote Management and the appropriate settings doesn't open the port) that's keeping it running regardless. You may be able to get help for that problem in the appropriate Mac OS X forum.

     

    Regards.

  • lmadden Level 1 Level 1 (0 points)

    Turned off Firewall, same problem, so it's not the mac's firewall stopping it.

     

    Am wondering if the benchmark file I loaded has something in it that is causing this.....am looking at that next.

     

    Strange.

     

    Lisa

  • TeenTitan Level 4 Level 4 (2,410 points)

    Do you have remote login enabled on one of the effected clients?

     

    if so ahve you tried ssh into the client and jump start ARD?

     

    ie:

    1. open terminal
    2. ssh username@computerIP
    3. login
    4. send the command sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -restart -agent

     

    if still not working you could try:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -off

     

    fallowed by:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -restart -agent -privs -all

  • nomad_nyc Level 1 Level 1 (0 points)

    It would be nice if Apple resolved this issue. I have 600+ Macs and oftentimes I will see this on 30-40 machines at a time. The next day it'll be a different set of stations. As much as TeenTitan's method might work, it is not really an option to ssh to a large number of stations.

  • TeenTitan Level 4 Level 4 (2,410 points)

    If turning ARD off and back on fixes the issue perminantly for a client.

    you could in thory deploy the setting through ARD in mass.

  • nomad_nyc Level 1 Level 1 (0 points)

    "In theory" but in practice I would have to restart ARD and then send your command multiple times every day just to retain access to all my clients. This means that something is broken and I would bet it is the interaction of different versions of client and server.

  • lmadden Level 1 Level 1 (0 points)

    Hi all,

     

    I tried everything I could think of including the kickstart commands.  No joy.

     

    I could connect and observe and/or control via ARD, but not do anything else like deploy pkgs or send UNIX commands.

     

    Remote Login was also being squirly as I could change it to only allow these users, add a user, and as long as dialog box remained open, I could SSH in.  Once I closed the dialog box for Remote Login, however, and reopened it, it was still set to only these users, but NO users were listed, so no one could ssh in....

     

    I fixed both issues by wiping the mac and reloading the OS.  Not a real fix as still have no idea why both of these things no longer worked as they should, but somethings when a user is pacing and can't work at all because you have their mac, it is the most efficient thing to do.

     

    So far so good with the wipe and reload, so fingers are crossed.

     

    Lisa

  • TonyPlack Level 1 Level 1 (10 points)

    I tried the restart first, but was getting a Bind(): Address in Use.  This occurs because the user has a Thunderbolt display with an ethernet jack.  I don't get this message with the user when they are on WiFi because that is the address it was binding.

     

    It does seem as if ARD has a problem with machines which connect physically and wirelessly and the transistion between the two.

     

    One updated to this fix by TeanTitan.  The first command should be deactivate.  Like this:

     

     

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -deactivate -configure -access -off

     

     

    Then run the activate and it cleared the bind issue for me. 

     

     

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -restart -agent -privs -all

     


    Thank you for the post.

  • lmadden Level 1 Level 1 (0 points)

    I ssh'd into one of the "screensharing" computers and ran the kickstart commands to deactivate and activate ARD, and it worked.  Had to "fix" the space after the k in kickstart :-)   Also had to delete the object from ARD and re-add it, and it then showed up fine!

     

    However, two other macs with same "screensharing" issue, this did not work.  Not sure what is up there, so still investigating!!

     

    Both macs that did not work are on ethernet, btw.

     

     

    Lisa