3 Replies Latest reply: Apr 12, 2013 7:42 AM by Eustace Mendis
sufficientgrace19 Level 1 Level 1 (0 points)

I have a 2006 Macbook. I got Snow Lepord and updated it. I cant use iTunes because it says I need Mac os x 10.3 or later and when I go to dowload it it says i need the previous version. And when I get the previous version and try to dowload that it says the same thing... Any help? Same thing when I try to get iMovie.


MacBook