Previous 1 2 Next 21 Replies Latest reply: Jan 3, 2016 6:19 AM by Mr.347
SonicCat Level 1 (0 points)

This is happening everytime! I have downloaded so many copies running from 10.6.4 to 10.6.8. I installed 10.6.3 clean from disk i just purchased from the MAC store and had to go through the most ridiculous update procedure to get to 10.6.7. Now that i am finally at 10.6.7 i can't update to 10.6.8 without the "installation failed" message... yet again! I am to say the least, at my wits end. What should be simple, is absolutely not, and nothing from Apple to inform people upgrading the path they need to take. How do i get from 10.6.7 to 10.6.8? Re-download 10.6.8 for the fourth time?


MacBook Pro, Mac OS X (10.6.7)
  • Mark Jalbert Level 5 (4,630 points)

    Why not try the Software Update application?

  • SonicCat Level 1 (0 points)

    hi, the software update application was the first thing i attempted, and it failed, but it also removed my 4.4g download, so i've been downloading every single update manually from 10.6.3 and running it. Now at 10.6.7 i am once again getting the error message. I have repaired authorisations, done safe boot, tapped my heals, whistled a tune, what next? Is it an issue with core duo intel mac or what? Because there is no indication what is going wrong for them to fail every single time.

  • ds store Level 7 (30,325 points)

    Must be what you installed 10.6.3 with and where or something  is wrong with your Internet connection.

     

    10.6 should install without a issue and then Software Updating is a breeze, just run it over and over until it's got no more.

     

     

    I suspect your drive is damaged or failing.

     

    Hold c and boot from the 10.6 disk and use Disk Utility to select the ENTIRE drive and Erase with Security option Zero All Data, when that's complete install OS X again and reboot, setup and run Software update on a decent Internet connection.

     

    Install/upgrade RAM or storage drive in Mac's

     

    How to erase and install Snow Leopard 10.6

     

    For Snow Leopard Speed Freaks

     

    https://discussions.apple.com/community/notebooks/macbook_pro?view=documents

  • Lanny Level 5 (6,944 points)

    Just download and run the 10.6.8 Combo updater: http://support.apple.com/kb/DL1399

  • Mark Jalbert Level 5 (4,630 points)

    The Installer.app does verbose logging. You can access the install.log with the Console.app. Even with a suscessful install, the install.log may contain many "error" messages.

     

    You may be missing some key updates if you have been manually installing the delta updates. Try downloading the 10.6.8 Combo updater as Lanny suggest. Before installing the update check the SHA 1 digest: http://support.apple.com/kb/HT1652 . This would indicate that your internet conection is OK if the digest matches.

     

    If the update fails then I recommend you take your MacBook pro to the Apple Store or an authorized dealer and have them look at it.

  • SonicCat Level 1 (0 points)

    After much hair pulling, the upgrade/update procedure for me was this;

     

    Starting from 10.5.8, installed 10.6.3. Experienced all manner of permission problems, so,

    10.6.3 clean install from disk. Attempted a 10.6.8 install (software update & manual dl/ both failed)

     

    manually dl'd and installed the following combos;

    10.6.4 --> .5 ---> .6 ---> .7

     

    installed 10.6.7 software installer fix, then

     

    10.6.8 installed, but not the combo.

     

    Thankfully upgrading to 10.8 was straight forward. Now after a week for getting one machine up to scratch I can get some work done. I am not at all happy with many aspects of this process, let alone the resources consumed having to do much of this by trial and error.

  • Lanny Level 5 (6,944 points)

    You should have done the 10.6.8 Combo from the start. The Combo means that you wouldn't have had to do all of the incrementals.

  • SonicCat Level 1 (0 points)

    "Attempted a 10.6.8 install (software update & manual dl/ both failed)"

     

    that simply means that yes I did attempt the 10.6.8 combo, first using the Software update function and then attempting a manual install.

  • Lanny Level 5 (6,944 points)

    My guess is that you mistakenly downloaded the 10.6.8 incremental update the first time, in lieu of the Combo. I've never heard of the Combo not working the first time.

  • dejswa Level 1 (0 points)

    Same problem.  My software info says "10.6" - no third digit.

     

    macosxupdcombo10.6.8.dmg - about a GB downloaded

     

    Says "Installation failed - contact software manufacturer".  Nice! I would have expected something just a bit more explanatory when installing an Apple OS update onto an Apple OS.

     

    BTW, my goal is to get to 10.8, but I understand I have to get to 10.6.8 first.

  • Mark Jalbert Level 5 (4,630 points)

    Link- http://support.apple.com/kb/DL1399

     

    Note: The size of the combo updater is 1.09G. Use the instruction that I posted and check the SHA-1 digest.

  • dejswa Level 1 (0 points)

    Thanks for the info, Mark.  Downloading now, will update.  It has the same name as the one I tried that did not work.  And . . . just checked and the one that did not work was also 1.09GB

  • andyBall_uk Level 7 (20,490 points)

    If Apple Menu - About This Mac says 10.6, w/o a, the update miight likely fail due to scripts within it which check the system version.

     

    So if the new download fails too - has /System/Library/CoreServices/SystemVersion.plist been modified ? you should be able to drag it onto textedit & see if the ProductVersion section has been altered.

  • craftkringle Level 1 (0 points)

    I was having the same problem. I tried every trick but what seemed to finally fix was in your guide. I was going to check the SHA 1 when I read you could use https for better error checking. Downloading the combo update from the https site rather than the http site did the trick. https://support.apple.com/kb/dl1399 instead of http://support.apple.com/kb/dl1399

     

    It seemed to download a different package and it worked first try. Definitly strange.

Previous 1 2 Next