3 Replies Latest reply: Apr 12, 2013 11:03 AM by Jerry Dammers
Jerry Dammers Level 1 (0 points)

I have Home Sharing switched on within the Music settings.


However when I open Music, I only get the music that I sync to the iPad, rather than my whole music library (iTunes is open on my computer when I try it).


How do I access my whole iTunes library via Home Sharing?

  • JimHdk Level 7 (28,320 points)

    You should be able to access your whole iTunes music library. Of course, Home Sharing has to be turned on in iTunes (File > Home Sharing) and iTunes must be running.


    On the iPad, as you say, Settings Music > Home Sharing must be Set up.


    If all this is good you should be able to access Home Sharing by touching the More button at the bottom of the iPad Music screen. This should bring up a selection with Shared as one of the choices. Touching Shared gives you the choice of My iPad or <your name> Library. Touch <your name> Library and the Music App should show (slowly perhaps) everything in your shared Music Library.


    Where is this going wrong?

  • Jerry Dammers Level 1 (0 points)

    All is fine until I select "More" within Music. The only options that I get are:




    Sort by Artist


    But no sign of "Shared".


    The problem is actually the same on my iPhone. I do recall once successfully setting up Home Sharing on my opine but now I have the same issue as my iPad.

  • Jerry Dammers Level 1 (0 points)

    I've worked this out now and got it to work.


    It was either:


    1) An old Apple ID password was stored in the Home Sharing settings, or

    2) The Apple IDs weren't exactly the same on my computer and the devices (I have one Apple ID but 2 email addresses that work on it - one hotmail and one icloud).


    Either way it's now working!


    Is it also possible to have Home Sharing for photos via iPhoto or Aperture?