5 Replies Latest reply: Sep 5, 2013 4:46 PM by kjmcfall
NoiD™ Level 1 Level 1 (0 points)

iPhone and iPad are not finding printer when using "AirPrint" option. My printer is an Epson XP-400. It was highly rated here at Apple's Site.  Keep getting message "No air print printer found" any time I try to print anythything off my iOS 6.1.3 devices. I can use iCloud, epson connect and email printing, So I know I'm getting wifi, infact the test page said "excellent" for reception. So I Downloaded new Epson firmware. Still the same problem I have never fought any printer as bad as this! Here's the response from Epson:

 

Dear Max,

 

Thank you for contacting Epson regarding your Epson XP-400.

 

I'm sorry for the frustration. If there is no new firmware found, this shows you have the newest firmware already on your printer and your AirPrint issue is not Epson firmware related.

We can only recommend Apple's support site for troubleshooting as there are no steps or settings on the printer itself to allow or disable Apple AirPrint.

 

We take your satisfaction seriously and hope that we have helped resolve your issue. If you receive a survey from us, we would greatly appreciate if you could take a few minutes to provide us with feedback about your support experience. Your ratings and comments are extremely important to us.

 

If this did not resolve your issue, please reply to this email for further assistance. If you have a different support issue, submit a request via our U.S. or Canada Support Site and we will respond in a timely manner.

 

Thank you again for contacting Epson.

 

 

So that's why I'm here, please help, Thanks!

 

Max


iPhone 4S, iOS 6.1.3
  • wjosten Level 10 Level 10 (93,825 points)

    Go through this troubleshooting assistant:

     

    http://www.apple.com/support/iphone/assistant/airprint/

  • Coorzman Level 1 Level 1 (10 points)

    I had the same issue.  BTW, that troubleshooting assistant is worthless.  I did 2 things to get it working.  I'm not sure if one or the other fixed it or it was combination of both.  I had the "No Air Printers Found" and did the usual rebooting everything, firmware updates, etc.  I could print and scan from the epson app fine.  I downloaded the epson airprint app from the app store (It's called Epson Printer Finder) and verified my settings under the Airprint section and choose to save the settings.  I didn't change anything, just looked at the settings.  I also setup the epson connect feature on the printer.  After I did both of those I went into mail and tried to print an email message and all of a sudden I could see my printer.  It's worked perfect since then.  I hope this helps someone.

  • Bubba_jr Level 1 Level 1 (0 points)

    Kudos to Coorzman.   I had exactly the same problem with iPad mini iOS 6.1.3 and Epson Workforce 845 and the Epson Printer Finder suggestion did the trick!  I agree that the troubleshooting assistant is worthless, especially in this case where I was already able to print fine from my iPhone 5 to that same printer.

  • djmapplefan Level 1 Level 1 (0 points)

    Had the same problem with my epson workforce845 and ipad mini which is connected to my airport express by ethernet.  Wifi connection kept resulting in message that airprinter wasn't found.  I powered off the printer and turned it back on and it worked.  Interestingly enough, I did that while on with applecare, when he returned I told him I fixed it and there was a known problem, he said he just learned that.  Either way, it's working now!!!!.  Hope that works for you too. 

     

    By the way, all other iphones and ipad worked and found the airport printer previously and were not having issues.  All devices are now working with airprint.

  • kjmcfall Level 1 Level 1 (0 points)

    I have had the same issue with an Epson XP-400.  I ave solved this by enabling uPnP on my wireless accesspoint/router.

    It looks like AirPrint uses uPnP as some kind of discovery protocol.  Hope this helps others out too.