7 Replies Latest reply: Apr 14, 2013 7:38 PM by randers4
sfurey Level 1 Level 1 (0 points)

I've set up icloud on my iphone and my pc at home but i can't see any of my contacts when I view using icloud from my home pc


I've used the general trouble shooting guide and everything looks like its set up ok, all my contacts are there in my phone and I did the back up also


Any idea's on this?

iPhone 5, Windows 7
  • randers4 Level 9 Level 9 (62,675 points)

    Are your contacts on icloud.com when you check from your computer?

  • sfurey Level 1 Level 1 (0 points)

    no, thats the problem I'm having, wanted to have a secure source of backup from my phone but no luck yet

  • randers4 Level 9 Level 9 (62,675 points)

    Open contacts on your phone and tap Groups.  Reply back with the names of all your groups, including the names of any headings.  (If a heading contains personal information, such as your email address or ID, don't post the actual heading.  Just post a fictitious heading like xxx@icloud.com.)

  • sfurey Level 1 Level 1 (0 points)

    not sure what you mean by "reply back" ?


    when I tap groups it brings up a screen that says such as


    Show all contacts

    Exchange active sync

    exchange active sync global



  • randers4 Level 9 Level 9 (62,675 points)

    I meant to reply to the discussion, just as you did.


    I believe your problem is that your contacts are being synced from one or more exchange accounts.  iCloud will only sync contacts that belong to the iCloud group/account.  It won't sync your exchange contacts.  If you want to sync these with iCloud you will have to copy them to your iCloud account.  I can help you do this is you want.


    If you are only syncing contacts with iCloud in order to have a backup, rather than to sync them to other devices, I can also suggest a backup program that will accomplish this without using iCloud, if interested.

  • sfurey Level 1 Level 1 (0 points)



    the contacts I have on my phone are from my work email account, do you think thats the reason it doesn't see them?


    how would I copy them to my icloud account?


    I realize that it won't update automatically but at least I'll some sort of a copy if needed



  • randers4 Level 9 Level 9 (62,675 points)

    Yes I believe that's why you don't see them.  You can prove this by tapping the work email groups so they are unchecked (so only iCloud is checked), then tap Done.  If you don't see any contacts, it means that they all belong to your work account.


    To copy them to iCloud, you would do the following:


    1. Go to Settings>Mail,Contacts,Calendars>Default Account (in the Contacts section) and select iCloud as your default account.
    2. Download the app My Contacts Backup from the App store on your phone.  (You will need the "Pro" version if you have 500 or more contacts).
    3. Use the app to back up your contacts as an attachment to an email.  Send this email to yourself.
    4. After receiving the email, open it on your phone and tap the attachment to re-import them to your phone.  They will be imported to iCloud as you have selected that as your default in step 1.
    5. Check icloud.com to confirm that they are there.
    6. You will see duplicates on your phone since you have copies of your contacts in your exchange account groups and your icloud group.  You can hide the duplicates from view by opening contacts, tapping Groups, then tap to uncheck either your exchange groups or your icloud group, then tap Done.
    7. If you want new contacts created on your phone to be added to your exchange account rather than your iCloud account, go back to Settings>Mail,Contacts,Calendars>Default Account (in the contacts section) and change it back to your exchange account again.  If you want new contacts to be created in iCloud, just leave your settings as they are.


    You should now have a copy of your contacts in your iCloud account (visable on icloud.com).  You can also use the app to back up your contacts at any time and save the attachment on your computer as a backup.