Previous 1 2 3 4 Next 103 Replies Latest reply: Aug 19, 2014 7:43 AM by Warboat Go to original post Branched to a new discussion.
  • Selda-istanbul Level 1 (0 points)

    I have tried :

    1. Verify that airplane mode is off by tapping Settings > Airplane Mode.
    2. Reset the network settings by tapping Settings > General > Reset > Reset Network Settings.
      Note: This will reset all network settings, including Bluetooth pairing records, Wi-Fi passwords, VPN, and APN settings

    It did not work.



    Turned on "celluler data and 3G" and fallowed again

    Settings > General > Reset > Reset Network Settings


    It worked Wi-fi is enable on my IPhone 4S

  • skinally Level 1 (0 points)

    I have had this problem not being able to turn on wifi for a while now and last night I restored my phone to factory settings, reset network settings, rebooted a number of times.

    I did thie freezer thing last night and it totally worked, but today it's not working again.


    Please can someone help me it's doing my head in.

  • Digital Cat II Level 1 (0 points)

    I needed to go apple store, none of these did not work with my phone. They changed my phone to new 4S, my phone was used only about 6 month. So it still had a warranty left.

  • ChuckB02 Level 1 (0 points)

    I'm having this same problem as of yesterday.  So far none of the electronic resets have worked. 

  • bravokilo Level 1 (0 points)

    I updated to iOS 6.1.3 on my iPhone 4S. I have had this replacement phone from Apple since January (they replaced my phone the first time when they found a crack in my LCD screen).

    I have tried everything:

    - Reset Network Settings

    - Soft Reset

    - Hard Reset

    - Restore Phone x 3

    - Placed the phone in the freezer for 15 min (Allowed the Wifi button to turn on, but unable to connect to my router).


    I just took my phone to Apple today and they thought that restoring the phone 3 times would help reset everything to no avail. According to the Apple "Genius," the reason why the phone's wifi capabilities do not work is because the iOS 6.1.3 update was not compatible with some iPhone 4S users. The tech specifically said "it shorted out something in the phone" and that there is nothing else they can do but replace the phone. Since my service warranty has ended, I have to pay $199 for another replacement phone. This is ridiculous!!!


    This was Apple's official update on an Apple product. It is Apple's fault that my phone lost Wifi capabilities, but I have to pay for a replacement because they messed up? I have been a loyal Apple user for many years. Apple needs to stand behind their products and customers. I'm always bragging about how great Apple is, but this has been a great disappointment.

  • tuts69 Level 1 (0 points)

    Thanks Lawrence its work for me like a magic, Try everything five times use restore wont work, then try this step "below" Voila! Wifi back to normal many thanks to you Sir, Keep up the good my $$$

    Lawrence Finch wrote:


    Most likely it's a hardware failure if it's both WiFi and BlueTooth. There are some strange suggestions to try; if these don't work take it to an Apple store for exchange. If it's out of warranty it will cost $199.


    • Turn off Cellular Data, reboot the phone. try to turn on WiFi.
    • Put it in a ziplock bag with the air squeezed out, then in a freezer for 15 minutes (yes, this is not a joke).
    • The opposite: Heat it with a hair dryer for a couple of minutes.


    All of these have worked for someone, but not for most.

  • jan1960 Level 1 (0 points)

    Thankyou for this piece of info, I first tried restoring after backup, but it still wouldn't work, so I thought I would try the freezer trick and hey presto it worked. this really does work so anyone having problems should try this before giving up.

  • Shakesx2 Level 1 (0 points)

    I certify that i am of sound mind and have a normal baseline.  The "freezer trick" did work for the "WiFi switch greyed out" problem.  I put it in a ziplock then in the freezer for 15 minutes.  Presto!!  I have now hacked my home network with my 4S (four-substandard).


    Thanks to all.

  • jmc606 Level 1 (0 points)


    Any news since your last post?  I have the same problem with my 4S, and after trying "everything" I had an appointment at the Apple Store... tech determined that the phone wasn't repairable (hardware issue), and that a replacement would cost me $199.  (Worse, almost: the replacement would be a 4S, not a 5).  Any resolution on your end? 



  • bravokilo Level 1 (0 points)

    Unfortunately, there was no other solution for me but to fork out $199 for a replacement 4S. Had I accepted a partial upgrade? I would still have a partial functional 4S and a more expensive iPhone 5, therefore I can wait a few months for my official upgrade date. Although, I am still eligible for an upgrade when my contract with AT&T ends in a few months. The phone would still work without WiFi and BlueTooth, but it's just an inconvenience.

  • tuts69 Level 1 (0 points)

    Well mine still work since i try the step from Lawrence Finch, the only thing i notice my wifi lil bit hard to catch signal, Like Lawrence said "its worked for someone but not for most" thanks and goodluck

  • hortensiaferrer Level 1 (0 points)

    wifi grayed out for weeks!!! It came back a couple of weeks and then again it turned gray for weeks!!!! I already did alll this about resetting network settings, turn it on and off, reset Iphone , everything and it's Not working!!!! Apple needs to fix this bug once and for all!!!!

  • Jaymcfay Level 1 (0 points)

    I Think you're spot on there pat4s. it happened to my mother and she ordered a new 4s under warranty, now it's happening on her second phone (running IOS 6.1.3). I haven't yet updated my 4s (don't think I'm too keen on the idea) and I'm running great on the same network

  • Shakesx2 Level 1 (0 points)

    Well i am back.  No longer of sound mind.  After the freezer trick, the wifi stayed on for a while (couple of days).  Then i when out for the evening, when i came back it had dis connected from my router.  I went in to settings and the wifi switch was not greyed out but it would not pick up on any routers near by including mine.  Then after a re-boot the switch was greyed out again!!


    Back in the freezer it went.  Over the nexy day or so the process took place again.


    Seems like a "open" in a circuit somewhere.


    My mental baseline is dropping quickly!!  Please help!!


    4S  (four-substandard)

  • GenaYosh Level 1 (0 points)

    UGH!!!  I had this same problem with my 4s.  I restored my phone to factory settings, etc. and nothing.  I ended up taking it back to the Apple store (over an hour away) and they replaced it for me.  Now that phone  just a few days later did the same thing!!  I have sent the phone in to be replaced AGAIN and am waiting for it to come back to me - probably next week.  This is ridiculous.  It is obviously not an isolated incident.

Previous 1 2 3 4 Next