7 Replies Latest reply: Apr 24, 2013 3:42 PM by Sam Beaver
Sam Beaver Level 1 Level 1 (120 points)

Hi, I haven't been able to print on a network printer from the macintosh for the past five years or so.

I have gone through a couple of PC computers that I use dedicated for printing. today, the PC crapped out, so came back into trying to fix the issue. an annual event or so.

I found this link:

https://discussions.apple.com/message/6873260?messageID=6873260&tstart=0#6873260 ?messageID=6873260&tstart=0

and by typing in the network path name (main server/server/printer) to the printer, I got it to almost print. it woke up the printer, but said it had an error and would not print.


anyway, tried in 10.5. 10.6. 10.7 and 10.8, so i figure the problem is the same for anyone else on a windows server network.

haven't quite figured out what is wrong.


'm close to getting this to work.


is there a third party permanent fix for this, or do i have to type in paths, usersnames, and passwords when ever I try to print?

iMac, Mac OS X (10.5.8), macpro, macbook, ipad, iphone, ect.
  • Sam Beaver Level 1 Level 1 (120 points)

    why is there any security for printing in the first place? this is just stupid.

  • Sam Beaver Level 1 Level 1 (120 points)

    ok, so print server permanently down. fresh print server in place. got it running on windows7, no problems. tried every option on the canon website to get the macside working, I finally got leopard running with a version 1 driver, but no options, no features, no good.

    when trying with some 10.5 drivers, i get the client-error not possible message pop up in a que.

    when trying with some 10.5 drivers, loads, but does not respond, force-quit.

    had canon tech crew out, but they didnt have any better luck than I.

    local IT staff has fear of anything mac

    called canon support, but they are not mac inclined either.

    I have the work center installed macside, and works fine for reprinting PC sent jobs.

    so far as I can tell, I have every PPD in correct position when I use other for driver source.


    If anyone in the macintosh community has had success installing print drivers for an iR-advanced 9075 or the IR8095 series using leopard, please respond.


    Macpro, 32 GB RAM, OS10.5.8

  • Alberto Ravasio Level 4 Level 4 (3,700 points)

    I think those printers have PostScript installed.


    Get Latest Canon Drivers

    Copy the Folder "iR-ADV C9065_9075" that you find inside the PPD_V3.40_MAC.dmg in your Document folder.

    You must have the printer's IP address at hand.


    Add printer using IP not the Default Browser.


    Fill in the IP address, choose HP Jetdirect - Socket, leave the Queue empty, Give a name, and position (Optional).

    In Use select Others, browse to your Document/iR-ADV C9065_9075 folder and choose the PPD.

  • Sam Beaver Level 1 Level 1 (120 points)

    Thanks, the HP socket didnt get any better results than the IP address or browse. got bonjour to recognize the printer special features, but didnt print. into my own print server gx300 now.

  • Sam Beaver Level 1 Level 1 (120 points)

    personally, I don't think it is possible to print from a macintosh. I have never seen it done anyway. in the 1990's, in a completely mac environment, we had a PC to use for printing. same still.

    Thank god for windows, i hate this stupid computer.

  • Alberto Ravasio Level 4 Level 4 (3,700 points)

    Very strange. If the printer is PostScript capable, any computer, Macintosh included, can print, even using generic PostScript drivers.

    Could be a problem involving the TCP port.


    • HP Jetdirect - Socket uses TCP port 9100
    • LPR/LPD user TCP port 515


    But the printer must have those daemons enabled to be able to receive requests.


    You should check printer's configuration, usually accessible through web interface.

  • Sam Beaver Level 1 Level 1 (120 points)

    Thanks, got it working for an hour today by using the HP jetdirect socket and the earliest version of the driver avilable.

    ran some test prints through acrobat, advanced print features and all was going well, functioned properly like a PC. Quit acrobat and was going to test out another software, before i did so, decided to print one more thing in acrobat, however, when i opened it the same printing resources were no longer available. printing was no longer possible on the printer in question, nor on my other ones.

    got rid of the existing, reinstalled again, no dice rolling.