Previous 1 2 Next 19 Replies Latest reply: Apr 16, 2013 2:37 PM by Jerrold Green1
wilfredfromcastleford Level 1 Level 1

Good Morning.  I submitted this question yesterday to the iMac forum but no one could help me.  It should  be a very simple thing to do but it escapes me.

 

Using 'Insert Date' brings up the long date format i.e.  Tuesday April 16 2013.  I prefer the short format 16.04.13.

 

I have tried to change this by going through the procedure System Preferences > Date Time.  The default format in that window is the one I want but it does not appear in my Pages or Numbers documents.  I then tried Systems Preferences > language and Text > Region > Customise I made sure I was in the correct region and selected the short date format.  Still get the long format in the documents.  I can edit this on the fly by right clicking the date but the next time I use 'insert date'  it reverts to the long format.  Now I'm the first to admit I am probably missing something really simple but could somebody plesae point out to me what it is 'cos it's driving me mad.

Wilf


iMac, OS X Mountain Lion (10.8.3), iMac 11,1 Intel Core i5. 2.66GHz
Reply by Yellowbox on Apr 16, 2013 10:08 AM Helpful

Hi Wilfred,

 

Three issues here.

 

1. Setting the short and long dates in System Preferences. See fruhulda's answer: Copy and paste to shift the dates position. [Nice one, fruhulda!]

 

2. Locking those changes in (restart your computer). See Jerry's first answer.

 

3. However I do not get that window that you show where it saysset to today and gives you those options which you can tick. This has nothing to do with System Preferences. That window is what you get in Pages when you double-click or right-click or Control-click the date object to bring up the options. See Jerry's last answer.

 

If I could try everyones patience a bit further.

No worries mate.

 

Regards, Ian.

Reply by Jerrold Green1 on Apr 16, 2013 2:19 PM Helpful

OK, it is what it is then. Don't delete the spare account. It comes in handy for testing apps.

 

Jerry

All replies

  • Yellowbox Level 6 Level 6
    expertise.macosx
    Mac OS X

    Hi Wilfred,

     

    After you Insert Date and Time from the Insert Menu, double click on the date and a pop-up menu allows you to choose a format. Click elsewhere in the document to dismiss the pop-up.

     

    BTW, it really is a date and time, as you will see from the options!

     

    Regards,

    Ian.

  • Yellowbox Level 6 Level 6
    expertise.macosx
    Mac OS X

    Update:

     

    I can edit this on the fly by right clicking the date

     

    On rereading your question, you have already found this. Sorry, I don't know how to set the default date format for 'Insert Date'.

     

    Regards,

    Ian.

  • fruhulda Level 6 Level 6

    Change it in the System preferences > Language& Text > Format > and chagne the date for Long date to the format of a short one and vice versa.

  • wilfredfromcastleford Level 1 Level 1

    As I stated in my original post I have already been through the System preferences > language & text > region business I do not have the option of 'Format' but if you mean 'Region' then I have done that. It has not worked.

    W.

  • Yellowbox Level 6 Level 6
    expertise.macosx
    Mac OS X

    Hi Wilfred,

     

    System preferences > language & text > region is the correct path. In OS X Mountain Lion 10.8.3, the 'Format' option fruhulda refered to is under Dates > Customize:

     

    Screen Shot 2013-04-17 at 1.17.26 AM.png

     

    Click on Customize.

     

    I think what fruhulda is suggesting is that you enter a short date into 'Long' and a long date into 'Short'. That change will be system-wide, so remember what you did in case you want to revert!

     

    Regards,

    Ian.

  • wilfredfromcastleford Level 1 Level 1

    What you show there Ian  is exactly what i have been doing.  It does not work.  The date always comes out in the long form irrespective of any changes I make in the customize window.  It's riduculous that I have a supposedly state of the art 1500 quid machine and sucj a bog standard task is so much hassle.

    W.

  • Jerrold Green1 Level 7 Level 7

    Wilfred,

     

    After creating your Custom Short Date Format, Restart your computer.

     

    Here's a screen shot:

     

    Screen Shot 2013-04-16 at 11.46.52 am.png

    Regards,

     

     

    Jerry

  • wilfredfromcastleford Level 1 Level 1

    Jerry, thanks for the reply.  However I do not get that window that you show where it says set to today and gives you those options which you can tick. If I could try everyones patience a bit further.  Opening date and time in system preferences shows the date in the format I want, I didn't put it in that format it was there the first time I opened it and it has not changed but it never appears like that in any document I work on.  Going the long way round via Syst. pref > Lang & text  > Region > brings up a window with all those options in but greyed out.  Proceeding to Customise I get a window with all the different options in which I can alter at will but it makes no difference.  Even the First day of the week option always reverts to Monday even though I constantly change it to Sunday.  In fact I don't fully understand all the options in that Customise window.

    Going out now to buy a quill and a bottle of ink!

    W.

  • fruhulda Level 6 Level 6

    Sorry, I wasn't aware of the change in Mountain Lion. But if you read my first post I suggest that you change  Long date and Shorter date with each other. See my screen shots. I could use Copy and Paste to shift the dates position.

     

    Bild 2013-04-16 kl. 18.05.34.png Bild 2013-04-16 kl. 18.06.08.png

  • Jerrold Green1 Level 7 Level 7

    Wilfred,

     

    To get the option list for Date and Time format, Insert a Date Object, then double-click or right-click or Control-click the date object to bring up the options.

     

    Jerry

  • Yellowbox Level 6 Level 6
    expertise.macosx
    Mac OS X

    Hi Wilfred,

     

    Three issues here.

     

    1. Setting the short and long dates in System Preferences. See fruhulda's answer: Copy and paste to shift the dates position. [Nice one, fruhulda!]

     

    2. Locking those changes in (restart your computer). See Jerry's first answer.

     

    3. However I do not get that window that you show where it saysset to today and gives you those options which you can tick. This has nothing to do with System Preferences. That window is what you get in Pages when you double-click or right-click or Control-click the date object to bring up the options. See Jerry's last answer.

     

    If I could try everyones patience a bit further.

    No worries mate.

     

    Regards, Ian.

  • wilfredfromcastleford Level 1 Level 1

    1. Ian, Fruhulda, just tried to do the copy paste trick but am not allowed to do that as copy/paste  option is greyed  out in 'Edit' on the customize window.  

    2.  I have tried the double-click before, I forgot I had seen that window.  Changed the format ok no problem but the next time I do 'insert date time' it reverts to the long format. 

    3. Selected date/time from Sys pref and with the format I want showing I tried to restart and the mac seized up.  Had to do a hard shutdown to get up and running again.  Long format still present.   

    W.

  • Jerrold Green1 Level 7 Level 7

    Wilfred,

     

    Try in another User Account.

     

    Jerry

  • wilfredfromcastleford Level 1 Level 1

    I don't have another user account Jerry I'm the sole user on this machine.

    W.

Previous 1 2 Next