14 Replies Latest reply: Apr 21, 2013 7:46 AM by vitod
Owen A Level 2 (235 points)

Check software update or go here, release notes from the Apple Support page:


Aperture 3.4.4 Update

  • Shared Photo Stream invitation lists now scroll correctly.
  • Fixes an issue that could cause multiple warning dialogs to appear when syncing web albums after waking from sleep.
  • Changes made to the Aperture library are now more reliably reflected in the iLife Media Browser.
  • Two fingered scroll now works in the To field of the Shared Photo Stream dialog.
  • Addresses an issue with library upgrades that could cause Aperture to incorrectly display a dialog stating "To open this iPhoto library in Aperture, it first needs to be upgraded."
  • Resolves an issue that could prevent images captured from a tethered camera to a user’s Pictures folder from being written to disk on computers with OS X Lion v10.7.5.
  • Nikon P7700 RAW images are now displayed correctly in the Import window.
  • The eyedropper for the Color tool now works correctly when you select either the Crop or Straighten tool in the Toolbar.
  • Thumbnails with version names longer than 250 characters are now displayed correctly.

This update also addresses stability issues that could cause Aperture to quit unexpectedly in the following cases:

  • Moving photos from one project to another
  • Uploading photos to Photo Stream
  • Attempting to access a vault
  • Connecting a second display to a computer while in Sleep mode, and then waking it from sleep

This update also addresses stability issues that could cause Aperture to become unresponsive in the following cases:

  • After canceling a print job
  • When adjusting white balance
  • léonie Level 10 (90,574 points)

    Sounds promising! Thank You, Owen A!



  • Ernie Stamper Level 8 (37,545 points)

    Because I am updating on two different computers, I updated first on my Mac Pro, and then moved a clone of the newly designated 3.4.4 library to my rMBP.  There Aperture 3.4.3 could open the 3.4.4 Library, and then the designation was changed back to 3.4.3.  This is similar to some changing done in the move to 3.3.


    Not that this really matters, but reporting because I had the sequencing to test, and do so.



  • Andreas Yankopolus Level 2 (415 points)

    I've been working in Aperture 3.4.4 for the last two hours, and it hasn't gone nuts after numerous switches between regular and full-sceren mode. I'd have to quite and re-start previous versions hourly.


    But really, Apple needs to deliver lot more than a handfull of bug fixes for their antique app. What they've done today is given a manicure to a heart-attack victim.

  • Andreas Yankopolus Level 2 (415 points)

    Never mind—the bug where Aperture goes nuts and jumps between virtual desktops after a few switches between full-screen and regular mode is still alive and kicking. Back to quitting and restarting!

  • Yuri Trukhin Level 1 (0 points)

    Can`t launch Aperture after last update https://www.evernote.com/shard/s12/sh/9096357d-faf5-4c3b-8a34-49bcaf620fc3/341de 3f1e18ad1d422bf82bb99a351df

    Process:         Aperture [389]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.4 (3.4.4)

    Build Info:      Aperture-320085000000000~4

    App Item ID:     408981426

    App External ID: 14995585

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [265]

    User ID:         501



    Date/Time:       2013-04-17 15:08:55.650 +0400

    OS Version:      Mac OS X 10.8.4 (12E30)

    Report Version:  10



    Interval Since Last Report:          13448 sec

    Crashes Since Last Report:           3

    Per-App Crashes Since Last Report:   2

    Anonymous UUID:                      8D9DABB4-FCA5-A6EE-EC44-360482E8D8D3



    Crashed Thread:  0



    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000



    Application Specific Information:

    dyld: launch, loading dependent libraries



    Dyld Error Message:

      Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

      Reason: image not found



    Binary Images:

           0x10421c000 -        0x104979ff7  com.apple.Aperture (3.4.4 - 3.4.4) <7C43FF75-DA6F-3613-AF60-ACAFBB73D673> /Applications/Aperture.app/Contents/MacOS/Aperture

           0x104b9a000 -        0x104ba3ff7  com.apple.PhotoFoundation (1.0 - 20.12) <9E3EA726-0AE7-3A40-AF03-EA7BDF21C099> /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Versio ns/A/PhotoFoundation

           0x104c19000 -        0x105177fff  com.apple.RedRock (1.9.4 - 321.1) <EAD3BDC5-3A3E-3246-B69F-DB2E39695403> /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/Red Rock

           0x1054a9000 -        0x10552cff7  com.apple.iLifePageLayoutCore (1.0 - 210.38) <BC05B804-298B-38CD-9647-1CDAD4F714E8> /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ve rsions/A/iLifePageLayoutCore

           0x105591000 -        0x105596ff7  com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5) <9D62897F-2817-3C68-8EDF-A52539B11EE7> /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fr amework/Versions/A/iLifePhotoStreamConfiguration

           0x1055a1000 -        0x1055d2fff  com.apple.iLifeAssetManagement (2.7 - 45.19) <EBF43BAB-B1EF-3A26-8C17-F5A8AD4F1923> /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/V ersions/A/iLifeAssetManagement

           0x105608000 -        0x105615fff  com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <EA624F78-C441-3514-9A77-362F96B84A94> /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.frame work/Versions/A/AccountConfigurationPlugin

           0x105625000 -        0x1056c8ff7  com.apple.MobileMe (13 - 1.0.4) <78787555-A65F-3F23-8473-E9CEBCD14BF3> /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mo bileMe

        0x7fff63e1c000 -     0x7fff63e5093f  dyld (210.2.3) <A40597AA-5529-3337-8C09-D8A014EB1578> /usr/lib/dyld

        0x7fff8eacd000 -     0x7fff8eacdfff  com.apple.Cocoa (6.7 - 19) <1F77945C-F37A-3171-B22E-F7AB0FCBB4D4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

        0x7fff8ed18000 -     0x7fff8eec6fff  com.apple.QuartzCore (1.8 - 304.2) <42FE7BA1-CA53-3927-BE2F-773C268FECFF> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

        0x7fff90225000 -     0x7fff904f6ff7  com.apple.security (7.0 - 55179.13) <AB71A089-131E-3741-87BD-AFF70639B07F> /System/Library/Frameworks/Security.framework/Versions/A/Security

        0x7fff90c94000 -     0x7fff90c94fff  com.apple.ApplicationServices (45 - 45) <A3ABF20B-ED3A-32B5-830E-B37831A45A80> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

        0x7fff90caa000 -     0x7fff90caafff  com.apple.Carbon (154 - 155) <372716D2-6FA1-3611-8501-3DD1D4A6E8C8> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

        0x7fff922e1000 -     0x7fff9246cff7  com.apple.WebKit (8536 - 8536.28.10) <724166AC-F156-31FA-A1EB-5288D86CC7E3> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

        0x7fff93551000 -     0x7fff935bfff7  com.apple.framework.IOKit (2.0.1 - 755.24.1) <36024692-FE93-387E-86CB-DFC15EF4F86C> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

        0x7fff935c0000 -     0x7fff935cffff  com.apple.opengl (1.8.8 - 1.8.8) <7A2BCB8B-BAA6-3300-B86E-C468E4DCBBC7> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

        0x7fff9435b000 -     0x7fff9435bfff  com.apple.CoreServices (57 - 57) <9DD44CB0-C644-35C3-8F57-0B41B3EC147D> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

        0x7fff94911000 -     0x7fff94917fff  com.apple.DiskArbitration (2.5.2 - 2.5.2) <C713A35A-360E-36CE-AC0A-25C86A3F50CA> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

        0x7fff9554e000 -     0x7fff95738ff7  com.apple.CoreFoundation (6.8 - 744.19) <0F7403CA-2CB8-3D0A-992B-679701DF27CA> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

        0x7fff98b68000 -     0x7fff98bb9ff7  com.apple.SystemConfiguration (1.12.2 - 1.12.2) <A4341BBD-A330-3A57-8891-E9C1A286A72D> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

        0x7fff98d98000 -     0x7fff99019fff  com.apple.AOSKit (1.051 - 152.3) <7E9F9D71-D09F-3E13-893D-6E3E3B2EF6B7> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit

        0x7fff9901a000 -     0x7fff990cefff  com.apple.PDFKit (2.7.6 - 2.7.6) <302BA679-CC9F-39D9-B0CB-2B8233C2B90C> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framew ork/Versions/A/PDFKit

        0x7fff99b53000 -     0x7fff99b53fff  com.apple.Accelerate (1.8 - Accelerate 1.8) <6AD48543-0864-3D40-80CE-01F184F24B45> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate



    Model: MacBookPro8,1, BootROM MBP81.0047.B27, 2 processors, Intel Core i5, 2.3 GHz, 16 GB, SMC 1.68f99

    Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB

    Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0707, 0x000000000000000000000000000000000000

    Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0707, 0x000000000000000000000000000000000000

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (

    Bluetooth: Version 4.1.4f2 12041, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Network Service: Ethernet, Ethernet, en0

    Serial ATA Device: OCZ-VERTEX4, 512.11 GB

    Serial ATA Device: Hitachi HTS545032B9A302, 320.07 GB

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfd100000 / 2

    USB Device: USB 2.0 Hub, 0x1a40  (TERMINUS TECHNOLOGY INC.), 0x0101, 0xfd120000 / 4

    USB Device: Portable HDD SH93, 0x125f  (ADATA Technology Co., Ltd.), 0xa93a, 0xfd122000 / 5

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfa100000 / 2

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0245, 0xfa120000 / 5

    USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 8

  • léonie Level 10 (90,574 points)

    Dyld Error Message:

      Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

      Reason: image not found

    That error message is an old "friend". Do you have Final Cut installed?

    You usually get this error, if an installation of other software replaced the "PluginManager" framework by an incompatible version. The recommended fix is to reinstall the opreating system.


    Or if you have a TimeMachine backup from before the uopdate to restore this folder in the System Library:


  • Yuri Trukhin Level 1 (0 points)

    I hasn`t Final Cut installed. Reinstall OS is Microsoft Way, I can`t do it because it isn`t solution for problem, it is bad workaround. I tried reinstall Aperture, but it can`t resolve a problem. IT IS PROBLEM IN APPLE SOFTWARE, waiting fix from Apple... 3.4.3 works good.

  • Yuri Trukhin Level 1 (0 points)

    Folder /Library/Frameworks/PluginManager.framework/ isn`t exist...

  • léonie Level 10 (90,574 points)

    Reinstall OS is Microsoft Way, I can`t do it because it isn`t solution for problem, it is bad workaround. I tried reinstall Aperture, but it can`t resolve a problem.

    Then you'll have to wait a long time.


    Read your crash report. Aperture is trying to call a framework, that should be installed in your system library, but it does not work, because the framework is missing or has been replaced by something incompatible. Reinstalling Aperture cannot help, because the framework is missing in your system, not in the Aperture application.


    If you have not installed Final Cut, you must have installed something else, that removed or replaced the Framework.



    Folder /Library/Frameworks/PluginManager.framework/ isn`t exist...


    Reinstalling the system is the safest way to restore this.

  • Yuri Trukhin Level 1 (0 points)

    ok, i try reinstalling... thank you

  • Owen A Level 2 (235 points)

    Yuri, you can also try installing the 10.8.3 Combo update again to see if that will fix it for you.


    Combo update can be found here: http://support.apple.com/kb/DL1640

  • Owen A Level 2 (235 points)

    Sorry Yuri, I missed that you were on a seed build of 10.8.4. If you can get a combo update from the developer site that might work other wise as leonieDF suggested, a reinstall of the OS should fix this as well. More info is here: http://support.apple.com/kb/ts3528

  • Yuri Trukhin Level 1 (0 points)

    Resolved by copying PluginManager.framework from other Mac. Thanks all for help.

  • vitod Level 1 (0 points)

    I downloaded the newest version 3.4.4 and since then I haven't been able import photos through Aperture.  I connect my camera with a USB and Aperture doesn't show it on the Import screen.  I am not able to import through iPhoto either.