13 Replies Latest reply: Dec 22, 2014 11:42 PM by cosmotic
mojo1993 Level 1 (0 points)

Within the last week, iCal has begun automatically changing the time zone of new events I enter via Calendar on my Google calendar to UTC. It does not do this for items entered on my iCal calendar.

 

I enter the date and time (Pacific Time)  and as soon as I add an invittee or click "Done" it changes the time zone to UTC.

 

Prefs:

  • iCal time zone support is on
  • Mac time zone is set automatically (and its correctly finding PDT)
  • gCal time zone is also set for Pacific

 

Calendar reads 11-1 pm...

Screen Shot 2013-04-16 at 3.13.42 PM.jpg

 

Yes, one solution would be to not use Calendar. Barring that, what do you suggest?


MacBook Pro (Retina, Mid 2012), iOS 6.1.3
  • Peter Payne Level 1 (5 points)

    Happening to me too. Anyone got a fix?

  • Jake_meister Level 1 (0 points)

    Happening here too... It shows correctly on ipad and other mobile devices, as well as gmail, but has the UTC time on Calendar. Would hope for a quick fix.

  • BenCon Level 1 (0 points)

    I found a way to stop this from happening.

     

    I went into Preferences and then Advanced, and UNCHECKED "Turn on time zone support".

     

    This left my original timings as they were supposed to. I rarely ever leave my timezone anyways, so it's just a nuisance feature for me.

     

    Hope this helps.

  • thenerj Level 1 (0 points)

    I have the exct same problem. Live in pacific time zone and chages to UTC. This only happens when I enter the event into iCal on my mac but not if I enter into into gmail or my phone (Galaxy S3) .

     

    I tried unchecking the timezone support which does work, except for when I do travel occasionally it messes things up. Would love to know if anyone is able to find a fix

  • seemaxwork Level 1 (10 points)

    I was having the same problem and spent some time on the phone with apple today.(new computer is under apple care). Tried a ton of stuff with different folks and ultimately I (well, me and 3 apple specialists) was able to solve this issue.

     

    Here's the break down:

    1. Quit Mail, Calendar and Messages.

    2. Open: System Preference -> Mail, Contacts & Calendars

    3. Delete all your google accounts (using the little minus button below your account list)

    4. Restart your computer.

    5. Re-add your google accounts. (Obviously, keep the calendar box checked).

    6. Open calendar and wait for your google info to populate.

    7. Attempt to add an event with correct time zone.

     

    -----------------------------------------------

     

    IMPORTANT NOTE:

    Events I created while I was having the problem still had the problem.

    I simply deleted those broken events and recreated them with refreshed settings.

     

    --------------------------------------------------

     

    I've only had this working for a few hours so I'm not certain it will stay working forever.

    But for now it is a relief.

     

    I realize deleting and re-adding the accounts is annoying but it's a lot less frustrating than seeing UTC every time you add an event.

     

    Hope that helps everyone else having this problem.

  • Paul Forgey Level 2 (160 points)

    This still won't work if adding events via .ics files. The events will be created, and shown, in UTC and attempting to edit the information back into the local time zone causes comedic offset failures. Editing the time zone info on the gCal side won't replicate into iCal either.

  • signenoerly Level 1 (0 points)

    I had the same problem.

    When I entered an event in Calendar for my google calendar it switched to UTC.

     

    What I did was:

    Go to the Preferences in calendar: Preferences > Advanced > uncheck "Turn on timezone support"

     

    After doing that it all worked like a time.

     

    A few people have suggested that this also plays a part in it, but it doesn't influence anything on my part:

    System Preferences > Date & time: "Set date and time automatically". For me it doesn't matter if this i checked or unchecked. It works either way.

  • mmmond Level 1 (0 points)

    I'm disabling time zone support too, after reading support posts on this topic for 30 minutes.

     

    Completely embarrassed about Apple's silence and cluelessness on this.

  • mainelysleepless Level 1 (0 points)

    I've disabled Time Zone support, have locked my Time Zone as EST (Philly) & it still exports an ics file & shifts the start time by 3 hours.  It is consistently a 3 hour shift to later (ie: 9:30am appears as 12:30pm).  I don't use Google - mostly only Evite.  I've tested Evite exports to iCal from various users in case the way they set it up differs or there is Evite user error & it is consistently 3 hours later than it should be.  When I go into edit the actual event, sometimes it is listed as UTC & other times nothing at all.  I can change the time manually but it's a PITA!!!!  Let's get on the ball Apple!!!!

  • edaws93 Level 1 (0 points)

    I am having a similar problem... only in reverse.  When I try to import iCal files from my school (which are in Atlantic Time) it imports them into iCal as UTC.  How can I fix this??

  • ashleydm Level 1 (0 points)

    I'm also having the same problem and I've called Apple / paid for extra support and still NOTHING. I've deleted, restarted, unchecked and rechecked every option in this post. My theory is that it is related to an issue they have integrating with google accounts. However, I'm giving up and switching to another calendar. This is total BS.

  • puneetfromjodhpur Level 1 (0 points)

    This Resolved my issue.

  • cosmotic Level 1 (0 points)

    I'm getting this same problem now too =(

     

    Deleting and recreating accounts is a work-around not a solution. Apple, we're running up on 2 years to fix this bug...