6 Replies Latest reply: Apr 17, 2013 1:35 PM by Brian Curp
Brian Curp Level 1 (20 points)

I was just attempting to export a Keynote presentation as a Quicktime Movie. Keynote froze up at the end of the export and then I had to force quit the app. However - now I am stuck with a massive loss of available disk space, almost 30 gigs!


Basically, I set Keynote to create a 10920x1080 ProRes (HQ) quicktime file to export to my desktop. I could see the available disk space under my startup disk icon shrinking as the movie rendered out. However, once Keynote crashed no temp file or anything was generated on my desktop, yet the disk space was gone. I can't find any sort of temp files or anything to delete, it's like that space just dissapeared!


I've tried restarting, reparing disk permissions, verifying the startup disk, resetting PRAM, running CRON scripts... so far nothing is helping. I created a smart folder to look for any files over 10GB and included system files and got no results.


I'm stuck! Does anyone have any ideas where I can find this elusive ghost file? I'm running off an SSD so that space is pretty valuable to me!

Mac Pro, OS X Mountain Lion (10.8.2), 2x2.26 Quad Core, 16GB RAM
  • Brian Curp Level 1 (20 points)

    Quick update - I tried exporting again, only this time to an external drive. It still took down my drive space on the startup disk, so that makes me think it's using a tmp directory no matter what... However when looking I can't find anything of the sort and rebooting did not recover any of the space. Now my free space is so low I'm thinking I'll just have to restore from a time machine backup.


    How irritating!

  • Gary Scotland Level 6 (12,270 points)

    The desktop is not the place to export Pro Rez files, as you found running the OS, Keynote and rendering in Quicktime is too much for the system drive to handle. A separate dedicated media drive is needed to handle all that data rate.


    Do you really need to render to Pro Rez HQ? This is a high end lossless professional editing  format, something delivered to a Broadcaster or editing facility. What is your end product that you need such a high data rate?


    Try a system software check:


    Shut down the Mac

    Start up again pressing the shift key untill the apple logo appears

    leave the Mac running while it performs error checking of the hard drive, the more errors the longer it will take. Expect 15 minutes as a minimum

    when the OS appears reboot

  • Brian Curp Level 1 (20 points)

    Hey Gary - first off, thanks for your reply! I am currently forcing spotlight to re-index to see if that might help me out. After that I will try your suggestion and run a system software check.


    I need a ProRes export as this is going to be combined with IMAG footage from a live presentation as well as additional video from an Arri Alexa. I want to preserve as much quality as possible so that there isn't a discrepancy in the final edit. Originally, I was rendering a small test to the desktop to gauge output quality of animations etc. I did go ahead and re-export a second time to an external drive, but it doesn't seem to matter as Keynote appears to initially render everything to the startup drive no matter what. The second export still ate about 15 gigs from my startup disk and I am unable to find any sort of temp files anywhere!


    I am showing all files in Finder and searching around the ~/private/tmp folders to no avail. In the image below there appears to be a discrepancy in the size being reported by finder and the size I'm seeing listed in terminal...


    folder size discrepancy.jpg

  • Brian Curp Level 1 (20 points)

    Tried system software check but doesn't look like I'm having much success. I did gain 1 GB back though .

  • Brian Curp Level 1 (20 points)

    Ok - I've narrowed it down and I think I've found the offending files!


    In terminal I used the command "sudo du -chxd 1 /" to list and followed the path until I reached ~/private/var/root/.Trash


    They appear to be listed as those pesky "recovered files" in the root trash...


    If you look at the image below you can see that Recovered files #15 and 16 pretty much correspond to the amount of space I've lost (10GB and 31GB respectively).


    I guess my main question now is: How do I empty or erase the trash from the root account? I'm wary of just deleting the .Trash folder via terminal  - don't want to screw up my system... If anyone can direct me on the best method to delete the files in that folder I think that would solve my issue!


    root trash.png

  • Brian Curp Level 1 (20 points)

    Ok - problem solved...


    Just to round out my (mostly) one-sided discussion in case anyone else ever runs across this wacky issue - I enabled the root user in System Prefs a la this support doc: http://support.apple.com/kb/ht1528


    Then I just logged in as the root user, and wouldn't ya know it... my trash can was full of big useless files! Emptied the trash like normal and now I've got all my disk space back.


    Hopefully this might save someone 6 hours of poking around terminal in the future!