Previous 1 2 3 Next 30 Replies Latest reply: Oct 8, 2015 2:04 AM by Mufana
liskabee Level 1 Level 1

I was using my 13" macbook pro no problem two days ago.  Woke up yesterday, completely unable to connect to the internet (both wifi and ethernet).


Despite using the wifi trouble shooting issues link I found (, I still have not been able to connect.


  1. Does the symptom occur with more than one Wi-Fi device?
    • My roommates are all able to connect to the internet via wifi router and ethernet cable; only I can't access it
  2. Make sure your software is up-to-date.
    • Current Version: 10.7.5
    • Unable to check to see if there is newer software to update as I have no internet connection to check (When I click under the apple menu > about this mac > verwion 10.7.5 > there is a "software update..." button; if I click it, it says "software udate can't check for updates because of a network problem.  You are not connected to the internet".
  3. Check your connections.
    • I have unpluged both the router and modem, and restarted my computer. I've also tried hitting the refresh button on the wifi router (as this normally fixes the problem)
  4. Verify that you are using the recommended settings for your device.
  5. Restart your network devices.
    • Doesn't work


Clicking the wifi arches symbol on the top of my computer says that the wifi is on.  When I click my network, it says to enter a password (I have the password; it worked 3 days ago to get a friends phone connected).  Normally it remembers my password however.  When I enter the pass, it spins and tries to load, then says that a connection timeout has occured.


Going through system preferances > network >, wifi (yellow dot) is at the top of the list, followed by ethernet (red dot) and firewire (red dot) on the left.  Clicking "advanced" > TCP/IP, there is no IPv4 address there.  Clicking renew DHCP lease doesn't do anything either.


What is going on? Why can't I connect at all? I'm right in the middle of finals (yay university) and this is quite inconveinent.  When I phoned apple they said that to do tech support over the phone would cost 60$, which I can't afford at this moment. Any ideas??

MacBook Pro, Mac OS X (10.6.8)
  • CMCSK Level 6 Level 6

    Some of the things you may have already tried - First contact your ISP.  You need to confirm that the issue is not on their end.


    Change your router channel.  Sometimes this is all you will have to do.


    Power cycling the router.  Read the router's user manual or contact their tech support for instructions.


    System Preferences/Internet & Network/Network

    Unlock the padlock

    Locations:  Automatic

    Highlight Airport and/or Ethernet

    Click the Assist Me button

    In the popup window click the Diagnostic button.


    System Preferences/Network- Unlock padlock.  Highlight Airport.  Network Name-select your name.  Click on the Advanced button.  Airport/Preferred Networks-delete all that is not your network.

    Place a check mark next to "Remember networks this computer has joined."  Click the OK button and lock the padlock.  Restart your computer.


  Mac OS: How to release and renew a DHCP lease



    No internet connection (wireless)

    Check to see if an extra entry is present in the DNS Tab for your wireless connection (System Preferences/Network/Airport/Advanced/DNS).

    Delete all extra entries that you find.

    Place a check mark next to "Remember networks this computer has joined."



    Other resources to check into:

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6


    Non-responsive DNS server or invalid DNS configuration can cause long delay before webpages load




    How to diagnose and resolve Wi-Fi slow-downs


    Pv6 troubleshooting


    Mac OS X 10.6 Help:  Solving problems with connecting to the Internet


    What Affects Wireless Internet?


    Solutions for connecting to the Internet, setting up a small network, and troubleshooting
















  • Revede Level 1 Level 1

    i´m having the same problem, Internet just stopped working, although skype works fine, everything else won't, just skype and works perfectly, i can even acces the other computers and print in my network thru wifi.


    I analyzed my computer with the antivirus, and it showd a thing called yontoo, which i deleted, but it didn't work.



    can anyone help??????

  • jefffrombarrie Level 1 Level 1

    I am having the exact same issue.

    I ran the firmware update for Thunderbolt and suddenly I cannot get out on either network interface. I cannot connect to the internet, or local resources.

    I am able to connect to various wifi networks, but cannot go further.

  • jarleaax Level 1 Level 1

    I have the same problem.


    Tried all the troubleshooting solutions but without success.


    My current OSX version is 10.8.4.


    All other devices connects just fine.


    And my computer worked fine yesterday. I havent changed anything since yesterday.

  • CMCSK Level 6 Level 6

    jarleaax wrote:


    I have the same problem.


    Tried all the troubleshooting solutions but without success.


    Take the computer to an Apple store or an AASP.  Whichever is more convenient for you.  If you have Apple Care, call them first & get a case number.


















  • jarleaax Level 1 Level 1

    Thanks man!


    I don't think that I have any warenty left on my computer since I bought it two years ago.


    And we don't have the same system in Denmark with the Genius-bar.


    BUT! a little update regarding my problem. I took my other MBP that connects just fine to the network and found the DNS adresses it uses with the connection. And manually copied them to my own computer.. Then I hit the renew DHCP lease button for around 20 times, and suddenly it connected to my wifi... I restarted to how it would behave, and sadly it diden't connect again, and i hat to start over. But I got i working again. So it can be done... just done know where the the problem is.

  • jarnomelenhorst Level 1 Level 1

    I have had the same problems as every other MBP retina user. the solution for me was the following


    i have changed my router settings. my only active channel now is channel six. i have disabled the auto channel configuration. this is a solution that works for a lot of people.

  • The Prosecutor Level 1 Level 1

    Same for me people, for a couple of weeks now I'm experiencing time-out problems on more than one MAC OSX notebook at different networks. I tried to change the network packet size in the network adapters MTU setting to a lower value e.g. 1453, but it did not completly solve my problem. My VPN connections fail. I'm running Windows on a different computer and even virtual on my MAC OSX notebook and the Windows OS doesn't have this problem and works fine. So the conclusion to me is that some stuppid OSX update must have broken our network adapter drivers.


    So @ Apple I say: get this annoying bug out of our lifes or I switch to Windows again.


    Thank you all for your time, and good luck with the bug!

  • leduch Level 1 Level 1

    Hi all,


    I've had the very same problems with my Macbook Air since i switched to Lion and i had tried every tips and tricks available without much success so far :

    - create new location

    - delete saved wifis + keychain

    - change MTU

    - remove preference files


    Yesterday, i noticed in activity monitor that many programs were running in the background (novacom drivers, Android file transfer agent, Google keystone...) which i did not want.


    Then i decided to go to CleanMyMac to uninstall them as cleanly as possible. I could not find them in the main "App" tab, therefore i clicked on "Others" and... light came.

    I had 83 "Others" old program bits and pieces scattered in folders such as Library, LaunchAgents or LauchDaemons. Those plist files belonged to Softwares i did not use anymore but my guess was that they were still loaded at boot time and could lead to problems.


    After a good cleanup i went down to 7 remaining plist files in this tab and as a side effect : All my wi-fi problems were GONE


    Yesterday was a good day!

  • beoti Level 1 Level 1

    I have a MacBook Air.  I was able to connect fine yesterday evening.  Ran into problems just this morning where the connection would timeout.  I completely rebuilt my router settings from scratch with no luck and finally came to this post.


    I followed jarnomelenhorst's advice and changed to a static channel and things are working fine now...thank you.  Yuck, yucky, yuck, MacOS bug.

  • natalija.kurm Level 1 Level 1

    Unbelivable, it seems like you never read what liskabee wrot!!!

  • Sungyub Han Level 3 Level 3



    I am experiencing now wifi timeout too....


    I purchased a film on iTunes and after 1.6GB of the film, when there was still the iTunes Extras (1.3GB) to be downloaded, my wifi (despite the fact that I saw the signal icon all black) was on without being able to connect to the internet.


    I thought it was the wifi modem, and I switched it off and then on.

    but after another 1GB of download, the same happened.


    Then it occured to me that maybe the wifi modem was ok, and then I tried using internet via my iPad, which proved the origin of the problem was my MBPro Retina (the model before the 2012 september launch).....


    I have mavericks and everything up to date....


    any ideas?

  • mjhanlonumd Level 1 Level 1

    That is for the tip!  My solution was slightly different but you took me about 90% of the way there.


    For those of you that aren't able to connect by follow liskabee's advice, try connecting to your secondary and/or guest Wifi connection.  That immediately solved my connectivity issue.


    Hope that helps!



  • ADirtyTowel Level 1 Level 1

    This thread is a bit old but I just ran into the same issue and came up with a fix. On my wireless access point (uses WPA2 encryption) I changed the settings from using TKIP to AES and that fixed the error that I was getting. For some strange reason Mac does not support TKIP. Good luck hopefully this helps anyone who is having this issue!

Previous 1 2 3 Next