Previous 1 2 Next 28 Replies Latest reply: Jul 2, 2015 12:45 AM by SEmmons Go to original post
  • Virginia709 Level 1 Level 1 (0 points)

    Happened to me and I tried all of the above but the only thing that worked for me was to disconnect my wifi for 60 seconds, restart and everything began working perfectly again.

     

    Hope this helps.

  • ecerrillos Level 1 Level 1 (0 points)

    Ok, after spending a few hours following everybody's advice, my wi-fi connection was still being dropped, was getting wifi connection timeouts and even when re-connecting I was getting "wrong password" messages even when entering the right password.

     

    I have my MacBook Pro connected to a secondary Dell monitor. I started noticing that I would connect to wifi and as soon as I connected my monitor the wifi connection would be dropped.  So I searched for whether it was possible for a monitor to cause interference and boila!, it's actually here:  http://support.apple.com/kb/HT1365.

     

    And I'm sure I wasn't experiencing the problem as the router would be using a different channel.

     

    To fix, follow the advice on the link.

     

    This won't apply to everyone out there with the wifi problems but I'm hoping it will save someone a few hours of pain and headaches.

     

     

    Cheers

  • Max Rinaldi Level 1 Level 1 (0 points)

    Hello, I figured out what was my problem in connecting to a brand-new Sitecom X3 N300 modem/router. I have a macbookpro and I realized that in the airport configuration it says, among other things:

     

    Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

     

    I connected the modem/router to my MBP with a LAN cable so I had access to its specs and configurations and I found that the setting "Channel" was "autoscan (recommended)". Apparently, this "autoscan" told the router to fix its broadcast on the Channel 13, which is not in the list above of supported channels. So I forced the router to broadcast into one of the channels of the list and now it works perfectly. Probably, by trying on and on to connect it works as well because the "autoscan" changes from 13 to some other channel. In any case, it is better to check.

  • jose-25 Level 1 Level 1 (0 points)

    Revede, I was having a connection problem with my macbook pro. The issue was AVAST free antivirus, this program has a website shield that for some reason locks all of the websites except for some of them. Try disabling this feature of this program, or uninstalling it.

     

    Hope this helps

  • thepetecom Level 1 Level 1 (75 points)

    This absolutely worked for me.  We'll see if the problem returns, however.  If it does, I'll just hop on my iPad and change the router channel again.  Much easier than factory reseting my router every time, which was my previous solution to this problem.  Thanks so much, Max!!

  • thepetecom Level 1 Level 1 (75 points)

    Ugh... spoke too soon.  Apparently, my MacBook Air will decide it doesn't like what ever channel my router is set to and will drop the connection.  This happened yesterday and so I changed the channel and found my MBA would connect again.  Then, just a few hours later, it decided it didn't like the new channel.  So today I had to go through and try each channel that my router had available (only 1-11) until I found one that the MBA liked.  This is not a good thing.  I really hope Apple gets this sorted with an update soon.  I really don't have time to take my laptop in.  I've had some serious bad luck over the years with Apple and their customer service...

  • LitSnitch Level 1 Level 1 (0 points)

    Sorry if this is long winded. I feel like I've spent years here and there trying to figure this out and I want to share the specifics because no two MBP problems are alike. After all this hassle, I now have a 2010 MBP running Mavericks that is up to date, connects to WiFi like a charm and doesn't disconnect intermittently (also, no more black screen since I deleted the Windows partition anyway).

     

    I have a 2010 MBP. I had it bootcamped with Windows 7 Ultimate because the mac HD wouldn't connect to WiFi. Then over the past year or two, I was experiencing a black screen issue whenever I used a browser in Windows 7. Doing a little research, I noticed that the black screen was due to a "graphics switching setting" in the Power settings on the mac side. Unfortunately, the mac HD OS X must've gotten corrupted (probably due to lack of updating and use, etc.) so I couldn't boot into mac to change the setting. Low and behold, I was left with a 3.5 year old machine that I paid $2k for and couldn't connect to the Internet or use a browser without having the restart the machine every 15-20 minutes.

     

    Problem Summary:

    #1 Mac couldn't connect to WiFi (connection timeouts, dropped signals)

    #2 Couldn't boot into Lion OS X (probably a personal problem since I never used the Mac side without Internet)

    #3 Couldn't use browser in Windows 7 (graphics switching setting in OS X)


    Here are the steps I took to resolve each problem. A lot of these steps utilized some tips and suggestions I found on the Apple forum, Verizon FIOS forums (I have a MI424WR-1 modem/router) and on general mac/tech forums.


    Problem 1 fixes:


    Changes to Router Settings - Following Apple and Verizon's suggestions (Diagnostic Tool - run it and read the WiFi settings info), I made the following changes to the Router and Mac Network settings:


    • Router Resets - I did the whole router reset via admin panel and on local modem. WiFi would connect but would disconnect upon sleep or just intermittently for no reason. Not a permanent fix.
    • IPv6 vs. IPv4 DHCP - I enabled IPv6 on my router to see if that would provide a more stable connection. After all the research and troubleshooting, I was starting to believe that the MBP needed a static connection of some sort but I'm too much of a novice to figure that out.
    • Security Settings - I actually disabled password-protection on the router and still couldn't connect to WiFi
    • MAC Address - I tried enabling my MBP's MAC address to have access to the router, but that didn't work either.
    • WEP vs WPA vs WPA2 - I tried all of these. WEP is definitely out of the question. I settled on WPA2 but I still couldn't connect smoothly and would lose connectivity.


    Changes to Mac Network Preferences


    • Keychain - I tried deleting all the airport preference files. Did it multiple times. Restarted machine as instructed. Not a permanent fix.
    • TCP/IP - I tried putting my MAC address as the DHCP Client ID and changed the IP settings (auto versus manually inputted). Also tried to Renew DHCP Lease, but that rarely worked since the MBP just wasn't able to communicate to the Verizon MI424WR-1 router. IPv6 didn't make much of a difference either. I tried adding a new Location, adding/deleting preferred network and trying new IPs but none of that made a difference.
    • Hardware - I also tried to change the MTU to manual setting of 1453 because I read that in a forum. Didn't make a difference (also changed on the router settings).

     

    At this point, I had probably restarted my machine 2 billion times. The more forums I read, the further down the rabbit hole I fell. Worst part of it all? In every single forum I read on Apple's site, there was not a single - NOT ONE - reply from anyone at Apple. So, if you're looking for help from your ISP or from Apple, you're out of luck on this one.

     

    Problem 2 fixes: This is probably an isolated problem, but thought I'd share since all these fixes occurred on the same weekend. Also, I've read here and there to make sure your OS X is up to date because that can also cause communication problems with certain routers. That said, I made a bootable USB with Lion OS X. Since I did not have a functioning OS  X to do this on, I made the bootable USB via the Recovery HD. I completely reformatted the MBP HD. Being connected to Ethernet, I updated the software all the way to Mavericks and then I deleted the bootcamp partition so all 500gb were allocated to MBP HD. So, at this point, I had a MBP with a fresh copy of Mavericks - completely up to date - that still couldn't connect to WiFi. So not sexy.

     

    Problem 3 fixes: At the end of the day, this one doesn't matter to anyone who wants to run OS X without bootcamp. However, if you're getting the intermittent black screen  and having to restart Windows all the time, you will need to boot your MBP HD and change the "graphics switching setting" in System Preferences > Power. Just uncheck the box and reboot back into Windows. Should be good to go.

     

    ****END RESULT****


    I bought a dual band wireless N router (Linksys E2500, $80). Problem solved. I'm not even joking. Oh, by the way, if you do plan on buying a replacement router to get the broadband signal and speed your MBP needs to connect, make sure the router set-up disc can be read/opened in Mavericks. Thankfully, I had a Windows 8 HP I could use to install and set up the Linksys router; otherwise, I wouldn't have been able to get the new router to speak to the old modem.


    angel.png

     

    Now I can close my MBP lid and reopen and the WiFi connects instantly without hesitation. I can restart my MBP and the WiFi magically connects as it should. I can even download large files over WiFi without any connectivity loss. I tried to fix my machine as cheaply as possible. Apple Care was expired and I didn't feel like paying someone for a temporary fix. Update your MBP to Mavericks for FREE today through the App Store and go out and buy yourself a 2.4ghz/5ghz dual band Wireless N Router.... perhaps Airport Express will work too?


    RANT 2.0 - It really ticks me off that after being such a loyal Apple and Verizon customer all these years that one of these companies would give a hoot about this problem. Apple knows it's a router issue and perhaps even a greater issue with all OS X versions since Mountain Lion? Who knows, I don't work there. Also, it drives me crazy that an ISP won't give a legacy customer a newer router that handles dual band. Verizon told me that those routers only go to new customers and that they'd happily replace my old router with a refurbished version. It ***** they won't listen. It ***** they won't help. At the end of the day, buying a $80 router was a lot cheaper than $$$ for Apple Care extension (and the time without a computer) or breaking up with Verizon so I could be classified as a "new" customer.

     

    Forum references:

    WiFi Connection Timeout - Macbook Pro?? Help! - goes through the system preferences tips and suggestions. None of these worked for me.

  • LitSnitch Level 1 Level 1 (0 points)

    Forgot to mention under Router settings:

     

    Channels - I tried 1, 6 and 11 as suggested on various forums. None of the channels made a difference. I think I left it on 6 though. I also did the handy wireless scan to see which channels my neighbors were using, just in case. Channel 6 seemed good to me.

  • Rein Aasland Level 1 Level 1 (0 points)

    With my Mac Book Pro  (2.4 GHz/ core i7) running OS X 10.7.5 (newly updated 3 days ago) I just experienced something very similar. System and wifi connections have been working perfectly … and then, this morning, the Mac Book gets the wifi timeout error. Three other devices are perfectly connected to the wifi, and a wifi router restart doesn't help. I CAN connect with the Mac Book via blootooth on the iPhone.

     

    Not wishing to through out all the wifi settings (different servers I frequently use), I was reluctant to trash network preferences.  So here is what worked for me:  I simply removed the wifi router from my collection of "known networks" and loaded it again and reentered the password.  Then .. bingo … it's in place again.

     

    A simple remedy that might work for many of you experiencing the same timeout error.

     

    cheers

     

    Rein

  • thepetecom Level 1 Level 1 (75 points)

    I don't think this will solve the OP's problem but I thought I'd mention it just in case.  I was thinking about how some folks mentioned turning off bluetooth solved their problem.  This won't work for me as I use Bluetooth for a lot of things.  Secondly, I had made no recent changes regarding how I ise Bluetooth devices.  So what other changes had I made? i recently bought a USB 3.0 hub that I placed directly behind my MacBook Air. So, I simply dropped the hub behind my desk, rather than leaving it on the same surface as my MBA, and voila--suddenly the MBA could connect to my wifi again.  Apparently, the hub (a cheap Dynex I got from BB on sale for $20) kicks off enough radiation to interfere with the MBA's wifi. Anyway, I hope this helps someone!

  • shariukas Level 1 Level 1 (0 points)

    Guys I think I SOLVED this. Personally me it helped when i disconnected my external HDD from my MacBook Pro. I have connected to my home wifi. When i connect HDD to mac again - wifi keeps connect but network doesn't work - strange, but worked for me

  • abu1haitham Level 1 Level 1 (0 points)

    simply renew DHCP and you'll be able to connect to wifi

    i tried various fixes but this worked for me.

     

    wifi>open network preferences>advanced>TCP/IP>renew DHCP lease

  • nikohl2 Level 1 Level 1 (0 points)

    Hey guys,

    Changing to channel 6 as another poster stated worked well for me.

  • SEmmons Level 1 Level 1 (5 points)

    Good grief, thanks for posting!

     

    I was having the same problem with my iMac and was ready to blame Yosemite, my router/modem, even Chromecast, anything. strange that only my Mac was affected, all other devices connected fine. Tried nearly everything on the net, read you post about the hub, moved my cheap USB3 hub back and bam! All systems are go!

     

    Thanks!

Previous 1 2 Next