9 Replies Latest reply: Oct 19, 2013 1:26 PM by andynick
vacadoug Level 1 (0 points)

Every time shut down so do my Safari prefernces. They revert back to default. Have reset Safari to no avail. How can I solve this time consuming bug?

MacBook Pro (15-inch Late 2011), OS X Mountain Lion (10.8.3)
  • Linc Davis Level 10 (192,479 points)

    Triple-click the line below to select it:


    Right-click or control-click the highlighted line and select
    Services Show Info
    from the contextual menu.* An Info dialog should open.
    • Does the dialog show "You can read and write" in the Sharing & Permissions section?
    • In the General section, is the box labeled Locked checked?
    • What is the Modified date?
    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). Open a TextEdit window and paste into it (command-V). Select the line you just pasted and continue as above.

  • vacadoug Level 1 (0 points)

    System (home) shows my privilages of readand write; plist does not show "locked" and modified date is 4-12-013

  • Linc Davis Level 10 (192,479 points)

    Back up all data. Don't continue unless you're sure you can restore from a backup, even if you're unable to log in.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. To do that, unlock the preference pane using the credentials of an administrator, check the box marked Allow user to administer this computer, then reboot. You can demote the problem account back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:staff ~ $_ ; sudo chmod -R u+rwX ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning to be careful. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2 (optional)


    Take this step only if you have trouble with Step 1 or if it doesn't solve the problem.

    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:



    Press the tab key. The partial command you typed will automatically be completed to this:



    Press return. A Reset Password window will open. You’re not  going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.



    from the menu bar.

  • vacadoug Level 1 (0 points)

    Lic, thank you so much for your help. Fortunately did not have to go to your last option as once I had the com.apple.safari.plist on desktop I unlocked (bottom right) and added me as administrator and 'system' only w/privilages to read/or all others could not ; relocked and then called Chantelle at Applecare who told me just to restart w/ library preferences pane open on desktop. After that Safari preferences were retained.

    *Interesting to note that last date on panel was the day I removed McAfee tool that ATT/Yahoo had offerred as 'free' download on its help page to it's Mac customers. Hindsight is 20/20 and perhaps its a coincidence, but  had never had a problem with using Sophos and it could have been a conflict with the free tool and Mountain Lion . . .

    Safari is important as it is my default browser on iPhone 4s which syncs w/ MacBook Pro every night.

  • ppvts Level 1 (0 points)

    Hi Vacadoug,


    Would you please detail the exact steps you followed?


    I'm having a similar issue for one user I created on my MBA with 10.8




  • vacadoug Level 1 (0 points)

    The hardest part was getting to the packlist: Credit to Carolyn Samit's post which is essentially what Applecare told me to do:


    "If you are having proboems with Safari, corrupted preferences can sometimes prevent Safari from functioning as it should. Try this user tip...


    Quit Safari.


    Go to ~/Library/Preferences


    Move the com.apple.Safari.plist file from the Preferences folder to the Desktop.


    Relaunch Safari. If that helped, move the.plist file to the Trash. If not, move it back to the Preferences folder.


    ~ (Tilde) character represents the Home folder


    For Lion v10.7x:  To find the Home folder in OS X Lion, open the Finder, hold the Option key, and choose Go > Library "

    Better yet, if your MBA has Applecare have them walk you through it . . . I am extra careful not to muck-up anything, so after I relaunched Safari and it saved preferences for two sessions, restarted MBP and went to Disc Utility and hit  "repair disc permissions"; once it stated 'repairs complete' -- then restarted MBP and have had no problems since.


    Message was edited by: vacadoug

  • ppvts Level 1 (0 points)

    Many thanks

  • alten Level 1 (10 points)

    Been trying to fix this for months. Good job with the cure. Thankyou

  • andynick Level 5 (4,925 points)

    Step one worked perfectly for me.

    Thanks Linc.