2 Replies Latest reply: Apr 18, 2013 8:47 AM by Niel
MollyFlint Level 1 (0 points)

To install my hp printer I need Mac os x version 10.6   I can't download 10.6 unless i get snow leopard but I can't download that unless I have 10.6 update!!  Help!!

iMac (20-inch Mid 2007), Mac OS X (10.5.8)