10 Replies Latest reply: Apr 24, 2013 6:57 AM by LownoteNB
LownoteNB Level 1 Level 1

After being out town for a week or two, I updated Java today. I normally keep Java turned off in Safari.  Following what it said was a successful installation, I continue to get a dialogue box asking if I want to allow Java to accept incoming internet connections.  These flash up very briefly, and I have to be very quick and accurate to get control of the box.  It doesn't matter if I select Deny or Allow, the box just keeps loading, seizing control and disrupting other processes, e.g., just typing this message was a start and stop process.  The only way to stop the box jumping up is to turn off my firewall.  I've deleted Java completely and these boxes still keep flashing up, making the computer effectively unusable.  Any ideas as to how to solve this problem?


iMac (27-inch Late 2009), OS X Mountain Lion
  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    Uninstall instructions in case something was missed.

     

    Java 7 Uninstall

  • LownoteNB Level 1 Level 1

    I followed these very simple instructions but I'm still plagued by this box that seizes control of my computer very briefly about every 15 seconds.  Quite frustrating.  I've restarted a few times and ran permissions repair as well.  Also reinstalled the latest version with Firewall off, and after successful installation turned on firewall and it started up again.  I then deleted Java again.

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.

     

    Isolating an issue by using another user account

     

    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

     

    General information.

     

    Isolating issues in Mac OS X

     

    Troubleshooting Permission Issues

     

     

    Step by Step to Fix Your Mac

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Why are you using the firewall?

  • LownoteNB Level 1 Level 1

    Was under the impression that it provided protection from malware and from having data on my computer  either stolen or corrupted.  True?  Why wouldn't it be better to not use it?  I have always been a bit curious why Apple's default is to have the firewall turned off.

  • LownoteNB Level 1 Level 1

    When it is morning here I'll start down this road.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    It seems to be a common belief that the built-in Application Firewall acts as a barrier to infection, or prevents malware from functioning. It does neither. It blocks inbound connections to certain network services you're running, such as file sharing. It's disabled by default and you should leave it that way if you're behind a router on a private home or office network. Activate it only when you're on an untrusted network, for instance a public Wi-Fi hotspot, where you don't want to provide services. Disable any services you don't use in the Sharing preference pane. All are disabled by default.

  • Forrest Jerome1 Level 2 Level 2

    i am having this same problem after software update last night. 

     

    what is the answer???

  • MightyDutchman Level 1 Level 1

    Hi there,

    I am facing the same annyoing issue after Appstore Java Update.

    I always have my firewall on, merely as a defence against possible intruders, and had no issues with Java before this update.

    While I appreciate your comment about switching the firewall off, it's not really a solution to the problem, granted that the annyoing java loop boxes go away after you disable the firewall, you are more exposed to malicious individuals and hack-attacks.

     

    The annoying thing is that the built in firewall is not granular enough to allow me to pinpoint which specific service is using Java and requires access.

     

    I hope that a real solution to this issue can be found, I am not very comfy with having my firewall switched off.

     

    M

  • LownoteNB Level 1 Level 1

    I've "solved" the problem for the moment by turning off the firewall but agree that this is not a solution.  Hopefully a future updatge of Java will solve this, or Apple will jump in and assist whoever is minding Java these days in correcting this annoying bad behaviour.