Previous 1 2 3 Next 41 Replies Latest reply: Apr 14, 2015 4:51 PM by rajshree san francisco Go to original post
  • Thomas B. Robison Level 1 (20 points)

    I finally disabled my Google account within Calendar preferences.  Now I'm just using my iCloud account and all is well.

     

    If there is a fix for this later, I'll just re-enable the Google account, once more.

  • christine56 Level 1 (0 points)

    Thank you - this seemed to fix my calendar as well; wouldn't have thought of it myself! 

  • neutralino Level 1 (0 points)

    So, could this be why Apple doesn't fix the bug, they want people to stop using google calendar??

  • thinlizzie Level 1 (0 points)

    I am also experiencing the same problem.

    Using Google Calender on OS X 10.8.4 iCal.

    Based in UK.

    Extremely frustrating!

  • dulcimer dude Level 1 (0 points)

    I'm still having this issue and I don't know why apple hasn't fixed it. I'm just using gmail web browser now but I really liked ical. I'm sorry I can't use it anymore.

  • macmillm Level 1 (0 points)

    Same problem. Just missed a meeting because of it...

     

    Apple comment???

  • timsvoboda Level 1 (0 points)

    Same problem for me.

  • kldietch Level 1 (0 points)

    This has been the bane of my existence for weeks. I found this discussion and tried this fix. Will let you know in a day or two if it worked out.

     

    https://discussions.apple.com/thread/4975744?start=0&tstart=0

     

     

     

    I found a way to stop this from happening.

     

    I went into Preferences and then Advanced, and UNCHECKED "Turn on time zone support".

     

    This left my original timings as they were supposed to. I rarely ever leave my timezone anyways, so it's just a nuisance feature for me.

     

    Hope this helps.

  • Aamir-Ice Level 1 (0 points)

    This seems to be a problem for users who are using google calendar in iCal. Turning of time zone support seems to be the only solution! quite frankly I don't consider that a solution at all and I am getting fed up of this war between these 2 companies. Apple if you hate Google so much come out with your own set of services like Google business apps hosted with a users own domain name and make it as competitive and I will gladly choose. But to keep breaking compatibility for a large number of your users who use Google Apps is just frustrating. More so because there is no alternative. Compatibility with google should be a priority at until you can provide an alternative.

  • PeeDee768947385 Level 1 (10 points)

    I also absolutely require time zone support, and need to sync with Google calendars for cross platform and community compatibility. So turning timezone support off, or going solely Apple cloud is not an option.

     

    I know for a fact, because I heavily used it, that the timezone feature worked just fine with iDevices against the Google calendar up until about six months ago. Since then we've switched to using Google calendar within the browser on our iMac's, iPad's, and iPhones instead of iCal/Calendar because it doesn't lose data. Not as pretty, but it works.

     

    I too think that this breaking now is more about corporate strategy than technology as I've seen it happen 'accidentally' too many times over the years. At best it's a mutual blame game between Apple clients and the Google back end. I'm waiting for a 3rd party, preferably opensource, client to offer a sync solution compatible with all servers, or a backend compatible with all clients.

  • crg_from_rochester Level 1 (0 points)

    I found a solution that works for me, pretty simple. In iCal (OS 10.8.4), went to Calendar/preferences/accounts. Unchecked "Enable this account" for both my Gmail (CalDav) account and my iCloud (CalDav) account. Then, I checked them back on to enable them both. After this things worked fine for me. Now when I create a new event and give it a specific time of day, that time does not get converted to UTC. (Previously, I could not get it to stay at EST in the US).

     

    So, it seems (at least for my situation) the above procedure resets the erring mechanism somehow. Hope this works for everyone else.

  • Thomas B. Robison Level 1 (20 points)

    Thanks for the tip, I'll give it a whirl!

  • jeepo67 Level 1 (0 points)

    This did not work for me, bummer

    I still have the same problem. I only have a Google (CalDev) account, not an iCloud account.

  • seemaxwork Level 1 (10 points)

    I was having the same problem and spent some time on the phone with apple today.(new computer is under apple care). Tried a ton of stuff with different folks and ultimately I (well, me and 3 apple specialists) was able to solve this issue.

     

    Here's the break down:

    1. Quit Mail, Calendar and Messages.

    2. Open: System Preference -> Mail, Contacts & Calendars

    3. Delete all your google accounts (using the little minus button below your account list)

    4. Restart your computer.

    5. Re-add your google accounts. (Obviously, keep the calendar box checked).

    6. Open calendar and wait for your google info to populate.

    7. Attempt to add an event with correct time zone.

     

    -----------------------------------------------

     

    IMPORTANT NOTE:

    Events I created while I was having the problem still had the problem.

    I simply deleted those broken events and recreated them with refreshed settings.

     

    --------------------------------------------------

     

    I've only had this working for a few hours so I'm not certain it will stay working forever.

    But for now it is a relief.

     

    I realize deleting and re-adding the accounts is annoying but it's a lot less frustrating than seeing UTC every time you add an event.

     

    Hope that helps everyone else having this problem.

  • kaz78 Level 1 (0 points)

    @seemaxwork

     

    Is this still working for you?