2 Replies Latest reply: Dec 25, 2013 8:22 AM by boomertooner
drew.eagleb Level 1 Level 1 (0 points)

I have enabled home sharing on my laptop and my Apple TV but the Apple TV is not recognizing my iTunes library for some reason.


AppleTV 2
  • Por4ge Level 1 Level 1 (0 points)

    1) If it is a PC you may need to make sure that the Bonjour service is running in order to enable sharing. In the top left corner of itunes 11: Open the drop down - Preferences - Sharing

    It will say if bonjour is turned off OR it will give you a list of folders to share if things are good.

     

    Enabling bonjour:

    Win 7: open the start menu and type "services.msc" in the search bar, enter - look for bonjour and make sure it is started - you can right click it to and pick start

    Also right click on bonjour - preferences and make sure it is set to automatic.  

     

    (I'm trying to remember the XP instructions, so they may not be 100%, also try looking in the task manager (ctrl +alt + Del)

    Win XP: Start menu - Run - "cmd" - services.msc  - look for bonjour right click to start - right click preferences to set to automatic

     

    2) You need to authorize your computer in order to use an itunes account for sharing.  You may have 5 computers authorized per itunes account.

     

    Itunes - Store - Authorize this computer - enter your iTunes account info.

  • boomertooner Level 1 Level 1 (0 points)

    If Firewall is on in Mac OS X (in the Sharing pane of System Preferences), make sure iTunes Music Sharing is selected. This worked for me. Although I have not seen this answer posted in the support community forums, so far, it is listed as No. 2.2 under TIPS in the troubleshooting guide http://support.apple.com/kb/ts1453.