9 Replies Latest reply: Oct 16, 2013 6:23 AM by iBozz
iBozz Level 1 (90 points)

I've asked for help on the iPad forum twice now without a single response, so I am thinking that it might be an iCal/iTunes problem rather then iPad/Calendar one!


I'll repeat the basics here and post this link (https://discussions.apple.com/message/21740855#21740855) to my iPad thread post which explains in more detail.


Essentially, syncing between my iCal v4.0.4 (1395.7) under MacOSX.6.8 Build 10K549 and my Calendards under iOS 6.1.3 (10B329) on an iPad 3rd generation is erratic and unreliable.  I do not use iCloud and syncing is done via USB cable and iTunes v11.0.2 (26).


What makes it worse is that the symptoms change!


Currently, appointments created on the iPad do not sync across to iCal but appointments created in iCal do sync across to the iPad.


Previously, existing appointments shown in iCal but which are subsequently edited show in iCal as expected but on the iPad as both the old and new entry.  Also, when creating an appointment in iCal the edit panel opens in the default calendar which is then changed to the correct calendar and actual data - the default panel and edited data both appreaded on the iPad.


I have recently noticed that iCal periodically, yet rarely, presents a message when opening: Upgrading iCal Calendars and when this has completed, syncing returns to normal.  However, I have no idea what prompts that message nor how I could manually start an "upgrading" so that I can force a syncing correction.


Complicated?  Well, it is rather difficult to explain what I mean as the problem is so erratic and inconsistent.


I have tried the Apple suggestion here: http://support.apple.com/kb/TS1627 and it made no difference whatsoever. 


In short, how can I get the iCal and Calendars to sync reliably and acurately?


My forehead is somewhat flattened after I have spent many hours beating my head against a brick wall over this - please help before the wall gets damaged beyond repair! 


Message was edited by: iBozz to correct stupid typos!

  • Ferd II Level 7 (25,780 points)



    Since your post mentioned "Upgrading iCal Calendars..." you may want to try removing the com.apple.iCal.plist file from your Macintosh HD/Users/yourusername/Library/Preferences Folder. Quit iCal, and drag the .plist file to your desktop.


    Then go to your Macintosh HD/Users/yourusername/Library/Calendars Folder and remove any files with "Cache" as a part of the file name. Log out/in, or restart and check Calendars for functionality.


  • iBozz Level 1 (90 points)

    Thanks, ferd.


    I've tried what you said and it has, alas, made no difference.


    I've looked at it a bit more and can report that entries made on the iPad's Calendar app are currently not sync'd across to the iMac's iCal, nor are changes to times of appointments on the iPad carried across to the iMac.


    Entries made on the iMac's iCal are, however, carried over to the iPad, but appointments changed on iCal are shown on the iPad as both the old and new timings.


    In addition, I subscribe to four external calendars, two public and two private.


    The private ones behave as expected, but the two public ones show correctly on the iMac but not on the iPad. 


    One of them ...




    ... appears as "All Day" items on the iPad several times each day.  I can't be sure, but I guess (speculation until proven one way or the other) that wundergorund update their forecast several times a day and the iMac/iCal version shows the correct and latest update whereas the iPad "remembers" and shows each previous update and these are not deleted after I sync the device.


    The second one ...


    http://www.google.com/calendar/ical/s22hiqne2bv9o3ilraq9p7ama0%40group.calendar. google.com/public/basic.ics


    ... is even more bizarre.  This is a sports team fixture calandar which is updated after games in order to show the scores.  For all games, the entries show once on the iMac but on the iPad the game played on 20 April appears twice - once as a "fixture" with no scores and once again as a "result" with the scores!  As far as I can see, that last game is the only one shown twice, all others show either as a future fixture or a past result!


    I have agian sync'd without Calendars being included in the sync data, turned off the iPad, restarted it, resync'd with Calendars included - and all the "incorrect" data has reappeared!  The iPad is clearly being fed data which includes appointments deleted from iMac/iCal (or is somehow remebering them itself) and i cannot imagine from where this "memory" comes.


    So from where is the iPad picking up the information?  I presume that the "historical" (i.e. changed) data comes from a cache file somewhere - but on your suggestion I have deleted the cache file in ~/Library/Calendars and also the ~/Library/Preferences plist file.  So it can't be from either of those.


    Upgrading the Calendars last time seemed to correct the problem, but that may well have been a coincidence.  Odd though, that it all appeared as expected after the "upgrade" - but this time that didn't work.


    I back up the iMac (including Calendars) to a Time Capsule every 6 hours and also, inter alia, Calendars to DropBox and a virtual disk on my ISP's servers every 24 hours, but I can't see why, or indeed how, syncing would look to any of those sources.  In any event, even if they did, surely any anomalies would iron themselves out each day?


    I am totally bemused by all of this, and not a little irritated as if I cannot rely on the accuracy of the iPad and iMac calendars then they are a waste of time.


    I confess to disliking Mountain Lion intensely, but I may have to consider upgrading merely to get my calendars synced acurately over iCloud.  It isn't a step i'd take lightly as I don't like the way ML works (I've seen it on a friend's machine and I am seriously unimpressed!) so I would prefer to get this resolved under Snow Leopard.


    Have you, or indeed anyone else, any ideas where to start looking for this "needle in a haystack" glitch/bug/undocumanted feature?

  • Ferd II Level 7 (25,780 points)


    Have you, or indeed anyone else, any ideas where to start looking for this "needle in a haystack" glitch/bug/undocumanted feature?

    One last suggestion that I can think of is to attempt Resetting the SyncServices folder. Make sure that you follow the backup recommendations, and use the Lion/Snow Leopard section instructions.


  • iBozz Level 1 (90 points)

    Well, being a bit short of time (and an alleged alpha type male who always rushes ahead of common sense!) I followed your instructions and added a few thoughts of my own along the way - specifically that iTunes might somehow be implicated in this curious affair as that was being used for the syncing. process.


    The result is, I hope you'll be delighted to know, success - syncing is now back to what I would have expected and what nature intended.


    For now that is, because there have been false dawns before and I expect the problem to return and haunt me again at some stage.


    But next time I'll be ready and will know how to confound and defeat the Apple Agents of Confusion!.


    What I did was ...


    • backed up iCal to the Desktop in case it all went horribly wrong;


    • sync'd without iCal/Calendars being checked in iTunes and thus all iPad calendars were initialised;


    • powered off the iPad to remove any "RAM" type data being maintained;


    • as earlier, deleted the iCal plist and all iCal/Calendar cache files but this time not only from the main user but from my DropBox and MacMate on-line back-ups (but not from Time Capsule as I wanted to have a fall-back position if it all went pear-shaped) by using Spotlight to look for all Calendar cache files wherever they might be.  I found a number of "document" files called Calendar Cache 17-22-4n n, one per day, stretching back to 23 03 2013 and these were located in my Dropbox folder.  Maybe that's the date when the current errors started to arise?  I really can't remember, but why would the iPad be looking for such files in my DropBox folder?  Most odd.


    • reset the SyncServices folder;


    • deleted the iTunes plist in case the "memories" of earlier appointments were in there - a long shot and probably a useless step, but I couldn't see any harm in doing it;


    • logged out of my user and then back in again;


    • relaunched iTunes to recreate a clean plist and then reset my preferences.  Quit iTunes;


    • relaunched iCal to recreat a clean plist and then reset my preferences;


    • turned on the iPad and connected it via USB lead;


    • opened iTunes and reset the syncing options which were erased by resetting the SyncServices folder ealrier;


    • sync'd the two devices.  iTunes reported that the iPad was "sync'd with another user" and asked if I wanted to Merge the data or Replace the data on the iPad - I guess that meant all data and not just iCal data as the latter had been cleaned from the iPad in the second stepo above.


    • Selected Replace data and sync'd;


    • entered a new appointment on iCal, another new one on the iPad and edited the times of an existing appointment on each device and re-sync'd ...


    ... and Robert's your mother's sister's brother's other brother!  Or Bob's your uncle, for short.


    Oh, I missed the final and most important step ...


    • breathed a sigh of relief and hit the caffeine!


    I have no idea of which step is the one which resolved the issue so when (note when, not if) it happens again I'll repeat the process one step at a time (re-syncing each step) to see just where in the process the incorrect data is held.


    I'll report back on this thread if I do manage to narrow down the steps to the vital one(s) as I cannot imagine that I'm the only person in the world experiencing this bizarre behaviour.


    As I mentioned in other posts, this has happened more than once before but on those occasions it resolved itself without my intervention - save for me uttering a fair number of good old-fashioned Anglo-Saxon Oaths and Curses all the while the syncing was incorrect - and it was only recently that I noticed it corrected itself after an "iCal upgrade".  That may have been a coincidence, though, as forcing an upgrade deliberately did not cure it this time.


    So I'm pretty confdent it will happen again, but just what triggers this untoward behaviour is beyond me - I can't think of anything that I might do which causes it, nor can I begin to imagine from where the iPad collects the "historical" deleted appointment data which it then displays in addition to the "current" data on appointments.  Nor can I think why it suddenly takes it upon itself to sync (albeit incorrectly) from iCal to iPad but not the other way round.


    I didn't mention this before, but at one point I discussed this with an AppleCare Level 2 Support dweeb in Cork - and he was totally unable to fix it no matter what he tried, nor could he explain what was happenig and why!


    Many thanks for your advice and patience - you may consider yourself a Level 3 (or higher!) surrogate AppleCare Genius! 


    Message was edited by: iBozz to correct a few minor typos.

  • Ferd II Level 7 (25,780 points)

    You are welcome...glad to help, I think?


    Your thorough, inciteful, and entertaining explanation is appreciated.

  • iBozz Level 1 (90 points)

    Help indeed you did!


    Even unto half my overdraft shall be yours! 

  • Leigh Anne in Africa Level 1 (0 points)



    Had the same issue.  This was great, worked perfectly.  Thanks.

  • Ferd II Level 7 (25,780 points)

    You are welcome...glad to help you too!

  • iBozz Level 1 (90 points)

    Either I am going mad, or I am going mad!


    A few days ago my Snow Leopard 10.6.8 Finder stopped responding for no apparent reason, no new software, no downloads, no application or sysytem crash, nothing in the logs.  Nothing would get it to relaunch or indeed do anything so, after trying everything I could think of - not Safe Booting, rebooting, running Disk Utilities, fsck -fy, applejack AUTO or anything else - I reinstalled OSX.6.2 from the DVD and then updated via the 10.6.8 combo and other items in Software Update.


    And, of course, I am now on iOS7.0.2.


    What has this to do with synicng, I hear you mutter, he has indeed gone mad!


    Bear with me ...


    After the reinstallation I sync'd via iTunes and ... the iMac's iCal would copy new appoitments to the iPad's Calendar - but not the other way round!


    But I didn't panic, Been there, done that, got the t-shirt! Have I not been here before and beaten Apple at it's own devous game?


    I ran through all the steps above and ... the iMac's iCal would copy new apponitments to the iPad's Calendar - but not the other way round!


    I did it again, same result.


    So, stymied I went to curl up in the foetal position and have a good cry.


    But all stories should have a happy ending, and this one does as well - untill, that is, it all goes pear-shaped again.


    Earlier today, I added a new appontment on the iPad and, as is by now traditional, it did not copy across when I sync'd just now.  So, I added it to iCal on the iMac and syn'c again and, again as is traditional, it did go that way.


    But ...


    ... there's always a but, isn't there ...


    ... I noticed that an apoointment I had changed earlier today on the iPad suddenly appeared as changed on the iMac!


    A test, without knowlingly doing anything extra, with a new appointment on each device showed that they now both  sync'd properly.


    So we are now "cooking on gas" and all seems to be in beautiful equilibrium again and all is well with the world!


    Until the next time!


    But can anyone explain why the problem should correct itself between this morning's first two syncs after failing for a few days?


    No, neither can I!