5 Replies Latest reply: Apr 23, 2013 4:09 AM by The hatter
tybaltstone Level 1 Level 1 (25 points)

I bought a Western Digital Caviar 2TB internal hard drive for my Mac Pro (2 x 2.66 GHz Dual Core Intel Xeon (late 2006), 12GB RAM, Mac OS 10.6.8). It already has two 500GB internal drives in two of the four slots.

 

I slotted the new WD hard drive in and started up the Mac, getting an alert saying there was an unrecognisable disk and did I want to initialise it? Yes, so it opened up Disk Utility.

 

This showed my two 500GB drives plus the new WD drive at 2TB. To initialise it I erased the disk which failed with an error ("POSIX reports: The operation

couldn't be completed. Input/output error").

 

I next decided to use Partition instead, choosing just one partition of 2TB, Mac OS Extended (Journaled). After 7 minutes it said the process had been completed and the volume was mounted, though it didn't appear on my desktop, just in Disk Utility. I thought a restart would refresh and show it on the desktop.

 

Once the Mac was up and running again there was nothing there at all - and now it wasn't even listed in Disk Utility. I shut down, took the hard drive out,

looked at it, scratched my head, replaced it, and turned the Mac back on.

 

Once again I got an alert telling me the disk was uninitialised and would I like to format it, so clicked OK and Disk Utility opened. This time the disk was

there (WDC WD20EZRX-00DC0B0) but no volume. The info said the drive had a size of 0 Bytes and I could not erase or partition as all buttons were greyed out,

with the Partition tab saying 'this disk is too small to contain partitions'.

 

So what can I do now? According to macupgrades.co.uk this drive should work in my model of Mac (they recommend and sell it, though I purchased it from NORDPC via Amazon as it was a little cheaper).

 

http://www.macupgrades.co.uk/store/product_info.php?products_id=532

 

I tried, with the help of my more computer-literate brother, to erase the disk from the command line via the Terminal, getting a result of "Error: 6: POSIX

reports: Device not configured". (Actually we first tried to reformat it, with an error of "does not appear to have a valid file system format").

 

Does anyone with more knowledge of such things have any ideas or advice? It would be much appreciated.


Mac Pro, Mac OS X (10.6.8), 2 x 2.66 GHz; 12 GB RAM