2 Replies Latest reply: Apr 19, 2013 7:57 PM by Kirby Krieger
Rick King Level 1 Level 1 (5 points)

Aperture has been making me crazy for over a month. 

 

So far I have tried the following (multiple times);

 

1.  Repairing the hard drive

2.  Repairing permissions

3.  Took my imac to the shop for a check up.  Everything checked out alright.

4.  Rebuilt libraries.  I'm a wedding photographer and keep lots of images on external drives (RAW and referenced).  So I make a new library every month or so, but the same issues seem to happen on any library I use.

5.  Running Disc Utility on the 2 external HDs attached.

 

I've had to force quit Aperture more times than I can remember.  All cases of force quit or aperture quitting on it's own sent reports to apple.

 

Just today upgraded to 3.4.4 but problems persist.

 

Issues;

 

Unsupported image format out of the blue.  Most images shot with Nikon D300 or D700 which have been supported for years.  But I might just click on a random image that has been processed and edited, and it will switch to unsupported in an instant.

 

Beachballs from ****.

 

Going to Force quit and seeing Aperture (not responding).

 

Is there a way to uninstall Aperture and re-install?  The only way I see to do this is to go to the app. store and buy aperture which isn't acceptable.

 

Thanks for any help...


iMac (21.5-inch Late 2009), OS X Mountain Lion (10.8.3), 3.06 GHz Intel Core 2Duo 16GB 1067
  • Frank Caggiano Level 7 Level 7 (25,715 points)

    How did you originally purchase Aperture? DVD, Apple web site, or the Mac App Store.

     

    If it was DVD then re-install from that . If you tried the trial way back when and then bought the authorization key then go to  Aperture 3.1 Trial and download the DMG.

     

    In both cases you will need the original Serial number to authorize Aperture. Note if your Aperture 3 was an upgrade from 2 (or 1) you will also need the earlier SN. Once the application is authorize run software update to get to the current version.

     

     

    If you bought from the Mac App Store you can move Aperture from the Applications fodder to the Desktop then log into the MAS with the same Apple ID you used to purchase it and download it again.

     

    However a reinstall may not fix your problems. Actually it has a low probability of helping.

     

    Where is the Aperture library located (internal or external drive)? If external how is the drive formatted?

     

    For troubleshooting purposes try making a new empty library, adding some images to it and run Aperture. Does it have the same problems?

     

    If so make a new user and run Aperture as that user. What happens?

     

    You should also move the preferences file out and see if that makes a difference. See  Aperture 3: Troubleshooting Basics for directions on how to do that.

     

    post back with the results

     

    good luck

  • Kirby Krieger Level 6 Level 6 (12,470 points)

    The OS reporting that Aperture is "Not Responding" should be ignored.  Do not, except in rare circumstance, force-quit Aperture.  Everytime you do force-quit Aperture, you should immediately repair your Library (details are on Apple's Aperture trouble-shooting page).

     

    And follow Frank's sage counsel.  My "scent-in-the-air" hunch is that you are either having data-transmission problems between your Libraries and your system, or you have faulty memory somewhere on your motherboard.  I would reformat all drives, move all Libraries to newly-formatted drives, and then get one Aperture Library to work from your system drive, then start moving outwards (cables, drives) until you recreate the problem.  You should run Apple's hardware test, too.

     

    (Sent from my magic glass.)