Skip navigation

Can a faulty logic board damage a graphics card?

1391 Views 17 Replies Latest reply: Apr 28, 2013 2:44 AM by The hatter RSS
1 2 Previous Next
wms44 Calculating status...
Currently Being Moderated
Apr 20, 2013 5:42 AM

I've been having some issues with my Mac Pro lately. After 4 years I decided to give it a bit of a clean as the dust had ecumalated on the fans.

When I put everything back I got some strange patterns on my LCD. Eventually my Mac Pro settled down and Occaisionally didn't wake from sleep.

 

My mac now boots with the distincive bong! but there is no signal to my monitors.

 

I'd ordered a new Graphics card (sapphire 7950 mac edition) with a view to upgrading and it's arriving on Tuesday.

 

My question is - If there is an issue with my logic board, could it damage the new graphics card when I install?

Mac Pro 2.66GHz Quad - Core Intel Xe, Mac OS X (10.6), G4 (FW800) 1GHz, iPod Touch, Apple TV, PC XP, Dell Laptop Vista
  • The hatter Level 9 Level 9 (58,535 points)
    Currently Being Moderated
    Apr 20, 2013 6:12 AM (in response to wms44)

    if you are running ML then your 2.66 quad is the 4,1 Early 2009.

    But you never mentioned what gpu you have and replacing - GT120?

     

    The 7950 Mac Edition? fine, just follow directions to connect the power cables.

     

    My Review of the Sapphire 7950 Mac Edition.

     

    March 22nd, 2013 -- PART DEUX: Sapphire Radeon HD 7950 versus other Mac Pro GPUs (running StarCraft, Diablo, Team Fortress, FCPX, Premiere Pro, Photoshop, and LuxMark)
    March 19th, 2013 -- REVIEW: Sapphire Radeon HD 7950 versus other Mac Pro GPUs (running DaVinci Resolve, Motion, OceanWave, Heaven 4, Valley, Civilization, and Dirt)

     

    What you should be doing is run Apple Hardware Test off the OEM DVD, and I would have done a fresh clean install of 10.8.x on its own drive, leave what your working system was 'as is' to insure you don't carry forward 4+ yrs of old extensions and stuff that can cause mischief. They do, it does happen.

     

    You think your issues now are with the logicboard? and that is why your graphic card is trouble? Or your card now is only issue? and failing. Made sure the GPU slot is clean and firmly pushed in; same for anything else you removed, and that in cleaning out dust didn't just move some to a new location.

     

    Sounds like the cleaning and reassembly not the logicboard (and not sure GPU).


  • The hatter Level 9 Level 9 (58,535 points)
    Currently Being Moderated
    Apr 20, 2013 10:16 AM (in response to wms44)

    Normal.

     

    Check photos online

     

    pcie slot picture

     

    http://en.wikipedia.org/wiki/PCI_Express

     

    Did you look for photos of 4870

     

    http://www.ebay.com/itm/Apple-Mac-Pro-ATI-Radeon-HD-4870-512MB-PCIe-Video-Card-/ 161001406071?pt=PCC_Video_TV_Cards&hash=item257c6e7e77

     

    http://www.ebay.com/itm/ATI-RADEON-HD-4870-512-MB-GRAPHICS-CARD-FOR-APPLE-MAC-PR O-EARLY-2008-AND-2009-/160967719743?pt=UK_Computing_Other_Computing_Networking&h ash=item257a6c7b3f

     

    Sometimes the little "lock" which is hard to reach or breaks off (optional).

    Making sure just like with DiMMs that it is FULLY seated in the slot, give it pressure.

     

    I read the 4870's age and lack of all the specs and features ML can look for to use, plus that most found the 5770 bench and performs better - compare the two on www.barefeats.com rather than go by subjective tests and 90% of apps will do better (unless they have not been updated, or are optimized maybe for Nvidia architecture).

  • The hatter Level 9 Level 9 (58,535 points)
    Currently Being Moderated
    Apr 20, 2013 3:21 PM (in response to wms44)

    No sign and unlikely.

     

    I keep spares of even video cards around.

     

    I would never use computers w/o a UPS. Lightning and storms and wind do interfere with our power.

     

    As this thread started, it was opening it up and trying to remove dust and putting it back together.

     

    One thread just closed that kept sounding to me like "this is a heat issue" turned out the fans on the front were not turning. A lot of things were tried to get to simple "clean those fans, use SCF 2.4 fan control to boost the fans.

     

    Popele have baked their Nvidia 8800GTs to get them back working. And worked.

     

    I would say you are over reacting but your own effort to clean dust was the only critical issue so far.

     

    People change out video cards all the time, even as part of troubleshooting.

    There are places that do that sort of thing and only charge if parts are needed.

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Apr 20, 2013 3:22 PM (in response to wms44)

    I cannot recall any reports of bad logic boards damaging ANY other components in the several years I have been reading and answering Users' queries here.

     

    Install with confidence.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • The hatter Level 9 Level 9 (58,535 points)
    Currently Being Moderated
    Apr 23, 2013 5:17 AM (in response to wms44)

    Just USE IT

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.