Skip navigation

How to stop AddressBookSourceSync

4601 Views 14 Replies Latest reply: Mar 28, 2014 9:33 PM by Alex Pn RSS
Ray_J Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 20, 2013 7:30 AM

My Activity Monitor tell me this is using up to 90% of my CPU. I also see CalendarAgent, SyncServciesAgent  and Mingle using this much. Where these come from and how can I stop/delete these?

iMac
  • BDAqua Level 10 Level 10 (114,830 points)
  • Linc Davis Level 10 Level 10 (108,160 points)
    Currently Being Moderated
    Apr 20, 2013 4:59 PM (in response to Ray_J)

    Note: These instructions are for OS X 10.8 or later. In OS X 10.7, the procedure is the same, but the application is named "Address Book" instead of "Contacts."

    Back up all data.

    If you use iCloud, uncheck the box marked Contacts in the iCloud preference pane.

    From the list of groups on the left side of the Contacts window, select All Contacts. From the menu bar, select

    File Export Export vCard

    Save the exported contacts to the Desktop, then quit Contacts.

     

    Triple-click the text on the line below to select it, then copy it to the Clipboard (command-C):

    ~/Library/Application Support/AddressBook

    In the Finder, select

    Go Go to Folder

    from the menu bar, paste into the box that opens (command-V), and press return.

    A Finder window will open with a folder selected. Move the selected folder to the Desktop, leaving the window open for now.

    Launch Contacts. Your contacts will be gone. From the menu bar, select

    File ▹ Import

    and import from the file you exported above. Your contacts will reappear.

    Re-enable Contacts in the iCloud preference pane, if you disabled it earlier. Test. If the issue is resolved, delete the AddressBook folder and the vCard file on the Desktop and close the open folder window.

    Otherwise, quit Contacts again and put the AddressBook folder back where it was, overwriting the newer one that will have been created in its place. Post your results.

  • BDAqua Level 10 Level 10 (114,830 points)
    Currently Being Moderated
    Apr 20, 2013 5:41 PM (in response to Ray_J)

    Sorry, Apple changed the name of AB to Contacts, but Linc is here.

  • masterbrowser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 8, 2013 8:36 AM (in response to Ray_J)

    For OSX Mountain Lion, in System Preferences, under Internet & Wireless section go to Mail, Contacts & Calendars

     

    Delete any accounts that you don't need. 

     

    For the rest, turn off (uncheck) all Contacts synchronization except for the one that you need, if any.

     

    At the same time you should turn off any Mail, Calendar and Notes & Reminders as well as any other unused account features.

     

    AddressBookSourceSync was killing the performance of my MacBook until I did this.

     

    No need to fiddle with plist files, etc...

     

    I use Microsoft Outlook 2011 for Personal Information Management functions  anyways.

     

    This fixed the problem for me.

  • Theo Gluck Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jul 23, 2013 4:33 PM (in response to masterbrowser)

    Good tips indeed and I will report back if it solved it for me.  I had TWO Exchange accounts for the same work enterprise server but deleted one, and I actually use Outlook for my work email so hopefully your recommendation will do the trick.  I now just have one exchange account and only checked Calendar and Calendars.  I can see that my calendar is up to date (syncing with my work Outlook calendar) and a test fake address entry added to my work Outlook address book did show up (took about 3-4 minutes) on my Contacts.  Fingers crossed

  • strange cranium Calculating status...
    Currently Being Moderated
    Jul 23, 2013 5:08 PM (in response to masterbrowser)

    I just did what you suggested. I'll keep everyone posted.

    This problem is killing me!

  • Theo Gluck Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jul 23, 2013 9:22 PM (in response to strange cranium)

    hmm...still getting the CalendarSync nuisance flag (and looking back at my original post I meant to say Calendar and Contacts.  Don't know yet if AddressBookSourceSync will reappear as well (so far so good)

  • Theo Gluck Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jul 24, 2013 9:10 AM (in response to Theo Gluck)

    Nope -  problems still persist......

  • Theo Gluck Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jul 30, 2013 6:15 PM (in response to Theo Gluck)

    WELL - I saw this posted on another site:

     

    "I had set my login keychain to lock after 15 minutes of inactivity.  I disabled this, and am now not bothered by AddressBookSourceSync asking me to unlock the keychain."

     

    Mine was set for 5 MINUTES!!! Just did this fix and hopefully THAT will do the trick.

     

    Will report back

  • Theo Gluck Level 1 Level 1 (85 points)
    Currently Being Moderated
    Aug 1, 2013 8:45 AM (in response to Theo Gluck)

    so far so good.......looks like this simple fix was all that was needed

     

    Also realize I did not post that to do this:

     

    launch Keychain Access (make sure your list of sites is open)

    Go to the EDIT pull-down menu

    Selecet "Change Settings" for Keychain Login

  • Axemohan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2014 8:38 PM (in response to Linc Davis)

    I was having the same problem as Ray_J (I am on Lion 10.7.5. and the AddressBookSyncSource process began consuming high CPU ever since I switched on iCloud for contact syncing). Linc's solution has worked. Its only been a few minutes since I did what he suggests but usually by this time the CPU usage would have started. Hasn't so far. Thank you, Linc.

  • John Sawyer1 Level 2 Level 2 (230 points)
    Currently Being Moderated
    Feb 22, 2014 10:16 PM (in response to Linc Davis)

    Thanks, Linc.  Your procedure fixed my problem, which was essentially the same one Ray_J was seeing--Activity Monitor showed the process "AddressBookSourceSync" eating up 100% and more CPU time, even when the Contacts application wasn't running, so apparently something had gotten messed up in my ~/Library/Application Support/AddressBook folder, which was also messing up iCloud's attempt to sync my contacts.  AddressBookSourceSync was also using tons of RAM, including about 1.7 gigagbytes of virtual memory, eventually creating so many swapfiles that it filled my Macbook's hard drive so that I couldn't really use the Mac.  When I launched the Contacts application, it too spiked CPU, RAM, and virtual memory usage.  Once I followed Linc's procedure, these problems stopped.

  • Alex Pn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2014 9:33 PM (in response to John Sawyer1)

    Linc's steps above have solved my problem. Just adding some more to my symptoms, the problems started once I turned on iCloud. I would also get the situation where I could update a contact on the Mac, and then a few seconds later it would revert to the previous version, as if Contacts and iCloud were confused. If I went to icloud.com with my browser and updated the contact there it would behave. Never really liked iCloud because of this. The steps above appear to solve this issue and also the CPU performance. System monitor no longer shows the process AddressBookSourceSync consuming CPU, in fact I hardly see it.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.