5 Replies Latest reply: Apr 22, 2013 9:17 AM by Alix Leigh
mish.1982 Level 1 Level 1

I am having trouble with Home Sharing....itunes shows home sharing is on however apple tv is not picking this up. I have read posts going back to 2012 that say this is a known issue, has there been any resolution or is there anything I can try??? thanks..

AppleTV 2
  • Rudegar Level 7 Level 7

    if you run with a firewall you need to allow itunes to share it's lib

  • Sandancer Level 1 Level 1

    Apple have done nothing, they just ignore this issue. Home sharing has not worked for me since the upgrade  to iTunes 11. Some People are buying new Routers changing their network configurations but to no avail. I have spoken with apple technicians for over 20 hours ( telephone). They would not accept that the issue was due to iTunes. Everything was tried with my network but the problem was never found. I made my network as simple as possible, because Apple told me that my network was to complicated. My simple network was a Cisco 3010 modem from my cable TV company, Apple AirPort Extreme and the ATV2. With this setup I could play one maybe 2 songs then it would lose the connection. I gave up in the end and told Apple that I was not interested in their help anymore. I was told that I could ring again anytime and they would continue to troubleshoot the problem.

    Everything else works on the ATV2 Netflix, podcasts in fact all of the apps. I only use my ATV2 for Netflix now. I use my Synology Diskstation to stream my music and videos from my computer to my TV,

    . I can also use DNLA to stream over my network without any problems, but homesharing it's a JOKE!

    Kind regards

  • Rudegar Level 7 Level 7

    then let them know they don't read or write in these forums


  • Sandancer Level 1 Level 1

    I have already done that. I am sorry for explaining what happened to me, I Will not let it happen again. It was not my intention to annoy anybody. I just thought that it might help to know that there are others having problems with homesharing.

    Kind regards.

  • Alix Leigh Level 2 Level 2

    Sandancer wrote:


    Home sharing has not worked for me since the upgrade  to iTunes 11.


    I had this happen once on an iTunes upgrade - not sure why but iTS upgrades DO seem to confuse ATVs occassionally.


    Some Options:

    If you have another home share device, try connecting to that first.


    One other thing that worked was a total reset. Then I followed Apple's instructions as if I was setting up for the first time. The counterintuitive part was that iTunes needs NOT running when you first enter info in ATV. THEN atv gives you a code to enter. At that point you open iTunes. (truly bass ackwards). Don't recall if I tried, disabling then enabling Home Sharing on the computer.


    Anyway, don't dismay. iTunes 11 DOES work with ATV.

    You should also look at the following article which discusses port settings for iTunes, ATV etc.:

    Well known TCP and UDP ports used by Apple software