1 Reply Latest reply: Nov 7, 2014 6:03 AM by adadad26
ajkirkpatrick Level 1 Level 1 (0 points)

I have a Pioneer X-SMC-4-k AirPlay compatible device. It shows up in my iPhone AirPlay list consistently and works quite well.

 

From my Macbook (10.6.8), I can access it as an "output device" if I hit the square-and-triangle AirPlay logo in iTunes and select the unit. This works just fine.

 

However, the unit does not show up in the "Output Device" list in System Preferences>Sound. Since it doesn't show up here, I can't route non-iTunes audio to the unit, so I can't use Pandora with it from my laptop. I've also tried holding OPT+clicking on the volumen/sound menu, and it doesn't show up there. Even if I'm streaming audio via AirPlay in iTunes, it doesn't show up in the list. I'm using a Netgear WGR61-4 router and not an AirPort, but this shouldn't matter, right?

 

Anybody know if this is a known issue, if it's fixed in 10.7, or if there's a way to re-build the "Output Device" list or manually add something to it?

 

Also - bonus question - anyone know of an iPhone app that controls AirPlay output? Pandora will play to AirPlay if you first select the device in the Music player, but if you lose connection, you can't select the AirPlay device in Pandora (or Spotify, etc.). How about an app that can quickly switch to AirPlay?

 

Thanks, AirPlay users!


MacBook, Mac OS X (10.6.8)
  • adadad26 Level 1 Level 1 (0 points)

    Hi

     

    I don't know if you're still having this issue but there is a way round it as I'm having the same troubles.

     

    I've just spoken to Apple about it and found out:

    – If you have a Mac made before Mid-2011, it doesn't have a piece of hardware needed to take advantage of the 'Airplay mirroring'

    – So you can update to a later version 10.6.8+ but this won't help at all

     

    The way round it:

    – Download 'Airfoil' and install this

    – You can then play music from any defined source (Spotify, Quicktime etc) through your Airplay connected speakers

     

    So sadly, for those have a Mac from before Mid-2011 there's isn't an option that's as easy as Option-click on the sound icon to switch to Airplay speakers.

     

    Hope that helps, I can now get on with the rest of my day now after sorting this out.

     

    Adam