12 Replies Latest reply: Apr 22, 2013 9:38 AM by Eric Root
jefferson Moore Level 1 Level 1

I use the TextEdit app to keep a running log on my files.  I upgraded to a new computer that uses OSX 10.8.3 and now when I open a new TextEdit document I can no longer save it to a new file. I can only select iCloud, Dropbox, and/or the last few files I have opened.  I used to be able to save new TextEdits in Dropbox and scroll to the exact file I wanted to save the document or create a new folder within Dropbox.  Anyone know how to reset TextEdit's save feature to be able to create a new folder or at least be able to scroll to a folder within Dropbox? I looked through TextEdit Preferences and System Preferenes and could not find anything. Thanks!


iMac, OS X Mountain Lion (10.8.3), TextEdit
Solved by jefferson Moore on Apr 21, 2013 10:16 AM Solved

Hi CT,

 

It does not happen when I use other applications. It is a new computer and I purposefully decided not to import anythng from the other computer to keep this one as clean as possible.  I had to put on my scanning software, Adopbe PDF, and my password program, but other than that, the programs and apps are all Mac's. 

 

I have real work to do at the moment and will get to the safe mode attempt later.  But thanks for the help!

Reply by Eric Root on Apr 21, 2013 10:13 AM Helpful

Select Save. In the box that appears, which has iCloud by default, the iCloud is part of a drop down menu. Select something else.

 

Screen Shot 2013-04-21 at 1.08.10 PM.png

 

Screen Shot 2013-04-21 at 1.08.50 PM.png

At this point, the triangle is no longer greyed out and you can select it to show more.

 

Screen Shot 2013-04-21 at 1.09.06 PM.png

All replies

  • Barney-15E Level 8 Level 8

    You can Duplicate the file, then when you save it asks where. If you have Documents selected in iCloud system prefs, it defaults to saving to iCloud.

     

    If you want to Save As..., hold down the option key while selecting that option from the File menu.

     

    There is a hidden preference that can be set so you can still use iCloud to store some documents, but not have it default to iCloud.

  • CT Level 6 Level 6
    expertise.notebooks
    Notebooks

    Maybe this:

     

    In the save dialog click on the little triangle next to the box where you put the file name.

  • jefferson Moore Level 1 Level 1

    Thanks, but that is the problem.  The little triangle next to the box were you put the file name is greyed out and not usable with the new version of TextEdit.  Not sure why they would redesign the app to give less choices on something as important as file saving options.  The "Where" box defaults to iCloud or  gives you a choide to major files such as Dropbox, Apps, photos, desktop, etc.  and to "Recent Places" and no more. 

  • CT Level 6 Level 6
    expertise.notebooks
    Notebooks

    Well, something is interfering with your application.  I have all the latest software and the little triangle works fine.

     

    Does this happen for a different user?

     

    Does this happen starting up in Safe Mode?

  • jefferson Moore Level 1 Level 1

    Thanks Barney.  Yes, duplicating the file is a work around and I will use it for now.  I was hoping that I could set a preference or something to have TextEdit save new files like it used to.  Not sure why a redesign would limit options for saving files.  That, to me, is crazy. Using the duplicating feature means more clicks to get it to do what I used to be able to do more easy.  I hate "improvements" like this to an app. 

     

    I have "Documents and Data" checked in my iCloud preferences and when I uncheck it warns me that unchecking means that if I turn it off then all documents stored in iCloud will be deleted from the Mac.  Not sure if I want to do that or nor.  I don't like using iCloud for storage, but I think my photos from my iphoneare on there and I am not sure I want to keep those deleted off of this Mac as I use some photos for work related items and this is a work related Mac.  What do you think?

     

    I would like to try a "save as" option, but that does not even come up when the "File" menu is selected.  Using the command key does not make it appear either. 

     

    And thanks for the advice about a hidden preference for iCloud.  I have not found it, but I amnot sure why they would hide such a preference either. 

     

    I switched to Mac a few years ago because they were so much better than PCs. Now, they seem to be creeping into PC **** with unnecessary changes to apps that do not make any sense to me. 

  • jefferson Moore Level 1 Level 1

    Hi CT,

     

    I'm the only user for this Mac, so I don't know if another adding another user is what will make it work (for that new user or for me).  I'll try it using safe mode on another day. Thanks for the advice!

  • jefferson Moore Level 1 Level 1

    And I have the latest update too.

  • CT Level 6 Level 6
    expertise.notebooks
    Notebooks

    The purpose of trying a new user and safe mode is simply to help determine if something else you have installed is not playing nice with TextEdit (or your system in general - does this same problem occur with other applications?).

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    Select Save. In the box that appears, which has iCloud by default, the iCloud is part of a drop down menu. Select something else.

     

    Screen Shot 2013-04-21 at 1.08.10 PM.png

     

    Screen Shot 2013-04-21 at 1.08.50 PM.png

    At this point, the triangle is no longer greyed out and you can select it to show more.

     

    Screen Shot 2013-04-21 at 1.09.06 PM.png

  • jefferson Moore Level 1 Level 1

    Hi CT,

     

    It does not happen when I use other applications. It is a new computer and I purposefully decided not to import anythng from the other computer to keep this one as clean as possible.  I had to put on my scanning software, Adopbe PDF, and my password program, but other than that, the programs and apps are all Mac's. 

     

    I have real work to do at the moment and will get to the safe mode attempt later.  But thanks for the help!

  • jefferson Moore Level 1 Level 1

    Hi Eric,

     

    This solved it!  Thanks! 

     

    (Heck!  I hit the "This sovled it"  button and it attached to my previous reply to CT.  Sorry about that!  Not sure what happend there.  I tried to edit the points, but all I can do now is give you a helpful point.) 

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    I'm glad it solved your problem. Don't worry about the points - they aren't as important as helping someone.