14 Replies Latest reply: Jun 12, 2006 5:55 PM by Rose Healy
aiund Level 1 Level 1 (0 points)
I keep getting a pop up window saying that the smtp.mail.mac server or whatever doesn't recognize my password and that is rejecting it. I tried using the question link on this and have done what is says to do to reset my password and it is not working. I don't know what else to do. I called apple and they said that I had to use the internet to fix the issue. I can't use mail at all. It lets me compose a message but keeps it in the outbox because my password is always rejected. If anyone could help that would be wonderful.

iMac G5, Mac OS X (10.4.6)
  • Allan Sampson Level 10 Level 10 (123,375 points)
    As a first step, try running Keychain First Aid on your login Keychain via Keychain Access located at Applications > Utilities > Keychain Access.app.

    Have you been able to successfully send messages with your .Mac account and the .Mac SMTP server previously and this is a recent problem?
  • William Fisher2 Level 1 Level 1 (55 points)
    I have had a version of the same issue.

    I had two email accounts (.mac and bellsouth.net) both worked fine with Mac Mail until I went on the road with my MacBook Pro. Nothing would let me send mail out, so I changed port on .mac outgoing mail server to 587 from 25 and it worked.

    Same fix did not work with bellsouth, and I have tried to add a third business email account and incoming works fine and outgoing fails for the same reason of "not recognizing the server"
  • Allan Sampson Level 10 Level 10 (123,375 points)
    When connected to a different ISP than your own when on the road, it depends on the ISP used for connecting to the internet regarding the required settings when using an SMTP server not provided by the ISP.

    Some free internet access provided at hotels do not support using an authenticated SMTP server such as the .Mac SMTP server. In that situation, changing authentication to None will usually resolve the problem. For others, using Port 25 instead of 587 is required.

    Some require an authenticated SMTP server and if the BellSouth SMTP server is not authenticated, this is why you could not send messages with your BellSouth account and SMTP server on Port 25 or 587.

    For the most part when traveling and using an ISP to connect to the internet other than your own, you need to check with the ISP to determine their required settings when using an SMTP server not provided by the ISP.
  • aiund Level 1 Level 1 (0 points)
    no i could never send a message. I just set up my .mac account today and now I can send messages to it, just not send them out. I have never taken the computer on the road as it is not a laptop. So, I know that isn't the problem. My internet does run off airport. I don't know if that has anything to do with it.
  • aiund Level 1 Level 1 (0 points)
    I will try doing a first aid on the keychain. I did get in there today for the first time, but didn't know how to do anything with it.
  • Allan Sampson Level 10 Level 10 (123,375 points)
    My previous reply was to William.

    You can receive messages with your .Mac account but not send message with the account.

    The .Mac SMTP server settings should be as follows:

    Outgoing Mail Server: smtp.mac.com

    Server Port: The standard SMTP server port is 25 but try entering 587 in place of 25 in the Server Port field and when finished, select OK to save the changed setting.

    Go to Mail > Preferences > Accounts and under the Account Information tab for your .Mac account preferences at the SMTP server selection, select the Server Settings button below to view or change these settings.

    Use Secure Sockets Layer: Off or not selected.

    Authentication: Password

    User Name: The portion of your .Mac email address in front of the @ sign only.

    Password: Your .Mac account password - the same password used to check the incoming mail server for new messages.

    If these settings are correct and entering 587 in place of 25 in the Server Port field does not work, are you accessing an email account and SMTP server in Mail that is provided by your ISP used for connecting to the internet

    If so and you can successfully send messages with this account and SMTP server, select/use your ISP's SMTP server to send mail with your .Mac account which is invisible to all recipients.

    Most, if not all ISPs now block the use of SMTP servers that are outside of their network on Port 25. Some ISPs allow the use of an authenticated SMTP server only that is outside of their network on Port 25 but some block its use regardless even when using 587 for the SMTP Server Port.
  • Dale Richards1 Level 1 Level 1 (5 points)
    Sometimes you will get this message if the server is busy and just simply not accepting mail fetch requests. It appears that the program assumes your password is being rejected when this happens and asks for the password. Solution: Wait a while and retry. This happens quite a bit for my university pop account.
  • aiund Level 1 Level 1 (0 points)
    I tried the Keychain first aid. It didn't work. It says there are no problems and mail is still rejecting my password
  • aiund Level 1 Level 1 (0 points)
    I tried doing what you suggested and it still doesn't work. It has never worked since I tried to set mail up 2 weeks ago. So, it isn't necessarily that it is busy I don't think. It just hasn't ever worked.
  • Allan Sampson Level 10 Level 10 (123,375 points)
    Are you accessing an email account and SMTP server in Mail that is provided by your ISP used for connecting to the internet and if so, can you send messages with this account?
  • aiund Level 1 Level 1 (0 points)
    I did this and it works! I had to leave it on 25 however. Thank you so much for your help. I am so excited.
  • Sari Kadison-Shapiro Level 1 Level 1 (75 points)
    I have a similar problem. I have a domain name so my mail is forwarded from a different server than my ISP.
    My "send" or smtp settings work fine.
    My incoming settings do not...but only on my laptop computer. On my desktop they work fine and they are the same!
    This is a recent problem. My last incoming message was yesterday at noon.
    (on my laptop. As I said, everything works fine on my desktop machine.)
    I tried fixing the keychain permissions and it found nothing wrong.
    I deleted any keychains for my mail that were as new as yesterday.
    It comes back with the denied request so quickly it makes me think that my mail server at my domain name host did not really get it...that the settings are somehow wrong on MY end. I have fixed disk permissions and restarted.
    I'm at a loss.
  • Sari Kadison-Shapiro Level 1 Level 1 (75 points)
    Go to the Keychain utility. Find the Mail keychain and check the checkbox that says "show password".
    You can see what has been set for your mail password.
    In my case, it was totally different than I had thought.
  • Rose Healy Level 1 Level 1 (5 points)
    I had the same issue and followed the suggestion of a post I saw on this site and it worked. If you have more than one mailbox, highlight the one you want to fix, go to Mailbox up in the toolbar and click on Rebuild. It worked great for me....just figured it out today after going crazy for weeks. Hope it works for you.