Previous 1 2 Next 26 Replies Latest reply: Dec 25, 2014 8:25 AM by brunolaturner Branched to a new discussion.
ojjo8 Level 1 Level 1 (0 points)

My macbook air can't find the home wifi. It can, however, find the neighbours' wifis. The home wifi is working fine with my other laptop and iphone so the wlan router is working.

 

I can't add the network by manually entering its name (says "no network found")

 

This happened suddenly without any changes to my computer or the wifi settings.

 

My computer is a 1-year old macbook air. I haven't found any threads with a real, working solution for this issue so any help is greatly appreciated!

 

Thank you


MacBook Air, Mac OS X (10.7.2)
  • dominic23 Level 7 Level 7 (32,940 points)

    Power off the router. Unplug it from the wall. Wait a while.

     

    Plug it back to the wall. Power the router on. Wait until all the lights are lit properly. It will take a while.

     

    Restart the computer.

     

    For more on this:

     

     

    http://support.apple.com/kb/HT4628?viewlocale=en_US&locale=en_US

  • ojjo8 Level 1 Level 1 (0 points)

    Do you honestly not think those were the first two things i did when i encountered the problem...

     

    And unfortunately no, neither option works.

     

    Thanks

  • kl01 Level 1 Level 1 (0 points)

    Can I please resurrect this thread and ask if your issue has been resolved? I have exactly the same problem and I have no clue what to do. I urgently need Internet for my work and I'm now stuck :((

  • Wendylangley Level 1 Level 1 (0 points)

    Same here. And the article referenced in the other similar posts gives no help for those MacBooks that aren't picking up wi-fi when every other device in the house. Any resolutions?

  • J Soren Level 1 Level 1 (120 points)

    ojjo8 wrote:

     

    Do you honestly not think those were the first two things i did when i encountered the problem...

     

    And unfortunately no, neither option works.

     

    Thanks

     

    Many people do not power cycle their routers when having wifi issues.

     

    When attempting to get help here or on any forum always include everything you have attempted to solve the issue and never assume anybody knows what you have or haven't done unless it is explicitly stated.

     

    Next troubleshooting steps:

     

    - Network Preferences > Advanced

      Delete all preferred networks, restart

     

    - Change your router's wifi channel to a channel > 5 from the one in current use

  • kl01 Level 1 Level 1 (0 points)

    Maybe I ask what is  router's Wi-Fi channel? Excuse my lack of knowledge in computing

  • J Soren Level 1 Level 1 (120 points)

    k,

     

    Devices (computers, tablets, smart phones, etc.) interact with wireless routers by receiving and sending  packets of data. These packets are transmitted by radio waves.

     

    Home wireless routers transmit in the 2.4 GHz (2400 MHz) and 5 GHz (5000 MHz) ranges, meaning (in the case of 2400 MHz) from 2400 - 2484 MHz.

     

    Wireless routers divide this frequency range into different channels in order to avoid interference.

     

    Government regulatory agencies in charge of communications determine the channels available for commercial use. In most of the world, there are 14 commercial wi-fi channels. In the U.S. there are 12.

     

     

     

     

  • kl01 Level 1 Level 1 (0 points)

    Captura de pantalla 2013-05-23 a la(s) 6.40.00 p.m..png

  • kl01 Level 1 Level 1 (0 points)

    I have checked it doesnt seem to be a problem of the interference as all my other devices are working fine in the same room. This appears to be a setting in macbook pro  mid 2012 batch as I realise there are loads others experiencing the same problem with this line. I am just wondering what it could be. If I am to bring it to Genius Bar I dont know what to say and what to show them as the macbook clearly shows intermittent connection and i can know it will just "magically" work when i bring it there.

     

    Any advice or recommendations what we should do next??

  • tweet tweet Level 1 Level 1 (0 points)

    Same problem won't detce my home wifi other device works just fine :( any idea

  • Huffet Level 1 Level 1 (0 points)

    This has just happened to me twice today, out of the blue. Have deleted all preferred networks and restarted, network came back automatically, but don't know how long this will last.

    No problems with any of our other devices ie iPad, iPod-Touch, and iMac, just the Macbook Air.

     

    The MBA was seeing all other local networks except its own, as if it was having some sort of amnesia attack.

     

    Somebody at Apple needs to sort this asap, as it seems to be a common problem.

  • IanFraff Level 1 Level 1 (0 points)

    I had exactly this problem with a new MacBook Pro.  All other Apple devices (and non-Apple) in the house were fine, and the MBP recognised all my neighbours' wifi networks!

     

    This simple fix though worked for me -

     

    https://discussions.apple.com/thread/5016957?start=0&tstart=0

  • carbon_dragon Level 1 Level 1 (70 points)

    There is a 36 page thread on this subject about the MBA 2013 and wifi connectivity. I don't think there is a fix ready to go yet. I'm not even sure Apple is admitting to the problem yet, but there is considerable useful information on the other thread. I solved the problem by buying a Airport Time Capsule from Apple. Now the MBA is happy and has really quick wifi (802.11AC).

     

    There is a rumour of a test fix for some customers with varying effectiveness. There are lots of suggestions. Go read the thread.

  • nirmals44 Level 1 Level 1 (0 points)

    I have faced the similar issue as my macbook cannot detect my home wifi, whereas it can detect my neighbour's.

    Here is the steps i did to fix, hope it will help to you guys.

    1. Go to system preferences, network

    2. Keeping your wifi off, set the location as Automatic

    3. Go to advanced and remove all the preferred networks and click ok and save the changes.

    4. Restart the modem and give a try. If it connects then fine. But if doesnt connect then follow the next steps.

    5. Open the factory ipaddress of the modem in a browser, Mostly it will be in the back of modem. (For eg it will be 192.168.1.1).

    6. After authenticating, go to wireless option, choose the wireless mode & Channel mode as auto

    7. Click ok and save the modem configurations.

    8. Restart the modem and try to switch back the wifi in macbook to on.

    9. It will detect.

     

    This is my first post here, So let me know for anyone if my steps worked.

     

    Regards

    Nirmal

Previous 1 2 Next