Problems with permissions in 10.6 and an external harddrive

6 Replies Latest reply: Apr 26, 2013 8:32 AM by Dave McKenzie
Dave McKenzie Level 1 Level 1 (0 points)

Having problems with write permits on my external harddrive

 

Hello.

 

First time ever that I encountered Linux and Unix today when I was in a computer store, trying to get help with my external harddrive.

 

I have a MacBook Pro 17" with a SSD 256 drive. I recently switched from my initial 128 GB SSD drive to this bigger drive. Only used Carbone Copy Cloner and that was no problem. The only thing was when I started the new disk I asked for the "User permision folder" (or something like that). Otherwise it works fine.

 

I also have a 2TB hard drive that have crashed. But before it crashed I used Disk Warrior on it an managed to back up everything on a new 2TB WD hard drive.

 

Seems like I managed to get all the info from it, but after copying it, something has changed with the permits to read and write.
The disk is open to all users (set under the "Get Info" folder)

 

I went into the store and a really friendly guy helped me with doing some stuff in Terminal and he discovered that there was a + sign behind RVX ending on the folder and files.
He said that this means that only the Root Admin can change this and this is the reason I have to enter Password everytime I try to change any of the files.

 

The "Group" that this drive has is called "Staff" but I dont have a user on my computer called "Staff".

 

I now need help to either add the group to my computer so that the disk recognizes the Macbook Pro as a "friend" or need instructions how I can re-write the disk so that it´s opens up to be used by all computers (or at least mine)

 

 

Best Regards

 

Dave

MacBook Pro, Mac OS X (10.6.8), Apogee Duet2, Western Digital Disk.
  • Alberto Ravasio Level 4 Level 4 (3,535 points)

    The group staff is the default group every user you create on your computer belongs to. So there is nothing wrong with it.

     

    Now, the plus sign at the end of the permissions triplet, means that there are ACLs associated to that file/folder.

     

    As a first step, to solve your problem you can start ignoring ownership on the 2TB external hard drive

     

    001.png

    I didn't have an external disk at hand to take a picture, so I used the first one I found googleing.

    This is the reference link. I hope Topher Kessler, the author of the article, that often write on this forum, could forgive my laziness

    May also be necessary to remove the ACLs, but let me know if ignoring ownership is enough.

  • Dave McKenzie Level 1 Level 1 (0 points)

    Hello and thax for responding.

     

    No, that was one of the first things we tried.

     

    My helpful guy in the store went into Terminal and tried to figure out why all the files were tied to Administrator and needed Root password to move or delete.

     

    Even the folder that he created via Terminal (he added a folder just to see what happended) got the + mark after it and was there by not able to move or add files into, without admin password.

     

    I also used the 10.6 startup DVD to go in and try to reset the ACL for my internal SSD drive, but that did not seem to help either.

     

    There is something about these files and disk that is not giving my Macbook permissions to change the info.

     

    Can also maybe be good to know that before the disk crashed, I managed to use time maschine to back it up. I hooked up the disk to my computer, added another backup disk and backed up my Internal MacBook drive together with the (about to) crashing disk. Then I copied the info from this time machine disk on to the New Drive.

     

    What I believe I need is to re-write the permissions on the disk so that not only admin are allowed to change the info but I have no idea how to do that.

     

    Hope this gives you a little more of a clue what´s is going on and that you have an idea how to solve it.

     

    Thanx

  • Alberto Ravasio Level 4 Level 4 (3,535 points)

    Can you please post a screenshot about the info window of the 2TB disk that shows Sharing and permission?

  • Dave McKenzie Level 1 Level 1 (0 points)

    I guess this is the one you mean.

     

    Screen shot 2013-04-25 at 9.34.14 AM.png

  • Alberto Ravasio Level 4 Level 4 (3,535 points)

    Yes, it is.

     

    Let's start removing ACL.

     

    Open Terminal. The volume New Music Drive must be connected to your computer.

    Copy and paste the following line into Terminal and confirm

     

    sudo chmod -R -N /Volumes/New\ Music\ Drive/
    

     

    type in your password when prompted to do so and press enter. It'll take a while to complete the command, depending on how many files the disk contains.

     

    I guess dreddfulmusic is your user. At the end the of the Terminal command, the picture you posted should have in Sharing & Permissions only 3 items

     

    • dreddfulmusic
    • staff
    • everyone

     

    If that is so, you shouldn't have any problem manage the entire disk. If not, please report here.

  • Dave McKenzie Level 1 Level 1 (0 points)

    That totally fixe the thing!!!!

     

    Thanx a million!!!!

     

    Thanx thanx thanx

     

    Dave