3 Replies Latest reply: Apr 24, 2013 11:26 PM by K_Haubold
K_Haubold Level 1 Level 1 (0 points)

I connected my Westen Digital ext. HD to my Mac and couldn't get it to show up. Just for kicks, I connected it my my Airport Extreme (2nd ed.) and sure enough, it shows up just find and I can fully access it from my computer view the network. I know the USB port on the Macbook is fine because other hard-drives work. I also know the cable is fine, because I'm using the same one to go to the router. Not sure if this is a software or hardware problem, but if it's showing up via the router, I am thinking probably something with my computer, right?


MacBook, Mac OS X (10.7.5)
  • OGELTHORPE Level 8 Level 8 (37,380 points)

    How is the WD HDD formatted?  Does it show in Disk Utility?

     

    Ciao.

  • CaptH Level 1 Level 1 (55 points)

    Was it showing up before and it "disappeared" or is this the first time you ever tried it and it didn't show up?

     

    You could check your preferences in Finder by clicking on the workspace, click on Finder, then preferences. Under "General" there will be a list of things that will or won't show up on the desktop.

     

    If you do as OGELTHORPE requested and used Disk Utility and it doesn't show up, try this:

     

    1. Open Terminal.app under the Utilities folder.
    2. Enter the command "diskutil list" without the quotes and hit return. A list of drives should show up.

     

    If the drive doesn't show up or volume information is missing, it means the OS doesn't recognize the drive's format for some reason. FWIW I have seen a bug appear in the OS once in a while where the drive doesn't show up on the desktop for some reason. I have no idea why.

  • K_Haubold Level 1 Level 1 (0 points)

    It wasn't showing up at all in Disk Utility so I knew the computer wasn't seeing the drive at all.

     

    It had been previously used (about a year ago) and then put in storage. Worked once this morning and then stopped. That's when I wrote my post on here. Strangely enough, after leaving it hooked up to the computer for about 20 minutes, it came back to life and gave me an error to the effect of 'You need to re-format this drive. You can read and copy off of it, but you can't save to it until you reformat it' (never seen that one before). So I transferred every thing off, reformatted, and it seems to be working fine (fingers crossed). Thanks for the help, every one.