0 Replies Latest reply: Apr 25, 2013 7:53 AM by sophiemarie22
sophiemarie22 Level 1 Level 1 (0 points)

hey, i attempted to download mac os 10.7 so my itues would work and now my safari wont work, is there anyway i can go back to an older verison just so i can have internet as when i go to click on safari it comes up with an error saying 'you need to download mac os version 10.7 for safari to work' i really need the internet as i have GCSE's in 17 days can anyone help me get my safari back please.


MacBook, Mac OS X (10.6.3)