Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How can I disable auto-switching desktops?

I've long appreciated the spaces/mission control feature of OS X. However, it seems more oriented to organizing desktops by application rather than by project.


Like many users, I suspect, I use different desktops for different projects, each of which requires a variety of applications (finder, word docs, spreadsheets, etc). When I'm working on project 1 in desktop 1, I never want to be whisked away to desktop 2. In fact, I never want to be switched to a different desktop automatically. If I click on an application, I want it to open a new window for that application. If a new iteration of an app can't be opened (ie, Mail), I'd like it to pull Mail to me rather than send me off to it. Aren't apps supposed to come when we call, not the other way around?


I have unchecked "...switch to a space with open windows of that application" in System Prefences, but my desktop continues to auto-switch, especially with Finder.


In short: is there a way disable auto-switching entirely? I'd like to be able to assign windows and navigate manually without being constantly pulled away from the project I'm working on.


Thanks for the help; I really appreciate people spending their time helping others on forums like this one.

OS X Mountain Lion (10.8.3)

Posted on

Reply

Apr 25, 2013 10:04 AM in response to jgl777 In response to jgl777

One thing I do is just set one Desktop as my 'Research' Desktop, so I have Desktop 1 as my 'Aperture' Desktop, Desktop 2 is for chatting with friends, and Desktop 3 is for Researching, ie opening finder windows etc, so I set what apps I frequently use to open on this particular Desktop like this..


User uploaded file


Other than that, no idea. Good luck on finding a more relevant answer.

Apr 25, 2013 10:04 AM

Reply Helpful (1)

Apr 25, 2013 10:31 AM in response to jgl777 In response to jgl777

Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


Isolating an issue by using another user account


If the problem is still there, try booting into the Safe Mode. Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.

Safe Mode


Safe Mode - About


General information.


Isolating issues in Mac OS X


Troubleshooting Permission Issues



Step by Step to Fix Your Mac

Apr 25, 2013 10:31 AM

Reply Helpful (1)
Question marked as Solved

May 1, 2013 3:05 PM in response to jgl777 In response to jgl777

I found my answer here:


http://mactips.dwhoard.com/mactips/other-applications/spaces-auto-switching


You must enter these Terminal commands:


defaults write com.apple.dock workspaces-auto-swoosh -bool NO

then restarting the Dock using the following command:

killall Dock


It says this is the solution for Leopard, but worked for me on 10.8.3


Thank you, Dr. Hoard, thank you!

May 1, 2013 3:05 PM

Reply Helpful (7)

May 20, 2013 11:53 AM in response to jgl777 In response to jgl777

I used this, but then I realized if I click on an application in the dock, the desktop will no longer auto-switch. I wish there was an in-between solution, where it wouldn't involuntarily autoswitch, but would when I want it to. To undo the change, I used the same script with a YES instead of NO:


defaults write com.apple.dock workspaces-auto-swoosh -bool YES

then restarting the Dock using the following command:

killall Dock


also using 10.8.3

May 20, 2013 11:53 AM

Reply Helpful (2)

Aug 5, 2013 12:16 PM in response to jgl777 In response to jgl777

There's a easier solution (if I'm reading the OP's post correctly).

Go to System Preferences/Mission Control and uncheck the box that says "When swithching applications, switch to another space with open windows for that application."


J.


User uploaded file


P.S. I'm running 10.8.4

Aug 5, 2013 12:16 PM

Reply Helpful (3)

Aug 5, 2013 12:54 PM in response to jaybe1021 In response to jaybe1021

I agree that I wish there were an in-between solution.


E.g. click on app:

- If the app is running with no windows open in any desktop, open new window

- If the app is running with window(s) open in other desktop, either (and the option would be nice) move most recently used window to current desktop, or open new window.


Also, it'd be nice to have a "send back" feature, like minimze but instead of sending it to the dock, send it to the desktop whence it came. E.g., if you're running Spotify and just want to change the song or something, click on it in the dock, the app window zips to current desktop, click it again (or a hotkey) and it zips back to the desktop where it was before.


I can understand switching desktops if you're switching projects, but I can't understand it as default functionality; it's like moving your desk chair in front of the paper you want instead of just reaching over and picking up the paper.

Aug 5, 2013 12:54 PM

Reply Helpful

Jul 29, 2015 9:59 PM in response to jgl777 In response to jgl777

Oh man. A thousand thanks! I am elated to find a solution. The switching is so annoying. Defeats the purpose of space entirely in my opinion but Apple acts like it is a helpful feature and the ostensible setting for it does nothing to stop the switching or if it actually works like it is supposed toopens a new iteration of a program off screen in another space. In other words both useless options.

Jul 29, 2015 9:59 PM

Reply Helpful

Mar 19, 2017 9:10 AM in response to jgl777 In response to jgl777

Thank you for this. But now the problem is that when you click on an icon in the Dock it won't take you to that app and when you have a lot of things open across different desktops it sometimes is hard to find the app you're looking for.

My problem with auto-switch was that when I had multiple windows of e.g. Adobe Pro (I'm a proofreader and do a lot of markup in pdfs, and will usually have 3 windows of the same document open so I can easily swipe back and forth between pdf:1, pdf:2 and so on, and then a couple other supporting documents open in Adobe in other desktops). Sometimes as I try to swipe e.g. from Desktop5 to Desktop1, even though I'm doing anything else, just swiping across screen, I keep being thrown back to one of those Desktops. So I get to D1 and before I can scroll down a page in D1, I'm suddenly at D5 -- which is not even necessarily another window of the same document!

Using those commands was helpful with that. But then when I have a dictionary open somewhere underneath one of 3 Browser windows, underneath sticky notes, say, in D6, I want to be able to just click on the Dictionary icon in the Dock and be taken there.

Is there a way to have both? That is, prevent iOS from automatically swiping me (god knows why!) to another Desktop (it feels like you're struggling against current, you swipe one way the computer is swiping the other! -- very frustrating) BUT allow to be taken to the corresponding desktop when you click on an icon in the Dock?

As is, I can't decide what is more annoying: looking for the app I "lost" somewhere in one of the Desktops (it's especially annoying when what you're looking for is a dialog window!) or getting swiped automatically because iOS seems to know better than I do which portion of the document I want to look at!


IF anyone needs to reverse the command, I simply replaced NO with YES, and followed with the "killall Dock" command.


I hope someone can find a solution to this! A more complex command?

Mar 19, 2017 9:10 AM

Reply Helpful

Jun 15, 2017 12:33 PM in response to jaybe1021 In response to jaybe1021

For me clicking a dock button twice switches desktops. I have a different problem with this option with Mission Control App Window display: clicking a window there no longer switches desktops, but I can live with this because application switching is so bad with this option. The actual problem here for me is that application switch focuses a seemingly arbitrary window. If application switch always focused the most recently focused window I would have no problem with auto workspace switching.


I'm using 10.12.4

Jun 15, 2017 12:33 PM

Reply Helpful
User profile for user: jgl777

Question: How can I disable auto-switching desktops?