3 Replies Latest reply: Apr 5, 2014 1:35 PM by Don H.
Jasper5150 Level 1 Level 1 (0 points)

Keep getting pop ups for invalid certificates for google, facebook, etc.  How can I fix this.  Very annoying.


Mac mini, iOS 6.1.3
  • Linc Davis Level 10 Level 10 (159,195 points)

    Take each of the following steps that you haven't already tried. Stop when the problem is resolved.

     

    1. Are the current date (including the year) and time shown on your system clock? If not, correct them and test.

      

    2. Check that the following files exist:

     

    • /System/Library/Keychains/SystemCACertificates.keychain
    • /System/Library/Keychains/SystemRootCertificates.keychain

     

    If they don't, restore them from a backup or reinstall OS X after backing up all data.

      

    3. Disable any third-party firewall, "security" software, or network filter. Test.

     

    4. In some versions of OS X, Parental Controls has a bug that prevents loading of secure websites. Turn it off.

     

    5. The process by which OS X checks the validity of root SSL certificates doesn't work behind the authenticating SOCKS proxies used on some enterprise networks. If applicable, contact your network administrator. The proxy server may need to have its settings changed.

     

    6. Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Activity Monitor in the icon grid.

     

    Select All Processes from the menu in the toolbar of the Activity Monitor window, if not already selected. Enter "ocspd" (without the quotes) in the "Filter" text field. Is a process with that name listed?

     

    If not, back up all data, then select

     

    Go Go to Folder

      

    from the Finder menu bar. Into the text box that opens, copy the following line of text:

     

    /var/db/crls

     

    From the folder that opens, move these two files to the Trash:

     

    • crlcache.db
    • ocspcache.db

     

    You’ll be prompted for your administrator password. Reboot, empty the Trash, and test.

  • kjmessner Level 1 Level 1 (0 points)

    Thank you!  This issue has been a real pain for me -your resolution worked perfectly.

  • Don H. Level 1 Level 1 (105 points)

    This worked for me as well, but I would note one difference.  When I searched for "ocspd" in the Activity Monitor filter, I did find a process of that name.  I took the risk, however, and continued with the instructions, locating and Trashing the two files noted:  crlcache.db and ocspcache.db.  That solved my problem, and thus far, does not seem to have added any new problems.

     

    Thanks!