2 Replies Latest reply: Apr 25, 2013 7:26 PM by AnaMusic
truck4life Level 1 (0 points)

I have  software Mac OS X 10.5.8  on my IMac with Intel Core, and 10.5.8 on my Mac Book Pro. I can't do any IPad mini or ITunes updates because I am told to download "updates". However, both of my computers tell me I am up to date. Should I buy the upgrade Leopard?

Mac OS X (10.5.8)