6 Replies Latest reply: Apr 26, 2013 2:43 PM by Eustace Mendis
rshorts Level 1 Level 1 (0 points)

Hi there,

 

First time poster, long time lurker.

 

I am attempting to upgrage the OS of my Mac Pro running 10.6.8 Snow Leopard.

 

3.33GHz 6-Core Interl Xeon

 

Having skipped Lion, I have downloaded Mountain Lion from the App Store.

 

During the install I recieved the following error:

 

http://cl.ly/image/2X2J0i402M0b

OSX cannot be installed because a recovery system can't be created.

 

All posts on this forum lead me to the following article:

 

http://support.apple.com/kb/TS3926

 

Yet when I tried to resize my HD, Disk Utility spat up the following message:

 

http://cl.ly/image/0B0D0s0h2h2g

Partition failed with error:

This operation requires a newer version of Mac OSX for this disk.

 

So now as you can see I'm stuck in a loop.

 

In order to perform the action I need to upgrade the os my os needs to be upgraded.

 

Please somebody help me!

 

Furthermore, the disc has never been partitioned & I've never run boot camp.


Mac Pro, Mac OS X (10.6.8)
  • Barney-15E Level 8 Level 8 (40,945 points)

    I think the only way to fix that is reformat the drive. .

    Save the Mountain Lion installer somewhere so you don't have to re-download.

     

    Back it up and then repartition the entire drive booting from your Snow Leopard install disk

    Once in the installer, select Disk Utility from the Utilities menu.

    Select the drive (not Macintosh HD)

    Select Partition tab

    Set it to 1 partition

    Select Options...

    Set it to GUID partition table and click ok

    Set the format to Mac OS Extended (Journaled)

    Set the volume name

    Click Apply

     

    Quit Disk utility and install Snow Leopard

    Updated to 10.6.8 and try again.

  • rshorts Level 1 Level 1 (0 points)

    Thank you for your swift reply Barney

     

    So, if I'm understanding you correctly, you are suggesting I reinstall Snow Leopard in order to upgrade to Mountain Lion?

     

    But if I'm still in Snow Leopard after a lengthy backup & reinstall wouldn't I get the "This operation requires a newer version of Mac OSX for this disk." yet again? And if not how so?

  • Barney-15E Level 8 Level 8 (40,945 points)

    You shouldn't. I'm talking the whole drive. You tried to resize the partition, which is a different process from formatting the entire drive.

     

    There is something wrong with the Disk structure that is preventing the ML installer from adding the recovery partition. My theory is if you fix that problem by reformatting it, it may work correctly.

     

    You could also just try repairing the disk in Disk Utility from the Snow Leopard install disk.

  • rshorts Level 1 Level 1 (0 points)

    OKay I repaired permissions (there were some conflictions)

    I repaired disc but it said the volume was okay.

     

    So I tried again.

     

    This time the installer popped up a warning:

     

    Some features are not available on this disc:

    http://support.apple.com/kb/HT4649

     

    I found the above post.

     

    I do believe that my mac once had been set up for raid (I have an additional 6tb of internal storage)

     

    I bought it used, so I installed from scratch. I didn't set it up for raid as I have no idea how to.

     

    Reading the above artice, I figure I can live without the features it lacks and proceeded with the install.

     

    AGAIN it gave me the OSX cannot be installed because a recovery system can't be created.

     

    But acording to Disc Utility the disc is fine.

  • rshorts Level 1 Level 1 (0 points)

    Me again,

     

    Okay, so I made a Time Machine backup of the drive ready to do a clean erase & install of SL and then in turn upgrade to ML.

     

    I am unable to boot from my Retail SL disc. It just hangs on a grey screen with an apple logo in the centre (where there is usually a spinning animation beneath) No spinning animation appears and the screen hangs indefinitely.

     

    What can I do next?

     

    I am really at a loss with this.

  • Eustace Mendis Level 7 Level 7 (25,315 points)

    Put the SL disk in and try holding the Option key down while restarting.