4 Replies Latest reply: Jun 25, 2013 11:19 AM by Old Toad
JEH-IT Level 1 Level 1 (0 points)

I recently had to reinstall Mountain Lion (10.8.3) on my Macbook Pro (4,1) and now Photo Stream is not working. At first I found out that Photo Stream was not turned on in on my System Preferences. But once I did turn it on, iPhoto (9.4.3) would sometimes say that it was downloading, but then nothing would download. I have tried turning off and on Photo Stream in system Preferences and quitting and reopening iPhoto. I am using the iPhoto library from my backup, but I don't know if that has anything to do with it.


MacBook Pro (15-inch Early 2008), OS X Mountain Lion (10.8.3)
  • pvonk Level 6 Level 6 (13,695 points)

    Photos are kept on the photo stream servers for up to 30 days, and only a max of 1000.  When a computer or device is connected to photo stream, it will keep photos there, even when they are no longer available on the servers.  If you turn off photo stream, then turn it on again, you will then get only those photos still on the servers.  All others will have been deleted of the device.

     

    IMPORTANT...

     

    Photos should be regularly synced to a computer (like you store photos from a digital camera) using either USB via iTunes (on a mac use iPhoto or Aperture to move them to an album) or using photo stream - and then moved into permanent albums for storage.  If using Photo stream, but sure to move the received photos to a permanent album.  If you have been doing that, then you can sync those photos back to your device.

  • JEH-IT Level 1 Level 1 (0 points)

    One more note: My shared photo stream downloaded (well 4/10 of it), but not my regular photo stream. Also, once I was able to get two photos to download, but I know that is not all that I had taken in the past 30 days. Essentially iPhoto will say "downloading __ photos" but nothing will ever download. This is all I ever see now. A couple days ago, the number up ontop was 377. I cannot figure out what is going on.Screen Shot 2013-04-28 at 2.44.11 PM.png

  • ncoult Level 1 Level 1 (0 points)

    I am having the same problem.  iPhoto photostream shows "downloading 55 photos" but no photos ever download.  I've tried turning off icloud and turning it back on on my mac, and that didn't help.  I have photos from my iPad photostream that are just a few days old so they haven't expired.  Did you ever get anywhere on this problem?

  • Old Toad Level 10 Level 10 (121,415 points)

    As a test launch iPhoto with the Option key held down and create a new, test library.  Import some photos and test to see if the same problem persists. Does it?

     

    If it doesn't and you are able to download successfully into the new library then your existing library needs repairs: apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iP93rebuild.PNG

    Since only one option can be run at a time start

    with Option #4 and then #1 as needed.

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

    1 - download iPhoto Library Manager and launch.

     

    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.

     

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.

     

    4 - In the next  window name the new library and select the location you want it to be placed.

     

    5 - Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost and converted to albums. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

     

     

    OT