Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 Hi, I'm having some real issues updating my itunes to the latest version. It keeps saying I need 10.6.8 or later. I keep trying to update my OS X too but It never works!!!!!

191 Views 2 Replies Latest reply: Apr 28, 2013 11:06 AM by Kappy RSS
Hitcher83 Calculating status...
Currently Being Moderated
Apr 28, 2013 11:04 AM

I just cannot seem to update my Mac

 

I have an iphone 5 and I would like to update it. But everytime I download a newer version of itunes it says it does not work

 

I look for updates on mac os x and itunes and it says everything is up to date when I know that to be false. I have no idea how to resolve this. I dont have snow leopard (or maybe I do as it says 10.5.8) but all I want to do is have an up to date mac book with up to date itunes!

itunes

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.