Previous 1 2 3 Next 32 Replies Latest reply: Jun 13, 2013 11:16 PM by léonie Go to original post
  • léonie Level 10 (90,604 points)

    The reason why I renamed the Aperture Library was to trick Aperture and force the app to create a brand new Library as default. I rather rename files than send them temporarily to the trash can... I may empty the bin accidentally and regret for ever .


    Renaming your library can be problematic, if you are using Time Machine for backups. The next backup will have to rewrite the whole library copy. The best way to create a new library is to launch Aperture with the ⌥-key held down and to use the "other/new" option from the panel that will pop up.

  • omancini Level 1 (0 points)

    Thanks I do not use Time Machine at this time, all the backup is handled by Carbon Copy Cloner for different reasons. I get your advise about how to start Aperture, will try it also after testing the other options I could catch during this exchange.



  • omancini Level 1 (0 points)

    I requested Aperture to repair the Database, toke a while, after finishing the process the "Opening Aperture Library" message appeared again. No improvement.


    I hope the attached image is available for everyone, it shows that the Aperture Menu is available while the application tries to open the Library. From there I can quit the program normally.


    Screen Shot 2013-04-29 at 3.40.13 PM.png

    I will try using a different user now. Thanks

  • omancini Level 1 (0 points)

    When I quit the program the "updating information for sharing previews" message appears, the the application closes normally.


    Screen Shot 2013-04-29 at 3.43.16 PM.png

  • omancini Level 1 (0 points)

    Created a new user and tried to open Aperture from that profile, same result. The screen shot shows I can access the preferences while the program tries to open the Library. Nothing changed. I will review the entire forum again in order to see if I am missing something here. Thanks


    Screen Shot 2013-04-29 at 3.54.00 PM.png

  • omancini Level 1 (0 points)

    In order to save some time to the readers, to the previous reply I must add that Aperture is trying to open the default Library that is created while it opens the first time not the one I use.


    I tried to open the original 70 GB Library without no positive result either.



  • léonie Level 10 (90,604 points)

    Since it is the same in all accounts, and since you already reinstalled Aperture, I'd reinstall the system.


    If the Client Combo (OS X Lion Update 10.7.5 (Client Combo)) does not suffice, try the recovery:


    OS X: About OS X Recovery

  • omancini Level 1 (0 points)

    Thank for the advice but it seems to me that is too much. All the other applications in the same machine are working well, including iTunes with a similar amount of information on its Library. The only problem is this one and happened after an upgrade of a single program, what if with all the time and pain that comes after the system restoral nothing changes?


    I consider that if I have to install the whole system again because of this behaviour that results from the upgrade then Apple has to look better to what they are doing. I already mentioned to them with all the flaws that I found in the new iTunes versions.


    Sorry if I sound not collaborative, I really apreciate all the time that all the people is assigning to this discussion but I really cannot take that step.



  • omancini Level 1 (0 points)

    I was able to open the 70.24 GB Library using iPhoto 11 (9.4.3) so it seems that the Library is not the problem. I will see if I can figure out something else and will share my findings.



  • firstlaunch Level 3 (620 points)

    Since you were able to open the library in iPhoto, I suggest trying to re-open that same library back in Aperture. It's possible that it will open now after beign opened in iPhoto.

  • omancini Level 1 (0 points)

    After been able to open the Library succesfully with iPhoto I tried to open it with Aperture but unfortunately there is no fix to the original problem.


    After the previous step initiated Aperture holding the OPTION Key, chose to use a new Library but no change.


    Now I am going to erase Aperture completely with AppDelete in order to be sure that everycomponent is removed and will install the application again. Before that will place the Library in a safe place.


    Thanks for your support

  • omancini Level 1 (0 points)

    So far:


    a. I removed the application and its associated directories from the hard drive using AppDelete.

    b. Renamed the original Aperture Library in order to allow the fresh installation to start from scratch with a new Library.

    c. Installed Aperture 3, and started the application without any problem.

    d. Closed the program and run a Software Update in order to update to 3.4.4

    e. After the update was completed opened Aperture again, now it requested to update the Library that was created automatically on step "c". Program opened normally after the Library update was completed.

    f. Closed the program again, sent to the trash the recently created Library and renamed the original 70.24 GB Library to the original name.

    g. Started Aperture again and now is working...


    I closed and started the program 4 times in a row and it seems to work consistently.


    Thanks for your support.

  • omancini Level 1 (0 points)

    I was going to work with my photos and now the very same problem appeared, I simply cannot believe how unstable this program is since the last update... I simply cannot afford waste more time with this program.

  • Ironman70 Level 1 (0 points)

    I have exactly the same problem, and have tried all of thes steps above with the same result. 


    Aperture hangs on trying to open my library although the menu bar is active.  Have tried all three aperture repair options without any success. 


    Just wondering if anyone has found a solution to this yet (or if Apple have recognised they have a problem with A3.4.4)?

  • omancini Level 1 (0 points)

    Hello, right after my last post I was contacted by AppleSupport in order to work on this issue together. I ended sending them some information from the Aperture program I have installed. So far there is no information regarding their progress, last e-mail from them was received a couple of weeks ago. I hope they find a way to fix this. So far Aperture is not working although I keep trying opening everyother they hoping that I can at least work with some pendings I have there.


    I will notify in this discussion if there is a solution that was found but based on the number of people that is experiencing this very same issue I suspect an new release may be the proper path.