12 Replies Latest reply: Jul 7, 2013 8:33 AM by iDenniNL
iDenniNL Level 1 Level 1 (0 points)

Hi,

 

I have a iMac(iMac9,1) here which experiences some boot problems. If you try to boot "normally" it just sais "No bootable device". Keycode's don't work so I imagened that the firmware password was active. And indeed; holding the option key gets me to a password an after that a screen where I can choose where to boot from.

 

If I start from the harddisk, most of the time Mac OS X starts. But it takes a very long time and the performance after starting isn't that great either. I repaired the harddisk using the disk utility on the Mac OS X DVD and tried to delete the firmware password(so I could try to reset the NVRAM at startup). But it just doesn't reset, althought it should(I even couldn't change the password while starting from the DVD). That seemed very odd.

 

By the way; using the startup disk utility gets me nowhere either.

 

Also if I reinstalled Mac OS X, it would do fine until the very end, where I got an error. The installation works but with the same boot problems.

 

Since the "no bootable device"-problem seems to be a Windows problem, I tried to recreate a windows partition so I could after that delete it again. But opening the bootcamp assistent just gives me an error saying that I need to update my ROM-software, which I can't update because it has the newest version already.

 

Is there any way to just reset the EFI?(there is no firmware restoration disk for this mac)

 

I hope someone can help!

 

Regards,

 

Dennis


iMac
  • BDAqua Level 10 Level 10 (119,865 points)

    Hi, is this 10.6.x, or later?

     

    Once started can you make a new admin user?

     

    To find out if it's system wide or user specific, try this...

    Open System Preferences>Accounts, unlock the lock, click on the little plus icon, make a new admin account, log out & into the new account.

    Does it work in the new account?

     

    To find out if it's system wide or user specific in 10.7+, try this...

     

    Open System Preferences>Users & Groups, unlock the lock, click on the little plus icon, make a new admin account, log out & into the new account.

     

    Does it work in the new account?

  • iDenniNL Level 1 Level 1 (0 points)

    At the moment I installed 10.5.x, but 10.6.x was installed before these problems. I reinstalled Mac OS X 10.5.

     

    I don't think this is user specific, because it's really the firmware password. I can edit the user passwords with the startup disk. But editing the firmware password just doesn't work.

  • BDAqua Level 10 Level 10 (119,865 points)

    How did you get a new OSX installed if no startup keys work???

     

    Well, there was an old way to get around that, but Apple changed sometime in the past, still I'll give you the old way...

     

    Firmware password protection in Mac OS X ...

     

    http://support.apple.com/kb/HT1352

     

    It would block usage of all the startup keys, like C, N, T, D, CMD+s, CMD+Option+p+r, CMD +v, Option boot will show a lock, and Shift, as well as booting from anything but the Hard Drive.

     

    Force Removing Password Protection

     

    1) Add or remove DIMMs to change the total amount of RAM in the computer.

     

    2) Then, the PRAM must be reset 3 times. (Command + Option + P + R).

     

    http://www.securemac.com/openfirmwarepasswordprotection.php

  • iDenniNL Level 1 Level 1 (0 points)

    I can boot using the option key and then selecting the Mac OS X drive.

     

    I tried doing that but it didn't seem to work. I removed one of the DIMMs and then started up pressing command + option + P + R, but it didn't do anything. It just "works" like it did(only the option key seems to work).

     

    Can I try it again by just putting the DIMM back in, so the RAM will change again?

  • BDAqua Level 10 Level 10 (119,865 points)

    Well, did you do 3 PRAM Rests in a Row?

  • iDenniNL Level 1 Level 1 (0 points)

    I tried but it didn't do anything(it should "bong" again but it didn't).

  • BDAqua Level 10 Level 10 (119,865 points)

    "Try Disk Utility

     

    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair Disk, (not Repair Permissions). Disk Utility checks and repairs the disk."

     

    http://docs.info.apple.com/article.html?artnum=106214

     

    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)

     

    If perchance you can't find your install Disc, at least try it from the Safe Boot part onward.

     

    If that doesn't help Reinstall the OS.

  • iDenniNL Level 1 Level 1 (0 points)

    I tried the Install disc-part already. It repaired some issues but that didn't solve my problem. I will try the safe-boot part tomorrow. Can I enter safe boot mode with the firmware password activated?

     

    Reinstalling the OS did not work, as I already mentioned.

     

    Thanks for your help (attempts) so far

  • iDenniNL Level 1 Level 1 (0 points)

    Ok I tried this;

    - starting up while holding down the shift key. This didn't work. It just tried to boot and showed the "no bootable device"-message again.

    - Starting up while holding down the option key. After that trying to boot the HDD while holding down the shift key. This just resulted in a normal startup.

    - I tried repairing the disk again using the Mac OS X disc.

     

    The PRAM reset still doesn't work. It just goes to the "no bootable device" screen..

  • BDAqua Level 10 Level 10 (119,865 points)

    Well, I'm suspecting a hardware problem after all this.

     

    Boot off your *original* Install Disk while holding down the *d key*, (not c key), then run the extended Apple Hardware Test. Some disks require you to use the Option key at bootup to select AHT. Some Discs have it inexplicably on Disc #2. Some models have a separate AHT CD.

  • iDenniNL Level 1 Level 1 (0 points)

    Ok I tried it. But I can't open the hardware test because booting while holding down the d-key doesn't work. I can't boot from the AHT-disk.

     

    I tried using the bless-command in command line. It told me that it can't access the NVRAM. So I think I know what is wrong now. But I have no idea how to fix it.

     

    I think the NVRAM is corrupted. Normally you would try to reset it, if not for the firmware password still activated. But since the NVRAM is corrupted I cannot delete that password. Because of the corrupt NVRAM the iMac also still tries to use bootcamp and I can't disable that.

     

    So is there another way to reset the NVRAM? Is there a battery inside which I can remove for a few seconds so it resets?

  • iDenniNL Level 1 Level 1 (0 points)

    Ok I am still stuck. I opened up the IMac today, and removed the battery for a few minutes so the NVRAM would reset. It did not reset the firmware password! So I still can't do most things. Is there any other way to remove the firmware password? I still get the no bootable device message and the iMac is still awefully slow..