3 Replies Latest reply: Apr 29, 2013 3:27 AM by Glynn Williams
Glynn Williams Level 1 Level 1 (5 points)

Hi

 

I'm having issues with TextEdit. It opens documents, even ones I've created in TextEdit, with the code viewable:

 

{\rtf1\ansi\margt1000\margb1000{\fonttbl{\f0\fcharset0 Arial;}{\f1\fnil\fcharset2 Symbol;}}\fs24\pard\ql\li6480 Glynn Williams\par

 

Can anyone explain why it does this?

 

As I said, even if the file was created TextEdit, when I next open it it comes in like this (i.e. containing "\par\pard\par\ql" etc.)

 

Is getting rather annoying now.

 

Any help would be appreciated.

 

Cheers

G


G5 1.6Ghz, Mac OS X (10.3.9), Own 2 Mac Mini's (intel 1.6Ghz Combo) and a Samsung Laptop
  • Glynn Williams Level 1 Level 1 (5 points)

    OK. Resolved this myself!

     

    In the preferences, for some reason by default, under "Open and Save" is "When Opening a File:" the tick box for "Display RTF files as RTF code instead of formatted text" is ticked. Not sure why one would want to see the code by default. Untocking this has worked.

     

    G

  • petermac87 Level 5 Level 5 (6,505 points)

    Glynn Williams wrote:

     

    Not sure why one would want to see the code by default. Untocking this has worked.

     

    G

    It is not set to see the code by default. Somehow it has changed itself, perhaps through some other third party install? All my Macs are set by default to show as text.

     

    Anyway, glad you got it all sorted.

     

    Cheers

     

    Pete

  • Glynn Williams Level 1 Level 1 (5 points)

    Hi Pete

     

    Thanks for the comment.

     

    Must be, as you say, a 3rd party, as I know I didn't set any preferences for TextEdit. Would be interesting to find out which one did it, but have WAY too many to uninstall and find out

     

    Hopefully if anyone else has an issue with files showing the code, they now know they simply need to untick this box.

     

    Cheers

    G