13 Replies Latest reply: May 1, 2013 10:04 AM by Timbro69
fl2 Level 1 (0 points)

I upgraded from 10.4.11 to 10.5.0 using a drop in DVD and now I can't log in...

 

This was on a G5 imac. I tried booting to the DVD and resetting the password but this did not help.

I did see the 2 user accounts still there when I reset the password so that gives me hope that my data is all there intact.

 

I need help getting past this login screen PLEASE!    

The login name is blank and I've tried everything to get past it.

 

I heard from a tech that there was a problem when upgrading from 10.4.11 to 10.5.0 instead of the 10.5.3 or whatever, and it was a known issue when using the 10.5.0 disc to upgrade and he said that there was information on apple's site on what to do when this happens but I have not come accross this info as of yet.

 

I would really appreciate any help anyone can give me.

 

Thanks!!!

 

Tim

  • Niel Level 10 (298,723 points)

    Click here and follow the instructions.

     

    (81824)

  • Timbro69 Level 1 (0 points)

    After I perform step 3 under "If you are unable to log in"

    it says: -sh: Launchct1: command not found

    :/ root#

    So now I'm stuck again :-(

  • Niel Level 10 (298,723 points)

    It's launchctl with a lowercase L at the end, not an i or 1.

     

    (81831)

  • Timbro69 Level 1 (0 points)

    Oops, ok my bad.... but....

    Now after performing step 8 and 9 it says.

     

    delete: Invalid Path

    <dscl_cmd> DS Error: -14099 (eDSUnknownNodeName)

    :/ root#

     

    Now I had already gone in and tried resetting the password while booted to the DVD and in utilities. Would that affect this at all?

  • Timbro69 Level 1 (0 points)

    Niel, thank you for your quick replies by the way. I hate when these things take days to get through because of slow response times.

  • Timbro69 Level 1 (0 points)

    OK I finally got passed the above problem by just trying to type it in over and over and over and it finally took!

     

    It seems as though I may have typed it wrong or misspelled something but I could swear I put it in the same way everytime!

     

    NOW...

     

    when I type : passwd username

    replacing username with the short name it says

    paddwd: Unknown user name 'username'

     

    someone told me that possibly the home folder is still there and intact but the login may have gotten trashed and that i may need to recreate the user login. Does that sound like a possibility?

  • Timbro69 Level 1 (0 points)

    I suppose now I need instructions on how to recreate the user account that possibly got trashed. So I don't know if that would be a whole other process to do then I would come back to this one or if I could do it right in this single user mode???

  • Niel Level 10 (298,723 points)

    Yes, it does. If you're able to log into any administrator account on the machine, you can select the home folder, choose Get Info from the File menu, and give yourself write access in the Sharing & Permissions section.

     

    (81835)

  • Timbro69 Level 1 (0 points)

    I can't get passed the login screen of either user account throught the normal way of logging in or are you speaking of doing it in this DOS type mode?

  • Niel Level 10 (298,723 points)

    Click here, use the instructions to enable the root user, log in as root, and then use the Accounts pane of System Preferences to create an administrator account.

     

    (81836)

  • Timbro69 Level 1 (0 points)

    Clicked the link above and followed all the steps and it still will not let me login and just acts like I am entering the wrong password

  • Timbro69 Level 1 (0 points)

    I did see that all the data was there when I booted from a network so that's good. I just gotta get passed this login problem.

  • Timbro69 Level 1 (0 points)

    The hard drive is failing I found out so that could be a huge part of the problem other than instsalling from 10.5.0 instead of 10.5.6