6 Replies Latest reply: Dec 3, 2013 6:49 PM by ObsoleteMan
PThody Level 1 Level 1 (0 points)

OS 10.8.3 - Mail 6.3 - MacBook Pro

Mail is POP in, SMTP out.

 

Title says it all. 48 hours ago Mail stopped downloading messages. Click Get Mail and the Mail Activity panel (bottom left) states 'Incoming messages 14 of 14', but nothing arrives. Sending works fine.

 

Mail also continues to work fine on office iMac and personal iPhone (all same email account).

 

  • Is there a preference I could delete to refresh things?
  • If not, can I re-load Mail on this machine without affecting things elsewhere?

 

Connection Doctor says:

 

Screen Shot 2013-04-29 at 20.11.06.png


MacBook Pro
  • PThody Level 1 Level 1 (0 points)

    Thanks but before posting here I spent 90 minutes on a call with my Email Service Provider checking that all settings were as they should be. They - and the two green lights on Mail Connection Doctor - confirmed that all was as it should be in that respect.

  • PThody Level 1 Level 1 (0 points)

    Just to clarify the above: my email settings and connection are fine but the main problem - the inabiliuty to collect mail - remains.

     

     

  • klbro8 Level 1 Level 1 (0 points)

    Sorry PThody no help to your issue,

     

    I have the same problem i have only just started using mail it worked fine for the first few days and yesterday it stopped working for one of my accounts. I ended up deleating the offending account and readding the account. After this it worked as normal.

     

    Now this morning the same account is not working. The two accounts are both Yahoo accounts and i have no problem accessing them via my Iphone. Any idears?

  • PThody Level 1 Level 1 (0 points)

    Hi there - I did eventually resolve my problem by narrowing things down. Deleted account and set up fresh: no change. Gave up on Mail and installed Thunderbird ... which failed in exactly the same way ... so not a software problem at all.

     

    What worked for me was to click the tiny 'cog' icon at the bottom left of the Mail window and select 'Get account info'.

     

    Screen Shot.jpg

     

    Looking through the mail still sitting on the server, I found one message with a 25 MB attachment. This came through ok on my office account and was also fine on the iPhone (presumably because that ignores such large attachments). But my home account was trying and failing to download it,  creating a bottleneck that prevented Mail from downloading anything else.

     

    Solution? Select the offending mail and 'Remove From Server'.

     

    Yours may be an entirely different issue but this worked for me.

  • ObsoleteMan Level 1 Level 1 (10 points)

    I had the same problem, your solution worked for me too.

     

    Mike