5 Replies Latest reply: Apr 30, 2013 3:13 PM by Barney-15E
NN2RL Level 1 (5 points)

I have a strange situation when trying to send pics from iPhoto through Mac Mail.  Sometimes a new email message is generated perfectly with my imbedded pic and sometimes it opens a blank email where a photo should be but is not. When I run Repair Disc Permissions I usually get the following:


Repairing permissions for “Macintosh HD”

User differs on “.DS_Store”; should be 0; user is 502.

Permissions differ on “.DS_Store”; should be -rw-rw-r-- ; they are -rw-r--r-- .

Repaired “.DS_Store”

Group differs on “Library/Preferences/com.apple.alf.plist”; should be 80; group is 0.

Repaired “Library/Preferences/com.apple.alf.plist”


Permissions repair complete


After this repair, my pictures are imbedded in the email they way I expected them to be. Does anyone know why this particular problem returns and how I am able to 'cure' the problem?


Thanks in advance.

iMac, OS X Mountain Lion, 24 inch, Early 2009
  • Barney-15E Level 8 (45,240 points)

    There's a .DS_Store in every folder that has its view settings altered. The ones inside your home folder should be owned by you (ID > 500), but any ones outside of your home will likely be owned by root (id=0).


    Do you have your iPhoto Library located somewhere outside of your Home folder?

  • NN2RL Level 1 (5 points)

    Hi Barney!  No, I do not.  My iPhoto Library is located inside my Home folder. 


    This identical problem occurs on my home iMac as well, running Mountain Lion with all the updates with iPhoto and Aperature on both machines as well.

  • Barney-15E Level 8 (45,240 points)

    Same thing on two Macs leads me to ask if you have installed any third-party software that would affect the Finder, or iPhoto/Aperture?


    To troubleshoot if it is some piece of software, try booting into Safe Mode and see if you experience the problem.


    Does it state where it is finding that .DS_Store file? That may be just a red herring, though.

  • NN2RL Level 1 (5 points)

    I am not aware of any 3rd party software that I may have -- I stick with Apple products for compatability etc.


    My problem is intermittent so booting in safe mode isn't going to show us much I'm afraid...the problem just randomly appears and is really quite unpredictable. The only time I see it pop up is when I go to send an email of a photo I want to share. Strange, huh?


    I sent you the entire Permissions Repair info as received when I ran the utility. I have no clue what it means.

  • Barney-15E Level 8 (45,240 points)

    Intermittent things like that are tough to track down.


    Just to see if it is a red herring, the next time you successfully attach a picture, run repair permissions and see if it shows up. If it is there when you had succes, it likely isn't the cause and we're just chasing our tail.


    If that file is showing up inside the iPhoto Library, it could be the problem.


    There is a glitch where you can't see the default user pictures in the dialog when you change yours. Deleting the .DS_Store file in the /Library/User Pictures folder fixes it.


    Do you ever go browsing around in the iPhoto Library folder structure?